summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-02-28 08:27:12 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-02-28 08:27:12 +0000
commitb9eeb75ddacc10f4457307aeed8ab390239aa654 (patch)
treec337f5b3f947f97f209778cad2471645528236ea /dev-lang/pike
parentstable x86, security bug 198644 (diff)
downloadgentoo-2-b9eeb75ddacc10f4457307aeed8ab390239aa654.tar.gz
gentoo-2-b9eeb75ddacc10f4457307aeed8ab390239aa654.tar.bz2
gentoo-2-b9eeb75ddacc10f4457307aeed8ab390239aa654.zip
Adding new version.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/pike')
-rw-r--r--dev-lang/pike/ChangeLog9
-rw-r--r--dev-lang/pike/pike-7.6.112.ebuild98
-rw-r--r--dev-lang/pike/pike-7.6.86-r1.ebuild4
3 files changed, 107 insertions, 4 deletions
diff --git a/dev-lang/pike/ChangeLog b/dev-lang/pike/ChangeLog
index e622ec1220e7..8abfce82646a 100644
--- a/dev-lang/pike/ChangeLog
+++ b/dev-lang/pike/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/pike
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.31 2007/07/31 12:56:32 uberlord Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.32 2008/02/28 08:27:12 araujo Exp $
+
+*pike-7.6.112 (28 Feb 2008)
+
+ 28 Feb 2008; Luis F. Araujo <araujo@gentoo.org +pike-7.6.112.ebuild:
+ Adding new version
31 Jul 2007; Roy Marples <uberlord@gentoo.org> pike-7.6.86-r1.ebuild:
Keyworded ~x86-fbsd
diff --git a/dev-lang/pike/pike-7.6.112.ebuild b/dev-lang/pike/pike-7.6.112.ebuild
new file mode 100644
index 000000000000..136aff6eecd1
--- /dev/null
+++ b/dev-lang/pike/pike-7.6.112.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.112.ebuild,v 1.1 2008/02/28 08:27:12 araujo Exp $
+
+DESCRIPTION="Pike programming language and runtime"
+HOMEPAGE="http://pike.ida.liu.se/"
+SRC_URI="http://pike.ida.liu.se/pub/pike/all/${PV}/Pike-v${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="bzip2 debug doc fftw gdbm gtk hardened jpeg kerberos mime mysql opengl pcre pdf scanner sdl ssl svg tiff truetype zlib"
+
+DEPEND="dev-libs/nettle
+ dev-libs/gmp
+ media-libs/giflib
+ bzip2? ( app-arch/bzip2 )
+ fftw? ( sci-libs/fftw )
+ gdbm? ( sys-libs/gdbm )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ jpeg? ( media-libs/jpeg )
+ kerberos? ( virtual/krb5 )
+ mysql? ( virtual/mysql )
+ opengl? ( virtual/opengl virtual/glut )
+ pcre? ( dev-libs/libpcre )
+ pdf? ( media-libs/pdflib )
+ !x86-fbsd? ( scanner? ( media-gfx/sane-backends ) )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer )
+ ssl? ( dev-libs/openssl )
+ svg? ( gnome-base/librsvg )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=""
+
+S=${WORKDIR}/Pike-v${PV}
+
+src_compile() {
+ local myconf=""
+ # ffmpeg is broken atm #110136
+ myconf="${myconf} --without-_Ffmpeg"
+ # on hardened, disable runtime-generated code
+ # otherwise let configure work it out for itself
+ use hardened && myconf="${myconf} --without-machine-code"
+
+ make \
+ CONFIGUREARGS=" \
+ --prefix=/usr \
+ --disable-make_conf \
+ --disable-noopty-retry \
+ --without-cdebug \
+ --without-bundles \
+ --without-copt \
+ --with-crypt \
+ --with-gif \
+ --with-gmp \
+ --with-bignums \
+ $(use_with bzip2 Bz2) \
+ $(use_with debug rtldebug) \
+ $(use_with fftw) \
+ $(use_with gdbm) \
+ $(use_with jpeg jpeglib) \
+ $(use_with kerberos Kerberos) \
+ $(use_with mime MIME) \
+ $(use_with mysql) \
+ $(use_with opengl GL) \
+ $(use_with opengl GLUT) \
+ $(use_with pcre _Regexp_PCRE) \
+ $(use_with pdf libpdf) \
+ $(use_with scanner sane) \
+ $(use_with sdl SDL) \
+ $(use_with sdl SDL_mixer) \
+ $(use_with ssl ssleay) \
+ $(use_with svg) \
+ $(use_with tiff tifflib) \
+ $(use_with truetype ttflib) \
+ $(use_with truetype freetype) \
+ $(use_with zlib) \
+ ${myconf} \
+ ${EXTRA_ECONF} \
+ " || die
+
+ if use doc; then
+ PATH="${S}/bin:${PATH}" make doc || die "doc failed"
+ fi
+}
+
+src_install() {
+ # do not remove modules to avoid sandbox violation.
+ sed -i s/rm\(mod\+\"\.o\"\)\;/break\;/ "${S}"/bin/install.pike || die "Failed to modify install.pike"
+ if use doc ; then
+ make INSTALLARGS="--traditional" buildroot="${D}" install || die
+ einfo "Installing 60MB of docs, this could take some time ..."
+ dohtml -r "${S}"/refdoc/traditional_manual "${S}"/refdoc/modref
+ else
+ make INSTALLARGS="--traditional" buildroot="${D}" install_nodoc || die
+ fi
+}
diff --git a/dev-lang/pike/pike-7.6.86-r1.ebuild b/dev-lang/pike/pike-7.6.86-r1.ebuild
index b38910924cc3..2d11f32da885 100644
--- a/dev-lang/pike/pike-7.6.86-r1.ebuild
+++ b/dev-lang/pike/pike-7.6.86-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.86-r1.ebuild,v 1.9 2007/07/31 12:56:32 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.6.86-r1.ebuild,v 1.10 2008/02/28 08:27:12 araujo Exp $
DESCRIPTION="Pike programming language and runtime"
HOMEPAGE="http://pike.ida.liu.se/"
@@ -24,7 +24,7 @@ DEPEND="dev-libs/nettle
opengl? ( virtual/opengl virtual/glut )
pcre? ( dev-libs/libpcre )
pdf? ( media-libs/pdflib )
- scanner? ( media-gfx/sane-backends )
+ !x86-fbsd? ( scanner? ( media-gfx/sane-backends ) )
sdl? ( media-libs/libsdl media-libs/sdl-mixer )
ssl? ( dev-libs/openssl )
svg? ( gnome-base/librsvg )