summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-11-08 18:20:18 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-11-08 18:20:18 +0000
commitf644e916ed3f64537bbaf27c4d493a031e3b47ea (patch)
treefe3f7d0b25d64c091e4e1ad893254718586c0b25 /dev-lang/pike
parentChanged mis-spelled emacsw3 USE flag to emacs-w3. Closing bug #21062. (diff)
downloadgentoo-2-f644e916ed3f64537bbaf27c4d493a031e3b47ea.tar.gz
gentoo-2-f644e916ed3f64537bbaf27c4d493a031e3b47ea.tar.bz2
gentoo-2-f644e916ed3f64537bbaf27c4d493a031e3b47ea.zip
disabled gtk+ support
Diffstat (limited to 'dev-lang/pike')
-rw-r--r--dev-lang/pike/ChangeLog6
-rw-r--r--dev-lang/pike/Manifest4
-rw-r--r--dev-lang/pike/pike-7.4.28-r1.ebuild27
3 files changed, 16 insertions, 21 deletions
diff --git a/dev-lang/pike/ChangeLog b/dev-lang/pike/ChangeLog
index a4e94a7e5911..80f3c6a4a1dc 100644
--- a/dev-lang/pike/ChangeLog
+++ b/dev-lang/pike/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/pike
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.3 2003/10/27 12:22:55 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.4 2003/11/08 18:20:13 scandium Exp $
+
+ 08 Nov 2003; Rainer Groesslinger <scandium@gentoo.org>
+ pike-7.4.28-r1.ebuild:
+ disabled Gtk+ support, it just caused too many problems
*pike-7.4.28-r1 (27 Oct 2003)
diff --git a/dev-lang/pike/Manifest b/dev-lang/pike/Manifest
index 96c9bce74f9e..349e2ffe2098 100644
--- a/dev-lang/pike/Manifest
+++ b/dev-lang/pike/Manifest
@@ -1,6 +1,6 @@
-MD5 46ac8649c4b24176d605405f2df83070 pike-7.4.28-r1.ebuild 3214
+MD5 1eee02d24093dbf0591ccbde4b00c0f6 pike-7.4.28-r1.ebuild 2890
MD5 70f36900617732b5a3ba6b2e9eba4d7e pike-7.4.28.ebuild 1618
-MD5 58667bea8b78255127168590ece031fb ChangeLog 826
+MD5 725f2c77dfd2b0493ed4ef1f738ce6b1 ChangeLog 967
MD5 7319ff3c2859ffcce59244a63a079bdd pike-7.4.20.ebuild 1633
MD5 7164d2a546785fee1e77dac8839fdeaa metadata.xml 224
MD5 308f6090a8fe96c717509be0d49c460f files/digest-pike-7.4.20 65
diff --git a/dev-lang/pike/pike-7.4.28-r1.ebuild b/dev-lang/pike/pike-7.4.28-r1.ebuild
index 9d243171cfd8..a64ffed23b15 100644
--- a/dev-lang/pike/pike-7.4.28-r1.ebuild
+++ b/dev-lang/pike/pike-7.4.28-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc., Emil Skoldberg (see ChangeLog)
+# Copyright 1999-2003 Gentoo Technologies, Inc., Emil Skoldberg, Fredrik Mellstrom (see ChangeLog)
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28-r1.ebuild,v 1.6 2003/10/29 19:12:47 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28-r1.ebuild,v 1.7 2003/11/08 18:20:13 scandium Exp $
inherit flag-o-matic
# -fomit-frame-pointer breaks the compilation
filter-flags -fomit-frame-pointer
-IUSE="debug doc gdbm gif gnome gtk java jpeg mysql oci8 odbc opengl pdflib postgres scanner sdl tiff truetype zlib"
+IUSE="debug doc gdbm gif java jpeg mysql oci8 odbc opengl pdflib postgres scanner sdl tiff truetype zlib"
S="${WORKDIR}/Pike-v${PV}"
HOMEPAGE="http://pike.ida.liu.se/"
@@ -32,8 +32,6 @@ DEPEND="dev-libs/gmp
tiff? ( media-libs/tiff )
opengl? ( virtual/opengl
virtual/glut )
- gtk? ( =x11-libs/gtk+-1.2* )
- #gtk2? ( =x11-libs/gtk+-2* )
sdl? ( media-libs/libsdl )
sys-devel/gcc
sys-devel/make
@@ -41,12 +39,10 @@ DEPEND="dev-libs/gmp
src_compile() {
-# disable gtk+-2 for now, it does not work
-# if use gtk2; then
-# einfo 'If building pike with GTK+ 2.x support breaks try'
-# einfo 'USE="-gtk2" emerge pike'
-# sleep 3
-# fi
+ einfo 'Gtk+ and Gnome support is disabled for now!'
+ einfo 'Gtk+-2 did not work with pike and'
+ einfo 'Gtk+-1 just caused too many problems'
+ sleep 5
local myconf
use zlib || myconf="${myconf} --without-zlib"
@@ -64,18 +60,13 @@ src_compile() {
use jpeg || myconf="${myconf} --without-jpeglib"
use tiff || myconf="${myconf} --without-tifflib"
use opengl || myconf="${myconf} --without-GL --without-GLUT"
- use gtk && myconf="${myconf} --with-GTK --without-GTK2" \
- || myconf="${myconf} --without-GTK --without-GTK2"
-# disable gtk+-2 for now, it does not work
-# use gtk2 && myconf="${myconf} --with-GTK2" \
-# || myconf="${myconf} --without-GTK2"
- use gnome || myconf="${myconf} --without-gnome"
# We have to use --disable-make_conf to override make.conf settings
# Otherwise it may set -fomit-frame-pointer again
# disable ffmpeg support because it does not compile
# disable dvb support because it does not compile
- emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-ffmpeg --without-dvb" || die
+ emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-ffmpeg \
+ --without-GTK --without-GTK2 --without-gnome --without-dvb" || die
# only build documentation if 'doc' is in USE
if use doc; then