summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-29 15:29:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-29 15:29:21 +0000
commit848383beede34e09e2bdf9ffee3a37292c8bcba8 (patch)
treeb40f9c7d46a3045cf4b6f9bad27efc36206b13c0 /dev-lang/python/python-3.1.1-r1.ebuild
parentamd64 stable wrt #292455 (diff)
downloadgentoo-2-848383beede34e09e2bdf9ffee3a37292c8bcba8.tar.gz
gentoo-2-848383beede34e09e2bdf9ffee3a37292c8bcba8.tar.bz2
gentoo-2-848383beede34e09e2bdf9ffee3a37292c8bcba8.zip
_ctypes module doesn't work with GCC's internal libffi.
(Portage version: 14920-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python/python-3.1.1-r1.ebuild')
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 3ffd64ac5388..5769d8bdb54a 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.17 2009/11/07 23:17:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.18 2009/11/29 15:29:21 arfrever Exp $
EAPI="2"
@@ -43,7 +43,8 @@ RDEPEND=">=app-admin/eselect-python-20090606
xml? ( >=dev-libs/expat-2 )
)"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ !sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )"
PDEPEND="app-admin/python-updater
=dev-lang/python-2*"
@@ -160,8 +161,8 @@ src_configure() {
$(use_with !ucs2 wide-unicode) \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
- --with-libc='' \
--with-dbmliborder=${dbmliborder} \
+ --with-libc='' \
--with-system-ffi
}