summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 21:20:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-15 21:20:57 +0000
commit2475b8e8844af258a6ce73915a64c09650e43b5f (patch)
tree667b112e27a893d264b6716209fe43f72dda1f0b /dev-lang/python/python-3.1.2-r4.ebuild
parentx86 stable, bug #326139 (diff)
downloadgentoo-2-2475b8e8844af258a6ce73915a64c09650e43b5f.tar.gz
gentoo-2-2475b8e8844af258a6ce73915a64c09650e43b5f.tar.bz2
gentoo-2-2475b8e8844af258a6ce73915a64c09650e43b5f.zip
Fix building with some locales (bug #328047).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python/python-3.1.2-r4.ebuild')
-rw-r--r--dev-lang/python/python-3.1.2-r4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.1.2-r4.ebuild b/dev-lang/python/python-3.1.2-r4.ebuild
index 8e64c22daaab..f78448ed1cbc 100644
--- a/dev-lang/python/python-3.1.2-r4.ebuild
+++ b/dev-lang/python/python-3.1.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r4.ebuild,v 1.1 2010/07/12 19:30:39 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r4.ebuild,v 1.2 2010/07/15 21:20:57 arfrever Exp $
EAPI="3"
@@ -176,6 +176,10 @@ src_configure() {
--with-system-ffi
}
+src_compile() {
+ LC_ALL="C" default
+}
+
src_test() {
# Tests will not work when cross compiling.
if tc-is-cross-compiler; then