summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-30 18:09:26 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-30 18:09:26 +0000
commita84254397e322f5830cecf1f6337c4948951d2f7 (patch)
treeb38437b40f93dae3927c33d728164d408a8518f0 /dev-lang/python/python-3.1.4-r3.ebuild
parentAdd m68k/s390 keywords #397769 by William Hubbs. (diff)
downloadgentoo-2-a84254397e322f5830cecf1f6337c4948951d2f7.tar.gz
gentoo-2-a84254397e322f5830cecf1f6337c4948951d2f7.tar.bz2
gentoo-2-a84254397e322f5830cecf1f6337c4948951d2f7.zip
Make sure $PKG_CONFIG is respected.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python/python-3.1.4-r3.ebuild')
-rw-r--r--dev-lang/python/python-3.1.4-r3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.1.4-r3.ebuild b/dev-lang/python/python-3.1.4-r3.ebuild
index e032ea61f64b..7ea6948894b3 100644
--- a/dev-lang/python/python-3.1.4-r3.ebuild
+++ b/dev-lang/python/python-3.1.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.11 2012/05/15 18:35:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.12 2012/07/30 18:09:26 vapier Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -187,6 +187,9 @@ src_configure() {
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
tc-export CXX
+ # The configure script fails to use pkg-config correctly.
+ # http://bugs.python.org/issue15506
+ export ac_cv_path_PKG_CONFIG=$(tc-getPKG_CONFIG)
# Set LDFLAGS so we link modules with -lpython3.1 correctly.
# Needed on FreeBSD unless Python 3.1 is already installed.