summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-12-19 18:03:41 +0000
committerMike Gilbert <floppym@gentoo.org>2012-12-19 18:03:41 +0000
commit47b599fce40bcf3458c6c8681bfad43d717105ea (patch)
treed61025adcddf0d54eca25ed540644a076d8b04fd /dev-lang/python/python-3.1.5-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-47b599fce40bcf3458c6c8681bfad43d717105ea.tar.gz
gentoo-2-47b599fce40bcf3458c6c8681bfad43d717105ea.tar.bz2
gentoo-2-47b599fce40bcf3458c6c8681bfad43d717105ea.zip
Don't depend on dev-lang/python. Bug 447752.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang/python/python-3.1.5-r1.ebuild')
-rw-r--r--dev-lang/python/python-3.1.5-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.1.5-r1.ebuild b/dev-lang/python/python-3.1.5-r1.ebuild
index 969e599a81c9..1eb66cb7741b 100644
--- a/dev-lang/python/python-3.1.5-r1.ebuild
+++ b/dev-lang/python/python-3.1.5-r1.ebuild
@@ -1,15 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.4 2012/12/02 18:21:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.5-r1.ebuild,v 1.5 2012/12/19 18:03:41 floppym Exp $
EAPI="3"
WANT_AUTOMAKE="none"
WANT_LIBTOOL="none"
-# Bootstrapping Python 3 requires any Python version.
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
-
-inherit autotools eutils flag-o-matic multilib pax-utils python-any-r1 toolchain-funcs
+inherit autotools eutils flag-o-matic multilib pax-utils python-utils-r1 toolchain-funcs
MY_P="Python-${PV}"
PATCHSET_REVISION="0"
@@ -24,6 +21,11 @@ SLOT="3.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
+# Do not add a dependency on dev-lang/python to this ebuild.
+# If you need to apply a patch which requires python for bootstrapping, please
+# run the bootstrap code on your dev box and include the results in the
+# patchset. See bug 447752.
+
RDEPEND="app-arch/bzip2
>=sys-libs/zlib-1.1.3
virtual/libffi
@@ -43,7 +45,6 @@ RDEPEND="app-arch/bzip2
xml? ( >=dev-libs/expat-2.1 )
)"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
virtual/pkgconfig
>=sys-devel/autoconf-2.61
!sys-devel/gcc[libffi]"