summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-29 15:21:51 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-29 15:21:51 +0000
commit0b61cd9bc376129970df895b20084cee868c313d (patch)
tree894ca39586820a103faaf24723575c5dcb2904df /dev-lang/python
parentnew version (diff)
downloadgentoo-2-0b61cd9bc376129970df895b20084cee868c313d.tar.gz
gentoo-2-0b61cd9bc376129970df895b20084cee868c313d.tar.bz2
gentoo-2-0b61cd9bc376129970df895b20084cee868c313d.zip
Fixing bug #2199
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog14
-rw-r--r--dev-lang/python/files/digest-python-2.2-r71
-rw-r--r--dev-lang/python/python-2.2-r4.ebuild144
-rw-r--r--dev-lang/python/python-2.2-r5.ebuild145
-rw-r--r--dev-lang/python/python-2.2-r7.ebuild (renamed from dev-lang/python/python-2.2-r6.ebuild)4
5 files changed, 12 insertions, 296 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index fe6a3f340870..ab4583f3f0b2 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,13 +1,17 @@
# ChangeLog for dev-lang/python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.6 2002/04/25 02:03:01 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.7 2002/04/29 15:21:51 drobbins Exp $
+
+*python-2.2-r7 (29 Apr 2002)
+
+ 29 Apr 2002; Daniel Robbins <drobbins@gentoo.org>: New rev to fix bug #2199;
+ python-config should now work properly.
*python-2.2-r6 (24 Apr 2002)
- 24 Apr 2002; Jon Nelson <jnelson@gentoo.org> python-2.2-r6.ebuild :
-
- Make python build with shared modules.
- Depends on python-fchksum, as fchksum *no longer built in*
+ 24 Apr 2002; Jon Nelson <jnelson@gentoo.org> python-2.2-r6.ebuild : Make
+ python build with shared modules. Depends on python-fchksum, as fchksum *no
+ longer built in*
*python-2.2-r5 (8 Apr 2002)
diff --git a/dev-lang/python/files/digest-python-2.2-r7 b/dev-lang/python/files/digest-python-2.2-r7
new file mode 100644
index 000000000000..1a6a57c9f144
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.2-r7
@@ -0,0 +1 @@
+MD5 87febf0780c8e18454022d34b2ca70a0 Python-2.2.tgz 6542443
diff --git a/dev-lang/python/python-2.2-r4.ebuild b/dev-lang/python/python-2.2-r4.ebuild
deleted file mode 100644
index afd9a2261a5c..000000000000
--- a/dev-lang/python/python-2.2-r4.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r4.ebuild,v 1.4 2002/04/07 13:33:00 gbevin Exp $
-
-PYVER="`echo ${PV} | cut -d '.' -f 1,2`"
-S=${WORKDIR}/Python-${PV}
-FCHKSUM="python-fchksum-1.6"
-FCHKSUMP="python-fchksum_1.6-2"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUMP}.diff.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python"
-
-SLOT="2.2"
-
-src_unpack() {
- # unpack python
- unpack Python-${PV}.tgz
- # unpack fchksum and move pieces into Modules subdir
- cd ${S}/Modules
- unpack ${FCHKSUM}.tar.gz
- zcat ${DISTDIR}/${FCHKSUMP}.diff.gz | patch -p0
- cd ${FCHKSUM}
- cp md5.h ../md5_2.h
- cp cksum.[ch] sum.[ch] fchksum.h ..
- sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
- # add fchksum configuration to Setup
- cd ${S}
- echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-}
-
-src_compile() {
- # python's config seems to ignore CFLAGS
- export OPT=$CFLAGS
-
- # configure fchksum
- cd ${S}/Modules/${FCHKSUM}
- ./configure
- cp pfconfig.h ..
-
- # adjust Setup to include the various modules we need
- cd ${S}
- scmd=""
- # adjust for USE readline
- if use readline; then
- scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
- scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
- fi
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s:# \(_tkinter \):\1:;"
- scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
- scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
- scmd="$scmd s:#\(\t-lX11.*\):\1:;"
- fi
- # adjust for USE berkdb
- if use berkdb; then
- # patch the dbmmodule to use db3's dbm compatibility code. That way,
- # we're depending on db3 rather than old db1.
- t=Modules/dbmmodule.c
- cp $t $t.orig || die
- sed \
- -e '10,25d' \
- -e '26i\' \
- -e '#define DB_DBM_HSEARCH 1\' \
- -e 'static char *which_dbm = "BSD db";\' \
- -e '#include <db3/db.h>' \
- $t.orig > $t
- # now fix Setup
- scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
- fi
- # no USE vars to switch off these adjustments:
- scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
- scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
- scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
- scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
- sed "$scmd" Modules/Setup.dist > Modules/Setup
-
- local myopts
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
- then
- myopts="--with-cxx=no"
- fi
- ./configure \
- --prefix=/usr \
- --without-libdb \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man $myopts
- assert "Configure failed"
- # kill the -DHAVE_CONFIG_H flag
- mv Makefile Makefile.orig
- sed -e 's/-DHAVE_CONFIG_H//' Makefile.orig > Makefile
- #emake || die "Parallel make failed"
- make || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python${PYVER} /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PYVER} python-config
-
- # seems like the build do not install Makefile.pre.in anymore
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- mkdir "${D}/usr/lib/python${PYVER}/tools"
- mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
- dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
diff --git a/dev-lang/python/python-2.2-r5.ebuild b/dev-lang/python/python-2.2-r5.ebuild
deleted file mode 100644
index 7e736790aa8e..000000000000
--- a/dev-lang/python/python-2.2-r5.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r5.ebuild,v 1.4 2002/04/08 12:36:57 jhhudso Exp $
-
-PYVER="`echo ${PV} | cut -d '.' -f 1,2`"
-S=${WORKDIR}/Python-${PV}
-FCHKSUM="python-fchksum-1.6"
-FCHKSUMP="python-fchksum_1.6-2"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUMP}.diff.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python"
-
-SLOT="2.2"
-
-src_unpack() {
- # unpack python
- unpack Python-${PV}.tgz
- # unpack fchksum and move pieces into Modules subdir
- cd ${S}/Modules
- unpack ${FCHKSUM}.tar.gz
- zcat ${DISTDIR}/${FCHKSUMP}.diff.gz | patch -p0
- cd ${FCHKSUM}
- cp md5.h ../md5_2.h
- cp cksum.[ch] sum.[ch] fchksum.h ..
- sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
- # add fchksum configuration to Setup
- cd ${S}
- echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-}
-
-src_compile() {
- # python's config seems to ignore CFLAGS
- export OPT=$CFLAGS
-
- # configure fchksum
- cd ${S}/Modules/${FCHKSUM}
- ./configure
- cp pfconfig.h ..
-
- # adjust Setup to include the various modules we need
- cd ${S}
- scmd=""
- # adjust for USE readline
- if use readline; then
- scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
- scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
- fi
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s:# \(_tkinter \):\1:;"
- scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
- scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
- scmd="$scmd s:#\(\t-lX11.*\):\1:;"
- scmd="$scmd s:#\(\t-I/usr/X11R6/include\):\1:;"
- fi
- # adjust for USE berkdb
- if use berkdb; then
- # patch the dbmmodule to use db3's dbm compatibility code. That way,
- # we're depending on db3 rather than old db1.
- t=Modules/dbmmodule.c
- cp $t $t.orig || die
- sed \
- -e '10,25d' \
- -e '26i\' \
- -e '#define DB_DBM_HSEARCH 1\' \
- -e 'static char *which_dbm = "BSD db";\' \
- -e '#include <db3/db.h>' \
- $t.orig > $t
- # now fix Setup
- scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
- fi
- # no USE vars to switch off these adjustments:
- scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
- scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
- scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
- scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
- sed "$scmd" Modules/Setup.dist > Modules/Setup
-
- local myopts
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
- then
- myopts="--with-cxx=no"
- fi
- ./configure \
- --prefix=/usr \
- --without-libdb \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man $myopts
- assert "Configure failed"
- # kill the -DHAVE_CONFIG_H flag
- mv Makefile Makefile.orig
- sed -e 's/-DHAVE_CONFIG_H//' Makefile.orig > Makefile
- #emake || die "Parallel make failed"
- make || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python${PYVER} /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PYVER} python-config
-
- # seems like the build do not install Makefile.pre.in anymore
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- mkdir "${D}/usr/lib/python${PYVER}/tools"
- mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
- dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
diff --git a/dev-lang/python/python-2.2-r6.ebuild b/dev-lang/python/python-2.2-r7.ebuild
index 8d5ec4ac396d..282cee257378 100644
--- a/dev-lang/python/python-2.2-r6.ebuild
+++ b/dev-lang/python/python-2.2-r7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r6.ebuild,v 1.3 2002/04/25 06:11:00 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r7.ebuild,v 1.1 2002/04/29 15:21:51 drobbins Exp $
PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S=${WORKDIR}/Python-${PV}
DESCRIPTION="A really great language"
SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"