summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-04 21:14:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-04 21:14:58 +0000
commit78901119446008d097c00840a8b09fc6fd0e675e (patch)
tree42fc6b6c9d8013524dc4f2dc16e980ae7aa0352b /dev-lang/python
parentMask Python 2.7. (diff)
downloadgentoo-2-78901119446008d097c00840a8b09fc6fd0e675e.tar.gz
gentoo-2-78901119446008d097c00840a8b09fc6fd0e675e.tar.bz2
gentoo-2-78901119446008d097c00840a8b09fc6fd0e675e.zip
Synchronize ebuilds.
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild13
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild12
-rw-r--r--dev-lang/python/python-2.6.5-r2.ebuild12
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild12
4 files changed, 24 insertions, 25 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index b3e16894f21e..8902f27a2930 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.39 2010/05/25 17:09:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.40 2010/07/04 21:14:58 arfrever Exp $
EAPI="1"
inherit autotools eutils flag-o-matic multilib python toolchain-funcs
MY_P="Python-${PV}"
-S="${WORKDIR}/${MY_P}"
PATCHSET_REVISION="0"
@@ -31,7 +30,6 @@ RDEPEND=">=app-admin/eselect-python-20091230
sys-libs/db:4.3
sys-libs/db:4.2
) )
- doc? ( dev-python/python-docs:${SLOT} )
gdbm? ( sys-libs/gdbm )
ncurses? (
>=sys-libs/ncurses-5.2
@@ -39,14 +37,16 @@ RDEPEND=">=app-admin/eselect-python-20091230
)
ssl? ( dev-libs/openssl )
tk? ( >=dev-lang/tk-8.0 )
- )"
-# xml? ( dev-libs/expat )
+ )
+ doc? ( dev-python/python-docs:${SLOT} )"
DEPEND="${RDEPEND}"
RDEPEND+=" !build? ( app-misc/mime-types )"
PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
python_pkg_setup
@@ -187,8 +187,7 @@ src_test() {
# Otherwise test_import fails.
python_enable_pyc
- # Skip all tests that fail during emerge but pass without emerge:
- # (See bug #67970)
+ # Skip failing tests.
local skip_tests="cookielib distutils global hotshot mimetools minidom mmap posix sax strptime subprocess syntax tcl time urllib urllib2"
for test in ${skip_tests}; do
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index d2963e335bc5..180645833d86 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.21 2010/05/25 17:09:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.22 2010/07/04 21:14:58 arfrever Exp $
EAPI="1"
inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs
MY_P="Python-${PV}"
-S="${WORKDIR}/${MY_P}"
PATCHSET_REVISION="3"
@@ -36,7 +35,6 @@ RDEPEND=">=app-admin/eselect-python-20091230
sys-libs/db:4.3
sys-libs/db:4.2
) )
- doc? ( dev-python/python-docs:${SLOT} )
gdbm? ( sys-libs/gdbm )
ncurses? (
>=sys-libs/ncurses-5.2
@@ -46,7 +44,8 @@ RDEPEND=">=app-admin/eselect-python-20091230
ssl? ( dev-libs/openssl )
tk? ( >=dev-lang/tk-8.0 )
xml? ( >=dev-libs/expat-2 )
- )"
+ )
+ doc? ( dev-python/python-docs:${SLOT} )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
RDEPEND+=" !build? ( app-misc/mime-types )"
@@ -54,6 +53,8 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
python_pkg_setup
@@ -202,8 +203,7 @@ src_test() {
# Otherwise test_import fails.
python_enable_pyc
- # Skip all tests that fail during emerge but pass without emerge:
- # (See bug #67970)
+ # Skip failing tests.
local skip_tests="distutils global mimetools minidom mmap posix pyexpat sax strptime subprocess syntax tcl time urllib urllib2 xml_etree"
# test_ctypes fails with PAX kernel (bug #234498).
diff --git a/dev-lang/python/python-2.6.5-r2.ebuild b/dev-lang/python/python-2.6.5-r2.ebuild
index ae67c4b9fce9..36bb9ab51ab2 100644
--- a/dev-lang/python/python-2.6.5-r2.ebuild
+++ b/dev-lang/python/python-2.6.5-r2.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.12 2010/06/22 13:09:38 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.13 2010/07/04 21:14:58 arfrever Exp $
EAPI="2"
inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs
MY_P="Python-${PV}"
-S="${WORKDIR}/${MY_P}"
PATCHSET_REVISION="4"
@@ -38,7 +37,6 @@ RDEPEND=">=app-admin/eselect-python-20091230
sys-libs/db:4.3
sys-libs/db:4.2
) )
- doc? ( dev-python/python-docs:${SLOT} )
gdbm? ( sys-libs/gdbm )
ncurses? (
>=sys-libs/ncurses-5.2
@@ -48,7 +46,8 @@ RDEPEND=">=app-admin/eselect-python-20091230
ssl? ( dev-libs/openssl )
tk? ( >=dev-lang/tk-8.0 )
xml? ( >=dev-libs/expat-2 )
- )"
+ )
+ doc? ( dev-python/python-docs:${SLOT} )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
!sys-devel/gcc[libffi]"
@@ -57,6 +56,8 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
python_pkg_setup
@@ -193,8 +194,7 @@ src_test() {
# Otherwise test_import fails.
python_enable_pyc
- # Skip all tests that fail during emerge but pass without emerge:
- # (See bug #67970)
+ # Skip failing tests.
local skip_tests="distutils httpservers minidom pyexpat sax tcl"
# test_ctypes fails with PAX kernel (bug #234498).
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index 125edc820e26..213c747291c6 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.12 2010/06/04 19:09:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.13 2010/07/04 21:14:58 arfrever Exp $
EAPI="3"
inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs
MY_P="Python-${PV}"
-S="${WORKDIR}/${MY_P}"
PATCHSET_REVISION="5"
@@ -27,7 +26,6 @@ RDEPEND=">=app-admin/eselect-python-20091230
virtual/libffi
virtual/libintl
!build? (
- doc? ( dev-python/python-docs:${SLOT} )
gdbm? ( sys-libs/gdbm )
ncurses? (
>=sys-libs/ncurses-5.2
@@ -37,7 +35,8 @@ RDEPEND=">=app-admin/eselect-python-20091230
ssl? ( dev-libs/openssl )
tk? ( >=dev-lang/tk-8.0 )
xml? ( >=dev-libs/expat-2 )
- )"
+ )
+ doc? ( dev-python/python-docs:${SLOT} )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
!sys-devel/gcc[libffi]"
@@ -50,6 +49,8 @@ PDEPEND=">=app-admin/python-updater-0.8
PROVIDE="virtual/python"
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
python_pkg_setup
}
@@ -188,8 +189,7 @@ src_test() {
# Otherwise test_import fails.
python_enable_pyc
- # Skip all tests that fail during emerge but pass without emerge:
- # (See bug #67970)
+ # Skip failing tests.
local skip_tests="distutils"
# test_ctypes fails with PAX kernel (bug #234498).