summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-10-06 13:05:36 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-10-06 13:05:36 +0000
commit9d6e1a0a55310b60aef94c85b701550b18d5e419 (patch)
tree7e36b1591713d2efdf2f47e0d36b41ff1f190813 /dev-lang/ruby
parentStable on ppc wrt bug 139179 (diff)
downloadgentoo-2-9d6e1a0a55310b60aef94c85b701550b18d5e419.tar.gz
gentoo-2-9d6e1a0a55310b60aef94c85b701550b18d5e419.tar.bz2
gentoo-2-9d6e1a0a55310b60aef94c85b701550b18d5e419.zip
version bump to get rid of fomit-frame-pointer filtering, per bug #148965
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog7
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.5-r16
-rw-r--r--dev-lang/ruby/ruby-1.8.5-r1.ebuild146
3 files changed, 158 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 49571fb3e437..9ac9eb9ec284 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.221 2006/10/05 13:01:10 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.222 2006/10/06 13:05:35 caleb Exp $
+
+*ruby-1.8.5-r1 (06 Oct 2006)
+
+ 06 Oct 2006; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.5-r1.ebuild:
+ version bump to get rid of fomit-frame-pointer filtering, per bug #148965
05 Oct 2006; Emanuele Giaquinta <exg@gentoo.org> ruby-1.8.5.ebuild:
tcltk -> tk, acked by Flameeyes.
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.5-r1 b/dev-lang/ruby/files/digest-ruby-1.8.5-r1
new file mode 100644
index 000000000000..55d88e714851
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.8.5-r1
@@ -0,0 +1,6 @@
+MD5 b3b6b2d2f77f1f485d055d74f6eb6f2a onigd2_5_4.tar.gz 212280
+RMD160 6f694c6cf12f803d0bc608f493789c92c3cbcf68 onigd2_5_4.tar.gz 212280
+SHA256 cd4b4177633e8e42e34c26e3f41b0b9bccf747dc51d72a38943fef9cbc0eaa7b onigd2_5_4.tar.gz 212280
+MD5 3fbb02294a8ca33d4684055adba5ed6f ruby-1.8.5.tar.gz 4438603
+RMD160 991899146c23c9ea30ac09f41b7077fa0c8686b6 ruby-1.8.5.tar.gz 4438603
+SHA256 19590e972b80333e26a6514c34d976c2037138361481a16f27b75e5d33f33a58 ruby-1.8.5.tar.gz 4438603
diff --git a/dev-lang/ruby/ruby-1.8.5-r1.ebuild b/dev-lang/ruby/ruby-1.8.5-r1.ebuild
new file mode 100644
index 000000000000..529daedeb1c6
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.5-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5-r1.ebuild,v 1.1 2006/10/06 13:05:35 caleb Exp $
+
+ONIGURUMA="onigd2_5_4"
+
+inherit flag-o-matic alternatives eutils gnuconfig multilib autotools
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${P}.tar.gz
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug socks5 tk cjk doc threads examples ipv6"
+RESTRICT="confcache"
+
+RDEPEND="virtual/libc
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3
+ !=dev-lang/ruby-cvs-1.8*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+
+DEPEND="sys-devel/autoconf
+ ${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+S=${WORKDIR}/${P%_*}
+
+src_unpack() {
+ unpack ${A}
+
+ if use cjk ; then
+ einfo "Applying ${ONIGURUMA}"
+ pushd ${WORKDIR}/oniguruma
+# epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+ econf --with-rubydir=${S} || die "econf failed"
+ make ${PV/./}
+ popd
+ fi
+
+ # Enable build on alpha EV67 (but run gnuconfig_update everywhere)
+ gnuconfig_update || die "gnuconfig_update failed"
+
+ cd ${S}
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+
+ # Socks support via dante
+ if use socks5; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ # On ia64 we need to build without optimization #48824
+ if use ia64; then
+ replace-flags '-O*' -O0
+ fi
+
+ econf --program-suffix=${SLOT/./} --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6 ipv6) \
+ $(use_enable debug debug) \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find ${S}/ext -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ if use doc; then
+ make DESTDIR=${D} install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir ${ROOT}usr/share/doc/${PF}
+ cp -pPR sample ${D}/${ROOT}usr/share/doc/${PF}
+ fi
+
+ if use ppc-macos ; then
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%.*}.dylib
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%_*}.dylib
+ else
+ dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%.*}
+ dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%_*}
+ fi
+
+ dodoc COPYING* ChangeLog MANIFEST README* ToDo
+}
+
+pkg_postinst() {
+ if ! use ppc-macos ; then
+ ewarn
+ ewarn "Warning: Vim won't work if you've just updated ruby from"
+ ewarn "1.6.x to 1.8.x due to the library version change."
+ ewarn "In that case, you will need to remerge vim."
+ ewarn
+
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ einfo
+ einfo "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ if ! use ppc-macos ; then
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ fi
+}