summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-07-31 09:52:41 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-07-31 09:52:41 +0000
commitb31315815eb3fbe3a51c2b8e711e7760889026f2 (patch)
treee1a2dabaa531660a834a2ff92f46e0b4e22dc5a0 /dev-lang/rust
parentStable for HPPA (bug #516314). (diff)
downloadgentoo-2-b31315815eb3fbe3a51c2b8e711e7760889026f2.tar.gz
gentoo-2-b31315815eb3fbe3a51c2b8e711e7760889026f2.tar.bz2
gentoo-2-b31315815eb3fbe3a51c2b8e711e7760889026f2.zip
version bump, closing bug #516466
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/ChangeLog8
-rw-r--r--dev-lang/rust/files/rust-0.11.0-stage0.patch28
-rw-r--r--dev-lang/rust/metadata.xml4
-rw-r--r--dev-lang/rust/rust-0.11.0.ebuild97
4 files changed, 135 insertions, 2 deletions
diff --git a/dev-lang/rust/ChangeLog b/dev-lang/rust/ChangeLog
index dfc234ac323c..7d25f34f9cdb 100644
--- a/dev-lang/rust/ChangeLog
+++ b/dev-lang/rust/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/rust
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.1 2014/05/18 23:46:09 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.2 2014/07/31 09:52:41 jauhien Exp $
+
+*rust-0.11.0 (31 Jul 2014)
+
+ 31 Jul 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +files/rust-0.11.0-stage0.patch, +rust-0.11.0.ebuild, metadata.xml:
+ version bump, closing bug #516466
*rust-0.10 (18 May 2014)
diff --git a/dev-lang/rust/files/rust-0.11.0-stage0.patch b/dev-lang/rust/files/rust-0.11.0-stage0.patch
new file mode 100644
index 000000000000..2416cefa9d3d
--- /dev/null
+++ b/dev-lang/rust/files/rust-0.11.0-stage0.patch
@@ -0,0 +1,28 @@
+--- src/libcore/ops.rs
++++ src/libcore/ops.rs
+@@ -570,12 +570,6 @@
+
+ macro_rules! shl_impl(
+ ($($t:ty)*) => ($(
+- #[cfg(stage0)]
+- impl Shl<$t, $t> for $t {
+- #[inline]
+- fn shl(&self, other: &$t) -> $t { (*self) << (*other) }
+- }
+- #[cfg(not(stage0), not(test))]
+ impl Shl<$t, $t> for $t {
+ #[inline]
+ fn shl(&self, other: &$t) -> $t {
+@@ -619,12 +613,6 @@
+
+ macro_rules! shr_impl(
+ ($($t:ty)*) => ($(
+- #[cfg(stage0, not(test))]
+- impl Shr<$t, $t> for $t {
+- #[inline]
+- fn shr(&self, other: &$t) -> $t { (*self) >> (*other) }
+- }
+- #[cfg(not(stage0), not(test))]
+ impl Shr<$t, $t> for $t {
+ #[inline]
+ fn shr(&self, other: &$t) -> $t { (*self) >> (*other as uint) }
diff --git a/dev-lang/rust/metadata.xml b/dev-lang/rust/metadata.xml
index a077e38baebf..b2372428725b 100644
--- a/dev-lang/rust/metadata.xml
+++ b/dev-lang/rust/metadata.xml
@@ -6,7 +6,9 @@
<name>Jauhien Piatlicki</name>
</maintainer>
<use>
- <flag name="clang">Use sys-devel/clang for building</flag>
<flag name="binary-bootstrap">Download precompiled rust for compilator bootstrap</flag>
+ <flag name="clang">Use <pkg>sys-devel/clang</pkg> for building</flag>
+ <flag name="libcxx">Use <pkg>sys-libs/libcxx</pkg> as standard
+ library when building with <pkg>sys-devel/clang</pkg></flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/rust/rust-0.11.0.ebuild b/dev-lang/rust/rust-0.11.0.ebuild
new file mode 100644
index 000000000000..2880ec4e734b
--- /dev/null
+++ b/dev-lang/rust/rust-0.11.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-0.11.0.ebuild,v 1.1 2014/07/31 09:52:41 jauhien Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit elisp-common eutils python-any-r1
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+
+ARCH_SRC_URI="amd64? ( http://static.rust-lang.org/dist/${P}-x86_64-unknown-linux-gnu.tar.gz )
+ x86? ( http://static.rust-lang.org/dist/${P}-i686-unknown-linux-gnu.tar.gz )"
+
+SRC_URI="http://static.rust-lang.org/dist/${P}.tar.gz ${ARCH_SRC_URI}"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="clang debug emacs libcxx vim-syntax zsh-completion"
+REQUIRED_USE="libcxx? ( clang )"
+
+RDEPEND="vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5.0
+ clang? ( sys-devel/clang )
+ emacs? ( virtual/emacs )
+ libcxx? ( sys-libs/libcxx )"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-stage0.patch"
+}
+
+src_configure() {
+ use amd64 && ARCH_POSTFIX="x86_64"
+ use x86 && ARCH_POSTFIX="i686"
+ LOCAL_RUST_PATH="${WORKDIR}/${P}-${ARCH_POSTFIX}-unknown-linux-gnu"
+
+ "${ECONF_SOURCE:-.}"/configure \
+ --prefix="${EPREFIX}/usr/" \
+ $(use_enable clang) \
+ $(use_enable debug) \
+ $(use_enable debug llvm-assertions) \
+ $(use_enable !debug optimize) \
+ $(use_enable !debug optimize-cxx) \
+ $(use_enable !debug optimize-llvm) \
+ $(use_enable !debug optimize-tests) \
+ $(use_enable libcxx libcpp) \
+ --enable-local-rust \
+ --local-rust-root="${LOCAL_RUST_PATH}" \
+ --disable-manage-submodules \
+ || die
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ cd src/etc/emacs || die
+ elisp-compile *.el
+ elisp-make-autoload-file "${PN}-mode-autoloads.el" .
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-install ${PN}-mode src/etc/emacs/*.el src/etc/emacs/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r src/etc/vim/*
+ fi
+
+ if use zsh-completion; then
+ insinto "/usr/share/zsh/site-functions"
+ doins src/etc/zsh/_rust
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}