summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2012-03-10 15:34:30 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2012-03-10 15:34:30 +0000
commit8569fd1ba538e54c314179330e1942f02d235379 (patch)
treed1013cd8102d643ba7f58d84d9110b1b3a62d241 /dev-lang/tcl
parentInitial version. Haskell library to deal with temporary files in a portable w... (diff)
downloadgentoo-2-8569fd1ba538e54c314179330e1942f02d235379.tar.gz
gentoo-2-8569fd1ba538e54c314179330e1942f02d235379.tar.bz2
gentoo-2-8569fd1ba538e54c314179330e1942f02d235379.zip
Use EAPI 4 to make use of REPLACING_VERSIONS which enables us to show pkg_postinst warnings only when they are needed.
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog6
-rw-r--r--dev-lang/tcl/tcl-8.5.11.ebuild28
2 files changed, 21 insertions, 13 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 95565e9e2d05..52233813a73d 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.150 2012/03/06 18:12:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.151 2012/03/10 15:34:30 betelgeuse Exp $
+
+ 10 Mar 2012; Petteri Räty <betelgeuse@gentoo.org> tcl-8.5.11.ebuild:
+ Use EAPI 4 to make use of REPLACING_VERSIONS which enables us to show
+ pkg_postinst warnings only when they are needed.
06 Mar 2012; Jeroen Roovers <jer@gentoo.org> tcl-8.5.10-r1.ebuild:
Stable for HPPA (bug #406607).
diff --git a/dev-lang/tcl/tcl-8.5.11.ebuild b/dev-lang/tcl/tcl-8.5.11.ebuild
index 287d4141397e..725ffd7ffb72 100644
--- a/dev-lang/tcl/tcl-8.5.11.ebuild
+++ b/dev-lang/tcl/tcl-8.5.11.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.11.ebuild,v 1.3 2012/03/06 07:52:42 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.11.ebuild,v 1.4 2012/03/10 15:34:30 betelgeuse Exp $
EAPI=4
-inherit autotools eutils flag-o-matic multilib toolchain-funcs
+inherit versionator autotools eutils flag-o-matic multilib toolchain-funcs
MY_P="${PN}${PV/_beta/b}"
@@ -96,8 +96,8 @@ src_install() {
rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h || die
# install symlink for libraries
- dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname) || die
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a || die
+ dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
+ dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
dosym tclsh${v1} /usr/bin/tclsh
@@ -106,12 +106,16 @@ src_install() {
}
pkg_postinst() {
- echo
- ewarn "If you're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
- ewarn "packages on your system that link with tcl after the upgrade"
- ewarn "completes. To perform this action, please run revdep-rebuild"
- ewarn "in package app-portage/gentoolkit."
- ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
- ewarn "upgrade them before this recompilation, too,"
- echo
+ for version in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 8.5 ${version}; then
+ echo
+ ewarn "You're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild"
+ ewarn "in package app-portage/gentoolkit."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ echo
+ fi
+ done
}