summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2005-10-31 18:13:08 +0000
committerTom William Payne <twp@gentoo.org>2005-10-31 18:13:08 +0000
commit9de4ed9209468e414c5572e42b4285b2aab555cf (patch)
tree026e7e4d92fe64fb6a341f60a7e5678b1d5ff39d /dev-lang/tolua/tolua-5.0-r1.ebuild
parentStable on x86. (diff)
downloadgentoo-2-9de4ed9209468e414c5572e42b4285b2aab555cf.tar.gz
gentoo-2-9de4ed9209468e414c5572e42b4285b2aab555cf.tar.bz2
gentoo-2-9de4ed9209468e414c5572e42b4285b2aab555cf.zip
Use portability eclass to conditionally link to dl. Bug # 106446.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'dev-lang/tolua/tolua-5.0-r1.ebuild')
-rw-r--r--dev-lang/tolua/tolua-5.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/tolua/tolua-5.0-r1.ebuild b/dev-lang/tolua/tolua-5.0-r1.ebuild
new file mode 100644
index 000000000000..ea397f3b596d
--- /dev/null
+++ b/dev-lang/tolua/tolua-5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/tolua-5.0-r1.ebuild,v 1.1 2005/10/31 18:13:08 twp Exp $
+
+inherit toolchain-funcs portability
+
+DESCRIPTION="A tool that simplifies the integration of C/C++ code with Lua"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~celes/tolua/"
+SRC_URI="ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/^CC=/ s/=.*/=$(tc-getCC)/" \
+ -e "/^LUA=/ s:=.*:=/usr:" \
+ -e "s/^\(LIB=.*\)/\1 $(dlopen_lib)/" \
+ -e "s:-O2:${CFLAGS}:" config || \
+ die "sed config failed"
+ sed -i \
+ -e 's:make:$(MAKE):' Makefile || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin bin/tolua || die
+ dolib.a lib/libtolua.a
+ insinto /usr/include
+ doins include/tolua.h
+ dodoc INSTALL README
+ dohtml doc/*
+}