summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2007-01-21 22:31:51 +0000
committerKeri Harris <keri@gentoo.org>2007-01-21 22:31:51 +0000
commitc5003b1e3cca581c3bcd7cd42ea85263ce3e947d (patch)
tree4ffe0fa080204f603dbc6d02f809995e05977935 /dev-lang/tuprolog
parentNew package, part of split-ant-1.7.0, bug #159820. (diff)
downloadgentoo-2-c5003b1e3cca581c3bcd7cd42ea85263ce3e947d.tar.gz
gentoo-2-c5003b1e3cca581c3bcd7cd42ea85263ce3e947d.tar.bz2
gentoo-2-c5003b1e3cca581c3bcd7cd42ea85263ce3e947d.zip
Fix deprecated code and javadoc warnings.
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-lang/tuprolog')
-rw-r--r--dev-lang/tuprolog/ChangeLog8
-rw-r--r--dev-lang/tuprolog/files/tuprolog-2.0-java1.4.patch164
-rw-r--r--dev-lang/tuprolog/files/tuprolog-2.0-javadocs.patch203
-rw-r--r--dev-lang/tuprolog/tuprolog-2.0.ebuild11
4 files changed, 380 insertions, 6 deletions
diff --git a/dev-lang/tuprolog/ChangeLog b/dev-lang/tuprolog/ChangeLog
index d36d92ca9672..74d540f03d1e 100644
--- a/dev-lang/tuprolog/ChangeLog
+++ b/dev-lang/tuprolog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tuprolog
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/ChangeLog,v 1.7 2006/10/31 08:06:59 keri Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/ChangeLog,v 1.8 2007/01/21 22:31:51 keri Exp $
+
+ 21 Jan 2007; keri <keri@gentoo.org> +files/tuprolog-2.0-java1.4.patch,
+ +files/tuprolog-2.0-javadocs.patch, tuprolog-2.0.ebuild:
+ Fix deprecated code and javadoc warnings.
*tuprolog-2.0 (31 Oct 2006)
diff --git a/dev-lang/tuprolog/files/tuprolog-2.0-java1.4.patch b/dev-lang/tuprolog/files/tuprolog-2.0-java1.4.patch
new file mode 100644
index 000000000000..8bfb717e89bd
--- /dev/null
+++ b/dev-lang/tuprolog/files/tuprolog-2.0-java1.4.patch
@@ -0,0 +1,164 @@
+diff -ur src.orig/alice/tuprologx/ide/AWTFrameLauncher.java src/alice/tuprologx/ide/AWTFrameLauncher.java
+--- src.orig/alice/tuprologx/ide/AWTFrameLauncher.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprologx/ide/AWTFrameLauncher.java 2007-01-22 09:53:52.000000000 +1300
+@@ -88,7 +88,7 @@
+ height = Math.min(height, screenSize.height);
+ setBounds((screenSize.width - width) / 2, (screenSize.height - height) / 2, width, height);
+ }
+- show();
++ setVisible(true);
+ }
+
+ public void update(Graphics g) {
+diff -ur src.orig/alice/tuprologx/ide/Applet.java src/alice/tuprologx/ide/Applet.java
+--- src.orig/alice/tuprologx/ide/Applet.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprologx/ide/Applet.java 2007-01-22 09:53:52.000000000 +1300
+@@ -41,7 +41,7 @@
+ ide.removeWindowListener(listeners[i]);
+
+ ide.pack();
+- ide.show();
++ ide.setVisible(true);
+ }
+
+ } // end Applet class
+\ No newline at end of file
+diff -ur src.orig/alice/tuprologx/ide/DotNetIOManager.java src/alice/tuprologx/ide/DotNetIOManager.java
+--- src.orig/alice/tuprologx/ide/DotNetIOManager.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprologx/ide/DotNetIOManager.java 2007-01-22 09:53:52.000000000 +1300
+@@ -46,7 +46,7 @@
+ FileDialog dialog = new FileDialog(parent, "Load Theory", FileDialog.LOAD);
+ dialog.setDirectory(currentLoadDirectory);
+ dialog.setFile("*.pro");
+- dialog.show();
++ dialog.setVisible(true);
+ String directory = dialog.getDirectory();
+ currentLoadDirectory = directory;
+ String fileName = dialog.getFile();
+@@ -61,7 +61,7 @@
+ public String saveTheoryAs(String theory) throws Exception {
+ FileDialog dialog = new FileDialog(parent, "Save Theory As...", FileDialog.SAVE);
+ dialog.setDirectory(currentSaveDirectory);
+- dialog.show();
++ dialog.setVisible(true);
+ String directory = dialog.getDirectory();
+ currentSaveDirectory = directory;
+ String fileName = dialog.getFile();
+diff -ur src.orig/alice/tuprologx/ide/GUILauncher.java src/alice/tuprologx/ide/GUILauncher.java
+--- src.orig/alice/tuprologx/ide/GUILauncher.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprologx/ide/GUILauncher.java 2007-01-22 09:53:52.000000000 +1300
+@@ -74,7 +74,7 @@
+ private void launchDotNetGUI() {
+ DotNetIDE ide = new DotNetIDE();
+ ide.pack();
+- ide.show();
++ ide.setVisible(true);
+ }
+
+ /**
+diff -ur src.orig/alice/util/jedit/JEditTextArea.java src/alice/util/jedit/JEditTextArea.java
+--- src.orig/alice/util/jedit/JEditTextArea.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/JEditTextArea.java 2007-01-22 10:59:07.000000000 +1300
+@@ -115,10 +115,10 @@
+ * Returns if this component can be traversed by pressing
+ * the Tab key. This returns false.
+ */
+- public final boolean isManagingFocus()
++ /*public final boolean isManagingFocus()
+ {
+ return true;
+- }
++ }*/
+
+ /**
+ * Returns the object responsible for painting this text area.
+@@ -507,7 +507,7 @@
+ if(id == Token.NULL)
+ fm = painter.getFontMetrics();
+ else
+- fm = styles[id].getFontMetrics(defaultFont);
++ fm = styles[id].getFontMetrics(painter, defaultFont);
+
+ int length = tokens.length;
+
+@@ -604,7 +604,7 @@
+ if(id == Token.NULL)
+ fm = painter.getFontMetrics();
+ else
+- fm = styles[id].getFontMetrics(defaultFont);
++ fm = styles[id].getFontMetrics(painter, defaultFont);
+
+ int length = tokens.length;
+
+diff -ur src.orig/alice/util/jedit/SyntaxStyle.java src/alice/util/jedit/SyntaxStyle.java
+--- src.orig/alice/util/jedit/SyntaxStyle.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/SyntaxStyle.java 2007-01-22 11:03:42.000000000 +1300
+@@ -9,6 +9,7 @@
+ package alice.util.jedit;
+
+ import java.awt.*;
++import javax.swing.*;
+ import java.util.StringTokenizer;
+
+ /**
+@@ -86,7 +87,7 @@
+ /**
+ * Returns the font metrics for the styled font.
+ */
+- public FontMetrics getFontMetrics(Font font)
++ public FontMetrics getFontMetrics(JComponent component, Font font)
+ {
+ if(font == null)
+ throw new NullPointerException("font param must not"
+@@ -98,7 +99,7 @@
+ (bold ? Font.BOLD : 0)
+ | (italic ? Font.ITALIC : 0),
+ font.getSize());
+- fontMetrics = Toolkit.getDefaultToolkit().getFontMetrics(
++ fontMetrics = component.getFontMetrics(
+ lastStyledFont);
+ return fontMetrics;
+ }
+diff -ur src.orig/alice/util/jedit/TextAreaPainter.java src/alice/util/jedit/TextAreaPainter.java
+--- src.orig/alice/util/jedit/TextAreaPainter.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/TextAreaPainter.java 2007-01-22 10:42:10.000000000 +1300
+@@ -67,10 +67,10 @@
+ * Returns if this component can be traversed by pressing the
+ * Tab key. This returns false.
+ */
+- public final boolean isManagingFocus()
++ /*public final boolean isManagingFocus()
+ {
+ return false;
+- }
++ }*/
+
+ /**
+ * Returns the syntax styles used to paint colorized text. Entry <i>n</i>
+@@ -350,7 +350,7 @@
+ public void setFont(Font font)
+ {
+ super.setFont(font);
+- fm = Toolkit.getDefaultToolkit().getFontMetrics(font);
++ fm = getFontMetrics(font);
+ textArea.recalculateVisibleLines();
+ }
+
+diff -ur src.orig/alice/util/thinlet/Thinlet.java src/alice/util/thinlet/Thinlet.java
+--- src.orig/alice/util/thinlet/Thinlet.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/thinlet/Thinlet.java 2007-01-22 09:55:25.000000000 +1300
+@@ -1,4 +1,4 @@
+-/* áÁÕôÛûÍí
++/* ����
+ Thinlet GUI toolkit - www.thinlet.com
+ Copyright (C) 2002 Robert Bajzat (robert.bajzat@thinlet.com)
+
+@@ -2157,7 +2157,7 @@
+ *
+ * @return true as focus-transverable component, overwrites the default false value
+ */
+- public boolean isFocusTraversable() {
++ public boolean isFocusable() {
+ return true;
+ }
+
diff --git a/dev-lang/tuprolog/files/tuprolog-2.0-javadocs.patch b/dev-lang/tuprolog/files/tuprolog-2.0-javadocs.patch
new file mode 100644
index 000000000000..e89692feaaac
--- /dev/null
+++ b/dev-lang/tuprolog/files/tuprolog-2.0-javadocs.patch
@@ -0,0 +1,203 @@
+diff -ur src.orig/alice/tuprolog/BuiltIn.java src/alice/tuprolog/BuiltIn.java
+--- src.orig/alice/tuprolog/BuiltIn.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/BuiltIn.java 2007-01-22 11:07:57.000000000 +1300
+@@ -88,7 +88,6 @@
+
+ /**
+ * usata per la retract in basicLibrary
+- * @return
+ */
+ public boolean $restore_db_0() {
+ theoryManager.transRestore(engineManager.restoreLastTheoryStatus());
+diff -ur src.orig/alice/tuprolog/ChoicePointStore.java src/alice/tuprolog/ChoicePointStore.java
+--- src.orig/alice/tuprolog/ChoicePointStore.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/ChoicePointStore.java 2007-01-22 11:07:58.000000000 +1300
+@@ -35,7 +35,6 @@
+
+ /**
+ * Return the actual choice-point store
+- * @return
+ */
+ public ChoicePointContext getPointer() {
+ return pointer;
+@@ -44,7 +43,6 @@
+ /**
+ * Check if a choice point exists in the store.
+ * As a side effect, removes choice points which have been already used and are now empty.
+- * @return
+ */
+ protected boolean existChoicePoint() {
+ if (pointer == null) return false;
+diff -ur src.orig/alice/tuprolog/ClauseStore.java src/alice/tuprolog/ClauseStore.java
+--- src.orig/alice/tuprolog/ClauseStore.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/ClauseStore.java 2007-01-22 11:07:58.000000000 +1300
+@@ -58,8 +58,6 @@
+
+ /**
+ * Verify if there is a term in compatibleGoals compatible with goal.
+- * @param goal
+- * @param compGoals
+ * @return true if compatible or false otherwise.
+ */
+ protected boolean existCompatibleClause() {
+diff -ur src.orig/alice/tuprolog/EngineManager.java src/alice/tuprolog/EngineManager.java
+--- src.orig/alice/tuprolog/EngineManager.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/EngineManager.java 2007-01-22 11:07:58.000000000 +1300
+@@ -81,7 +81,7 @@
+ /**
+ * Solves a query
+ *
+- * @param g the term representing the goal to be demonstrated
++ * @param query the term representing the goal to be demonstrated
+ * @return the result of the demonstration
+ * @see SolveInfo
+ **/
+diff -ur src.orig/alice/tuprolog/PrimitiveManager.java src/alice/tuprolog/PrimitiveManager.java
+--- src.orig/alice/tuprolog/PrimitiveManager.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/PrimitiveManager.java 2007-01-22 11:07:58.000000000 +1300
+@@ -89,7 +89,7 @@
+ * This involves identifying structs representing builtin
+ * predicates and functors, and setting up related structures and links
+ *
+- * @parm term the term to be identified
++ * @param term the term to be identified
+ */
+ public void identifyDirective(Term term) {
+ identify(term,PrimitiveInfo.DIRECTIVE);
+diff -ur src.orig/alice/tuprolog/lib/BasicLibrary.java src/alice/tuprolog/lib/BasicLibrary.java
+--- src.orig/alice/tuprolog/lib/BasicLibrary.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/lib/BasicLibrary.java 2007-01-22 11:11:44.000000000 +1300
+@@ -96,7 +96,7 @@
+ /**
+ * Loads a library constructed from a theory.
+ *
+- * @param theory theory text
++ * @param th theory text
+ * @param libName name of the library
+ * @return true if the library has been succesfully loaded.
+ */
+@@ -173,16 +173,16 @@
+ return true;
+ }
+
+- public boolean warning_0() {
+- getEngine().setWarning(true);
+- return true;
+- }
+-
+- public boolean nowarning_0() {
+- getEngine().setWarning(false);
+- return true;
+- }
+-
++ public boolean warning_0() {
++ getEngine().setWarning(true);
++ return true;
++ }
++
++ public boolean nowarning_0() {
++ getEngine().setWarning(false);
++ return true;
++ }
++
+ //
+ // term type inspection
+ //
+diff -ur src.orig/alice/tuprolog/lib/JavaLibrary.java src/alice/tuprolog/lib/JavaLibrary.java
+--- src.orig/alice/tuprolog/lib/JavaLibrary.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/tuprolog/lib/JavaLibrary.java 2007-01-22 11:07:58.000000000 +1300
+@@ -1227,7 +1227,6 @@
+
+ /**
+ * Generates a fresh numeric identifier
+- * @return
+ */
+ protected Struct generateFreshId() {
+ return new Struct("$obj_" + id++);
+diff -ur src.orig/alice/util/jedit/InputHandler.java src/alice/util/jedit/InputHandler.java
+--- src.orig/alice/util/jedit/InputHandler.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/InputHandler.java 2007-01-22 11:13:33.000000000 +1300
+@@ -24,7 +24,7 @@
+ *
+ * @author Slava Pestov
+ * @version $Id: tuprolog-2.0-javadocs.patch,v 1.1 2007/01/21 22:31:51 keri Exp $
+- * @see org.gjt.sp.jedit.textarea.DefaultInputHandler
++ * @see alice.util.jedit.DefaultInputHandler
+ */
+ public abstract class InputHandler extends KeyAdapter
+ {
+@@ -187,7 +187,7 @@
+ /**
+ * Grabs the next key typed event and invokes the specified
+ * action with the key as a the action command.
+- * @param action The action
++ * @param listener The action
+ */
+ public void grabNextKeyStroke(ActionListener listener)
+ {
+diff -ur src.orig/alice/util/jedit/JEditTextArea.java src/alice/util/jedit/JEditTextArea.java
+--- src.orig/alice/util/jedit/JEditTextArea.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/JEditTextArea.java 2007-01-22 11:14:18.000000000 +1300
+@@ -1389,7 +1389,7 @@
+
+ /**
+ * Sets if the selection should be rectangular.
+- * @param overwrite True if the selection should be rectangular,
++ * @param rectSelect True if the selection should be rectangular,
+ * false otherwise.
+ */
+ public final void setSelectionRectangular(boolean rectSelect)
+diff -ur src.orig/alice/util/jedit/KeywordMap.java src/alice/util/jedit/KeywordMap.java
+--- src.orig/alice/util/jedit/KeywordMap.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/KeywordMap.java 2007-01-22 11:14:52.000000000 +1300
+@@ -75,7 +75,7 @@
+ /**
+ * Adds a key-value mapping.
+ * @param keyword The key
+- * @Param id The value
++ * @param id The value
+ */
+ public void add(String keyword, byte id)
+ {
+diff -ur src.orig/alice/util/jedit/TextAreaPainter.java src/alice/util/jedit/TextAreaPainter.java
+--- src.orig/alice/util/jedit/TextAreaPainter.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/TextAreaPainter.java 2007-01-22 11:17:22.000000000 +1300
+@@ -75,7 +75,7 @@
+ /**
+ * Returns the syntax styles used to paint colorized text. Entry <i>n</i>
+ * will be used to paint tokens with id = <i>n</i>.
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public final SyntaxStyle[] getStyles()
+ {
+@@ -86,7 +86,7 @@
+ * Sets the syntax styles used to paint colorized text. Entry <i>n</i>
+ * will be used to paint tokens with id = <i>n</i>.
+ * @param styles The syntax styles
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public final void setStyles(SyntaxStyle[] styles)
+ {
+@@ -356,7 +356,7 @@
+
+ /**
+ * Repaints the text.
+- * @param g The graphics context
++ * @param gfx The graphics context
+ */
+ public void paint(Graphics gfx)
+ {
+diff -ur src.orig/alice/util/jedit/TokenMarker.java src/alice/util/jedit/TokenMarker.java
+--- src.orig/alice/util/jedit/TokenMarker.java 2006-10-30 12:45:16.000000000 +1300
++++ src/alice/util/jedit/TokenMarker.java 2007-01-22 11:17:55.000000000 +1300
+@@ -24,7 +24,7 @@
+ * @author Slava Pestov
+ * @version $Id: tuprolog-2.0-javadocs.patch,v 1.1 2007/01/21 22:31:51 keri Exp $
+ *
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public abstract class TokenMarker
+ {
diff --git a/dev-lang/tuprolog/tuprolog-2.0.ebuild b/dev-lang/tuprolog/tuprolog-2.0.ebuild
index 470095e18adb..ba5c534aa53d 100644
--- a/dev-lang/tuprolog/tuprolog-2.0.ebuild
+++ b/dev-lang/tuprolog/tuprolog-2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/tuprolog-2.0.ebuild,v 1.1 2006/10/31 08:06:59 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/tuprolog-2.0.ebuild,v 1.2 2007/01/21 22:31:51 keri Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -16,15 +16,18 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE="doc"
-DEPEND=">=virtual/jdk-1.3
+DEPEND=">=virtual/jdk-1.4
app-arch/unzip
dev-java/ant-core"
-RDEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jdk-1.4"
S="${WORKDIR}"
src_unpack() {
unpack ${A}
+ epatch "${FILESDIR}"/${P}-java1.4.patch
+ epatch "${FILESDIR}"/${P}-javadocs.patch
+
cd "${S}"
cp "${FILESDIR}"/build.xml "${S}"
}