summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-06-08 07:37:44 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-06-08 07:37:44 +0000
commitd08924c773df05d5984683849d5ae92c69015414 (patch)
treeab35933de7a5f43f562f2fee335eea09e94de0e4 /dev-lang/v8
parentFix underlinking wrt #368927 by Diego Elio Pettenò <flameeyes@gentoo.org> (diff)
downloadgentoo-2-d08924c773df05d5984683849d5ae92c69015414.tar.gz
gentoo-2-d08924c773df05d5984683849d5ae92c69015414.tar.bz2
gentoo-2-d08924c773df05d5984683849d5ae92c69015414.zip
Version bump for stable channel release. Fails tests. Remove old.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/files/v8-upstream-bug-1326-r0.patch14
-rw-r--r--dev-lang/v8/v8-3.2.10.15.ebuild (renamed from dev-lang/v8/v8-3.2.3.1.ebuild)10
3 files changed, 28 insertions, 4 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 2e347a53aaed..f7aa1e70009f 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.58 2011/05/24 08:04:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.59 2011/06/08 07:37:44 phajdan.jr Exp $
+
+*v8-3.2.10.15 (08 Jun 2011)
+
+ 08 Jun 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-3.2.3.1.ebuild,
+ +v8-3.2.10.15.ebuild, +files/v8-upstream-bug-1326-r0.patch:
+ Version bump for stable channel release. Fails tests. Remove old.
24 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-3.1.8.12.ebuild,
v8-3.2.3.1.ebuild, v8-3.2.8.2.ebuild, v8-3.3.4.ebuild, v8-9999.ebuild:
diff --git a/dev-lang/v8/files/v8-upstream-bug-1326-r0.patch b/dev-lang/v8/files/v8-upstream-bug-1326-r0.patch
new file mode 100644
index 000000000000..68cf5393cc36
--- /dev/null
+++ b/dev-lang/v8/files/v8-upstream-bug-1326-r0.patch
@@ -0,0 +1,14 @@
+Index: src/d8-readline.cc
+diff --git a/src/d8-readline.cc b/src/d8-readline.cc
+index 67fc9eff7e528fd66dba1e724f2e42909dd76668..08395e53de103aa481aa2752bdf94db15bdbc0ad 100644
+--- a/src/d8-readline.cc
++++ b/src/d8-readline.cc
+@@ -30,6 +30,8 @@
+ #include <readline/readline.h> // NOLINT
+ #include <readline/history.h> // NOLINT
+
++// The readline includes leaves RETURN defined which breaks V8 compilation.
++#undef RETURN
+
+ #include "d8.h"
+
diff --git a/dev-lang/v8/v8-3.2.3.1.ebuild b/dev-lang/v8/v8-3.2.10.15.ebuild
index 2a7bbb79dcea..5cb5f8fe0da3 100644
--- a/dev-lang/v8/v8-3.2.3.1.ebuild
+++ b/dev-lang/v8/v8-3.2.10.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.2.3.1.ebuild,v 1.3 2011/05/24 08:04:01 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.2.10.15.ebuild,v 1.1 2011/06/08 07:37:44 phajdan.jr Exp $
EAPI="2"
@@ -32,6 +32,9 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+ # Backport a compile fix.
+ epatch "${FILESDIR}"/${PN}-upstream-bug-1326-r0.patch
+
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die
@@ -47,9 +50,10 @@ src_configure() {
}
src_compile() {
- # To make tests work, we compile with sample=shell.
+ # To make tests work, we compile with sample=shell and visibility=default.
# For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
- local myconf="library=shared soname=on sample=shell importenv=\"LINKFLAGS\""
+ # and http://groups.google.com/group/v8-users/browse_thread/thread/165f89728ed6f97d
+ local myconf="library=shared soname=on sample=shell visibility=default importenv=LINKFLAGS,PATH"
# Use target arch detection logic from bug #354601.
case ${CHOST} in