summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2009-01-17 03:30:45 +0000
committerKeri Harris <keri@gentoo.org>2009-01-17 03:30:45 +0000
commit2da9f855cec3b56d3899b85b9b5cb642795667ed (patch)
tree5704853031a028df9d50b3785b963fc4430fc128 /dev-lang/yap
parentversion bump that fixes security vulnerability (dkim validation weakness - se... (diff)
downloadgentoo-2-2da9f855cec3b56d3899b85b9b5cb642795667ed.tar.gz
gentoo-2-2da9f855cec3b56d3899b85b9b5cb642795667ed.tar.bz2
gentoo-2-2da9f855cec3b56d3899b85b9b5cb642795667ed.zip
Install Prolog library examples
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 x86_64)
Diffstat (limited to 'dev-lang/yap')
-rw-r--r--dev-lang/yap/ChangeLog6
-rw-r--r--dev-lang/yap/files/yap-5.1.3-clpbn-examples.patch13
-rw-r--r--dev-lang/yap/yap-5.1.3-r1.ebuild14
3 files changed, 28 insertions, 5 deletions
diff --git a/dev-lang/yap/ChangeLog b/dev-lang/yap/ChangeLog
index 35b805123e2e..cdb502f3c537 100644
--- a/dev-lang/yap/ChangeLog
+++ b/dev-lang/yap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/yap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.23 2009/01/16 08:42:13 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.24 2009/01/17 03:30:43 keri Exp $
+
+ 17 Jan 2009; <keri@gentoo.org> +files/yap-5.1.3-clpbn-examples.patch,
+ yap-5.1.3-r1.ebuild:
+ Install Prolog library examples
*yap-5.1.3-r1 (16 Jan 2009)
diff --git a/dev-lang/yap/files/yap-5.1.3-clpbn-examples.patch b/dev-lang/yap/files/yap-5.1.3-clpbn-examples.patch
new file mode 100644
index 000000000000..9427efdddc46
--- /dev/null
+++ b/dev-lang/yap/files/yap-5.1.3-clpbn-examples.patch
@@ -0,0 +1,13 @@
+--- Yap-5.1.3.orig/CLPBN/Makefile.in 2008-03-27 13:41:32.000000000 +1300
++++ Yap-5.1.3/CLPBN/Makefile.in 2009-01-17 16:24:29.000000000 +1300
+@@ -72,10 +72,7 @@
+ install: $(CLBN_TOP) $(CLBN_PROGRAMS) $(CLPBN_PROGRAMS)
+ mkdir -p $(DESTDIR)$(SHAREDIR)/clpbn
+ mkdir -p $(DESTDIR)$(SHAREDIR)/clpbn/learning
+- mkdir -p $(DESTDIR)$(SHAREDIR)/clpbn/examples/School
+ for h in $(CLPBN_TOP); do $(INSTALL_DATA) $$h $(DESTDIR)$(SHAREDIR); done
+ for h in $(CLPBN_PROGRAMS); do $(INSTALL_DATA) $$h $(DESTDIR)$(SHAREDIR)/clpbn; done
+ for h in $(CLPBN_LEARNING_PROGRAMS); do $(INSTALL_DATA) $$h $(DESTDIR)$(SHAREDIR)/clpbn/learning; done
+- for h in $(CLPBN_EXAMPLES); do $(INSTALL_DATA) $$h $(DESTDIR)$(SHAREDIR)/clpbn/examples; done
+- for h in $(CLPBN_SCHOOL_EXAMPLES); do $(INSTALL_DATA) $$h $(DESTDIR)$(SHAREDIR)/clpbn/examples/School; done
+
diff --git a/dev-lang/yap/yap-5.1.3-r1.ebuild b/dev-lang/yap/yap-5.1.3-r1.ebuild
index 4711c6970988..81d3a0704599 100644
--- a/dev-lang/yap/yap-5.1.3-r1.ebuild
+++ b/dev-lang/yap/yap-5.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.3-r1.ebuild,v 1.1 2009/01/16 08:42:13 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.3-r1.ebuild,v 1.2 2009/01/17 03:30:43 keri Exp $
inherit autotools eutils java-pkg-opt-2
@@ -37,6 +37,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-parallel-make.patch
epatch "${FILESDIR}"/${P}-bootdir.patch
epatch "${FILESDIR}"/${P}-chr.patch
+ epatch "${FILESDIR}"/${P}-clpbn-examples.patch
epatch "${FILESDIR}"/${P}-tkyap.patch
eautoconf
@@ -84,8 +85,13 @@ src_install() {
fi
if use examples ; then
- docinto examples
- dodoc CLPBN/clpbn/examples/cg.yap
- dodoc CLPBN/clpbn/examples/School/*
+ docinto examples/clpbn
+ dodoc CLPBN/clpbn/examples/*.yap
+ docinto examples/clpbn/school
+ dodoc CLPBN/clpbn/examples/School/*.yap
+ if use mpi ; then
+ docinto examples/mpi
+ dodoc library/mpi/examples/*.pl
+ fi
fi
}