summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2006-10-27 06:10:04 +0000
committerPeter Johanson <latexer@gentoo.org>2006-10-27 06:10:04 +0000
commit0368126f3d1d4c1eab24bb820b231bcbd8097d37 (patch)
tree4188c517685e434c90f779f0454c74348dace50f /dev-lang
parentamd64 stable, bug 144170 (diff)
downloadgentoo-2-0368126f3d1d4c1eab24bb820b231bcbd8097d37.tar.gz
gentoo-2-0368126f3d1d4c1eab24bb820b231bcbd8097d37.tar.bz2
gentoo-2-0368126f3d1d4c1eab24bb820b231bcbd8097d37.zip
Fix nasty bug in mcs cause banshee not to compile. See bug #152843.
(Portage version: 2.1.2_pre2-r8)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog6
-rw-r--r--dev-lang/mono/files/mono-1.1.18-mcs-crasher-fix.diff12
-rw-r--r--dev-lang/mono/mono-1.1.18.ebuild7
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 32cce772051b..170d46cf251a 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.92 2006/10/22 18:42:50 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.93 2006/10/27 06:10:03 latexer Exp $
+
+ 27 Oct 2006; Peter Johanson <latexer@gentoo.org>
+ +files/mono-1.1.18-mcs-crasher-fix.diff, mono-1.1.18.ebuild:
+ Fix nasty bug in mcs cause banshee not to compile. See bug #152843.
22 Oct 2006; Jurek Bartuszek <jurek@gentoo.org> mono-1.1.18.ebuild:
Updated dependency for libgdiplus (was >=1.1.17, is >=1.1.18).
diff --git a/dev-lang/mono/files/mono-1.1.18-mcs-crasher-fix.diff b/dev-lang/mono/files/mono-1.1.18-mcs-crasher-fix.diff
new file mode 100644
index 000000000000..c3aaec8a03a5
--- /dev/null
+++ b/dev-lang/mono/files/mono-1.1.18-mcs-crasher-fix.diff
@@ -0,0 +1,12 @@
+Index: mcs/anonymous.cs
+===================================================================
+--- mcs/anonymous.cs (revision 66810)
++++ mcs/anonymous.cs (revision 66811)
+@@ -1232,6 +1232,7 @@
+
+ aec.CurrentAnonymousMethod = this;
+ aec.IsFieldInitializer = ec.IsFieldInitializer;
++ aec.IsStatic = ec.IsStatic;
+
+ Report.Debug (64, "RESOLVE ANONYMOUS METHOD #1", this, Location, ec, aec,
+ RootScope, Parameters, Block);
diff --git a/dev-lang/mono/mono-1.1.18.ebuild b/dev-lang/mono/mono-1.1.18.ebuild
index e3fc9eff77d5..d366bf8c666b 100644
--- a/dev-lang/mono/mono-1.1.18.ebuild
+++ b/dev-lang/mono/mono-1.1.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.18.ebuild,v 1.2 2006/10/22 18:42:50 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.18.ebuild,v 1.3 2006/10/27 06:10:03 latexer Exp $
inherit eutils flag-o-matic multilib autotools
@@ -37,6 +37,11 @@ function get-memory-total() {
src_unpack() {
unpack ${A}
+
+ # Fix mcs crasher
+ cd ${S}/mcs
+ epatch ${FILESDIR}/${P}-mcs-crasher-fix.diff
+
cd ${S}
# Fix the install path, install into $(libdir)