summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-07-19 14:33:44 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-07-19 14:33:44 +0000
commit0a6854f9d0fb9b27d5b3e7a3727f0c61a0987c1a (patch)
tree8b48140a64809ff5fba541a650c7ee873088caab /dev-lang
parentStable for HPPA (bug #231074). (diff)
downloadgentoo-2-0a6854f9d0fb9b27d5b3e7a3727f0c61a0987c1a.tar.gz
gentoo-2-0a6854f9d0fb9b27d5b3e7a3727f0c61a0987c1a.tar.bz2
gentoo-2-0a6854f9d0fb9b27d5b3e7a3727f0c61a0987c1a.zip
build-time-specific (no revbump): fixing warnings (which sometimes seem to be fatal) regarding to missing function prototypes because of _GNU_SOURCE being defined too late (bug 230809)
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r5 x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/php-5.2.6-r5.ebuild9
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 4dbcf2680656..06bb2b3be40f 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.278 2008/07/17 13:54:24 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.279 2008/07/19 14:33:44 hoffie Exp $
+
+ 19 Jul 2008; Christian Hoffmann <hoffie@gentoo.org> php-5.2.6-r5.ebuild:
+ build-time-specific (no revbump): fixing warnings (which sometimes seem to
+ be fatal) regarding to missing function prototypes because of _GNU_SOURCE
+ being defined too late (bug 230809)
*php-5.2.6-r5 (17 Jul 2008)
diff --git a/dev-lang/php/php-5.2.6-r5.ebuild b/dev-lang/php/php-5.2.6-r5.ebuild
index 77bca8ec7ff6..67af697e99fc 100644
--- a/dev-lang/php/php-5.2.6-r5.ebuild
+++ b/dev-lang/php/php-5.2.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.6-r5.ebuild,v 1.1 2008/07/17 13:54:24 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.6-r5.ebuild,v 1.2 2008/07/19 14:33:44 hoffie Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -20,7 +20,7 @@ MY_PHP_P="php-${MY_PHP_PV}"
PHP_PACKAGE="1"
# php patch settings, general
-PHP_PATCHSET_REV="4"
+PHP_PATCHSET_REV="5"
SUHOSIN_PATCH="suhosin-patch-5.2.6-0.9.6.2-r1.patch.gz"
MULTILIB_PATCH="${MY_PHP_PV}/opt/multilib-search-path.patch"
# php patch settings, ebuild specific
@@ -169,9 +169,6 @@ src_unpack() {
ext/standard/tests/file/006_error.phpt \
ext/standard/tests/file/touch.phpt
- # Workaround for autoconf-2.62 behaviour change, bug 217392
- sed -re 's:(#ifdef HAVE_CONFIG_H.*):#define _GNU_SOURCE\n\1:' -i ext/posix/posix.c
-
# REMOVING BROKEN TESTS:
# removing this test as it has been broken for ages and is not easily
# fixable (depends on a lot of factors)
@@ -194,6 +191,8 @@ src_unpack() {
}
src_compile() {
+ # bug 217392 (autconf-2.62 behavior changes)
+ append-flags -D_GNU_SOURCE
if use fastbuild && [[ -n "${FASTBUILD_PATCH}" ]] ; then
src_compile_fastbuild
else