summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2011-12-14 22:48:49 +0000
committerMatti Bickel <mabi@gentoo.org>2011-12-14 22:48:49 +0000
commit0bc60b545f24399683bdf15dc221f7d6590e1a74 (patch)
treeaf378dc4f409446184ca11f8a28c1d43cbb6e60f /dev-lang
parentAdd missing libpcre rdep. (diff)
downloadgentoo-2-0bc60b545f24399683bdf15dc221f7d6590e1a74.tar.gz
gentoo-2-0bc60b545f24399683bdf15dc221f7d6590e1a74.tar.bz2
gentoo-2-0bc60b545f24399683bdf15dc221f7d6590e1a74.zip
Merging categories dev-php5 and dev-php (bug #324665)
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/php-5.2.17.ebuild4
-rw-r--r--dev-lang/php/php-5.3.8.ebuild16
-rw-r--r--dev-lang/php/php-5.3.9_rc1.ebuild16
-rw-r--r--dev-lang/php/php-5.3.9_rc2.ebuild16
-rw-r--r--dev-lang/php/php-5.4.0_rc3.ebuild16
6 files changed, 40 insertions, 35 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 14fb094534f8..5eb2bbe7602e 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.527 2011/12/09 20:19:24 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.528 2011/12/14 22:48:49 mabi Exp $
+
+ 14 Dec 2011; Matti Bickel <mabi@gentoo.org> php-5.2.17.ebuild,
+ php-5.3.8.ebuild, php-5.3.9_rc1.ebuild, php-5.3.9_rc2.ebuild,
+ php-5.4.0_rc3.ebuild:
+ Merging categories dev-php5 and dev-php (bug #324665)
09 Dec 2011; Ole Markus With <olemarkus@gentoo.org>
-files/eblits/pkg_postinst-v2.eblit, php-5.2.17.ebuild, php-5.3.8.ebuild,
diff --git a/dev-lang/php/php-5.2.17.ebuild b/dev-lang/php/php-5.2.17.ebuild
index f94ccdc1ddc3..58fc056a8edc 100644
--- a/dev-lang/php/php-5.2.17.ebuild
+++ b/dev-lang/php/php-5.2.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.17.ebuild,v 1.16 2011/12/09 20:19:24 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.17.ebuild,v 1.17 2011/12/14 22:48:49 mabi Exp $
EAPI=2
@@ -383,7 +383,7 @@ pkg_postinst() {
if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
ewarn "The suhosin USE flag now only installs the suhosin patch!"
ewarn "If you want the suhosin extension, make sure you install"
- ewarn " dev-php5/suhosin"
+ ewarn " dev-php/suhosin"
ewarn
fi
}
diff --git a/dev-lang/php/php-5.3.8.ebuild b/dev-lang/php/php-5.3.8.ebuild
index 159630d3fecc..15cdb1c503cd 100644
--- a/dev-lang/php/php-5.3.8.ebuild
+++ b/dev-lang/php/php-5.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.8.ebuild,v 1.11 2011/12/09 20:19:24 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.8.ebuild,v 1.12 2011/12/14 22:48:49 mabi Exp $
EAPI=4
@@ -247,12 +247,12 @@ REQUIRED_USE="
!cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
DEPEND="${DEPEND}
- enchant? ( !dev-php5/pecl-enchant )
- fileinfo? ( !<dev-php5/pecl-fileinfo-1.0.4-r2 )
- filter? ( !dev-php5/pecl-filter )
- json? ( !dev-php5/pecl-json )
- phar? ( !dev-php5/pecl-phar )
- zip? ( !dev-php5/pecl-zip )"
+ enchant? ( !dev-php/pecl-enchant )
+ fileinfo? ( !<dev-php/pecl-fileinfo-1.0.4-r2 )
+ filter? ( !dev-php/pecl-filter )
+ json? ( !dev-php/pecl-json )
+ phar? ( !dev-php/pecl-phar )
+ zip? ( !dev-php/pecl-zip )"
[[ -n $SUHOSIN_VERSION ]] && RDEPEND="${RDEPEND} suhosin? (
=${CATEGORY}/${PN}-${SLOT}*[unicode] )"
@@ -408,7 +408,7 @@ pkg_postinst() {
if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
ewarn "The suhosin USE flag now only installs the suhosin patch!"
ewarn "If you want the suhosin extension, make sure you install"
- ewarn " dev-php5/suhosin"
+ ewarn " dev-php/suhosin"
ewarn
fi
}
diff --git a/dev-lang/php/php-5.3.9_rc1.ebuild b/dev-lang/php/php-5.3.9_rc1.ebuild
index 1e3860f3a807..a2530e1ae8c6 100644
--- a/dev-lang/php/php-5.3.9_rc1.ebuild
+++ b/dev-lang/php/php-5.3.9_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.9_rc1.ebuild,v 1.3 2011/12/09 18:23:44 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.9_rc1.ebuild,v 1.4 2011/12/14 22:48:49 mabi Exp $
EAPI=4
@@ -247,12 +247,12 @@ REQUIRED_USE="
!cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
DEPEND="${DEPEND}
- enchant? ( !dev-php5/pecl-enchant )
- fileinfo? ( !<dev-php5/pecl-fileinfo-1.0.4-r2 )
- filter? ( !dev-php5/pecl-filter )
- json? ( !dev-php5/pecl-json )
- phar? ( !dev-php5/pecl-phar )
- zip? ( !dev-php5/pecl-zip )"
+ enchant? ( !dev-php/pecl-enchant )
+ fileinfo? ( !<dev-php/pecl-fileinfo-1.0.4-r2 )
+ filter? ( !dev-php/pecl-filter )
+ json? ( !dev-php/pecl-json )
+ phar? ( !dev-php/pecl-phar )
+ zip? ( !dev-php/pecl-zip )"
[[ -n $SUHOSIN_VERSION ]] && RDEPEND="${RDEPEND} suhosin? (
=${CATEGORY}/${PN}-${SLOT}*[unicode] )"
@@ -408,7 +408,7 @@ pkg_postinst() {
if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
ewarn "The suhosin USE flag now only installs the suhosin patch!"
ewarn "If you want the suhosin extension, make sure you install"
- ewarn " dev-php5/suhosin"
+ ewarn " dev-php/suhosin"
ewarn
fi
}
diff --git a/dev-lang/php/php-5.3.9_rc2.ebuild b/dev-lang/php/php-5.3.9_rc2.ebuild
index 7c1777036345..dd7ff88c664f 100644
--- a/dev-lang/php/php-5.3.9_rc2.ebuild
+++ b/dev-lang/php/php-5.3.9_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.9_rc2.ebuild,v 1.2 2011/12/09 18:23:44 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.9_rc2.ebuild,v 1.3 2011/12/14 22:48:49 mabi Exp $
EAPI=4
@@ -247,12 +247,12 @@ REQUIRED_USE="
!cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
DEPEND="${DEPEND}
- enchant? ( !dev-php5/pecl-enchant )
- fileinfo? ( !<dev-php5/pecl-fileinfo-1.0.4-r2 )
- filter? ( !dev-php5/pecl-filter )
- json? ( !dev-php5/pecl-json )
- phar? ( !dev-php5/pecl-phar )
- zip? ( !dev-php5/pecl-zip )"
+ enchant? ( !dev-php/pecl-enchant )
+ fileinfo? ( !<dev-php/pecl-fileinfo-1.0.4-r2 )
+ filter? ( !dev-php/pecl-filter )
+ json? ( !dev-php/pecl-json )
+ phar? ( !dev-php/pecl-phar )
+ zip? ( !dev-php/pecl-zip )"
[[ -n $SUHOSIN_VERSION ]] && RDEPEND="${RDEPEND} suhosin? (
=${CATEGORY}/${PN}-${SLOT}*[unicode] )"
@@ -408,7 +408,7 @@ pkg_postinst() {
if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
ewarn "The suhosin USE flag now only installs the suhosin patch!"
ewarn "If you want the suhosin extension, make sure you install"
- ewarn " dev-php5/suhosin"
+ ewarn " dev-php/suhosin"
ewarn
fi
}
diff --git a/dev-lang/php/php-5.4.0_rc3.ebuild b/dev-lang/php/php-5.4.0_rc3.ebuild
index fce8dd393735..90134440e661 100644
--- a/dev-lang/php/php-5.4.0_rc3.ebuild
+++ b/dev-lang/php/php-5.4.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_rc3.ebuild,v 1.2 2011/12/09 20:19:24 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_rc3.ebuild,v 1.3 2011/12/14 22:48:49 mabi Exp $
EAPI=4
@@ -225,12 +225,12 @@ REQUIRED_USE="
!cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
DEPEND="${DEPEND}
- enchant? ( !dev-php5/pecl-enchant )
- fileinfo? ( !<dev-php5/pecl-fileinfo-1.0.4-r2 )
- filter? ( !dev-php5/pecl-filter )
- json? ( !dev-php5/pecl-json )
- phar? ( !dev-php5/pecl-phar )
- zip? ( !dev-php5/pecl-zip )"
+ enchant? ( !dev-php/pecl-enchant )
+ fileinfo? ( !<dev-php/pecl-fileinfo-1.0.4-r2 )
+ filter? ( !dev-php/pecl-filter )
+ json? ( !dev-php/pecl-json )
+ phar? ( !dev-php/pecl-phar )
+ zip? ( !dev-php/pecl-zip )"
[[ -n $SUHOSIN_VERSION ]] && RDEPEND="${RDEPEND} suhosin? (
=${CATEGORY}/${PN}-${SLOT}*[unicode] )"
@@ -384,7 +384,7 @@ pkg_postinst() {
if ( [[ -z SUHOSIN_VERSION ]] && use suhosin && version_is_at_least 5.3.6_rc1 ) ; then
ewarn "The suhosin USE flag now only installs the suhosin patch!"
ewarn "If you want the suhosin extension, make sure you install"
- ewarn " dev-php5/suhosin"
+ ewarn " dev-php/suhosin"
ewarn
fi
}