summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-07 21:30:10 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-07 21:30:10 +0000
commit10083837982fc1d0e901a4f6b20c6a16c348113c (patch)
treebcf698e7c1205509fc4688fc98a15928df69ddfb /dev-lang
parentAdded proper virtual provide (diff)
downloadgentoo-2-10083837982fc1d0e901a4f6b20c6a16c348113c.tar.gz
gentoo-2-10083837982fc1d0e901a4f6b20c6a16c348113c.tar.bz2
gentoo-2-10083837982fc1d0e901a4f6b20c6a16c348113c.zip
ocaml-3.04
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog15
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.041
-rw-r--r--dev-lang/ocaml/ocaml-3.04.ebuild42
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
new file mode 100644
index 000000000000..c6ff2e85df20
--- /dev/null
+++ b/dev-lang/ocaml/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-lang/ocaml
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.1 2002/02/07 21:30:10 karltk Exp $
+
+*ocaml-3.04 ( 7 Feb 2002 )
+
+ 7 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> ChangeLog ocaml-3.04.ebuild files/digest-ocaml-3.04 :
+
+ Objective Caml is a fast modern type-inferring functional programming
+ language descended from the ML (Meta Language) family.
+
+ This builds a runtime environment and native compiler for ocaml.
+
+ Submitted by Sean Mitchell.
+
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.04 b/dev-lang/ocaml/files/digest-ocaml-3.04
new file mode 100644
index 000000000000..04d32a943930
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.04
@@ -0,0 +1 @@
+MD5 7f2fbb849fccb33308188aa19aa9b0ee ocaml-3.04.tar.gz 1970176
diff --git a/dev-lang/ocaml/ocaml-3.04.ebuild b/dev-lang/ocaml/ocaml-3.04.ebuild
new file mode 100644
index 000000000000..79b18d3489f6
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.04.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Sean Mitchell <sean@arawak.tzo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.build,v 1.11 2001/12/06 22:12:34 drobbins Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
+SRC_URI="ftp://ftp.inria.fr/lang/caml-light/${P}.tar.gz"
+HOMEPAGE="http://www.ocaml.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/tk-3.3.3"
+#RDEPEND=""
+
+src_compile()
+{
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/man/man1 \
+ -with-pthread \
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install ()
+{
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/man/man1 \
+ install || die
+
+ dodoc Changes INSTALL LICENSE README Upgrading
+
+}
+
+
+
+