summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-12-31 19:07:27 +0000
committerPacho Ramos <pacho@gentoo.org>2010-12-31 19:07:27 +0000
commit2af835a19893ae878abcafa85fd8999b5b928b7b (patch)
tree4d234c7578055ffaafdec25828d84ec7f75fb321 /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-2af835a19893ae878abcafa85fd8999b5b928b7b.tar.gz
gentoo-2-2af835a19893ae878abcafa85fd8999b5b928b7b.tar.bz2
gentoo-2-2af835a19893ae878abcafa85fd8999b5b928b7b.zip
Version bump with bug fixes and binding updates, bump to eapi3.
(Portage version: 2.1.9.27/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/vala/ChangeLog7
-rw-r--r--dev-lang/vala/vala-0.10.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index 705a55a35133..813db80678f2 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/vala
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.32 2010/12/20 22:37:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.33 2010/12/31 19:07:27 pacho Exp $
+
+*vala-0.10.2 (31 Dec 2010)
+
+ 31 Dec 2010; Pacho Ramos <pacho@gentoo.org> +vala-0.10.2.ebuild:
+ Version bump with bug fixes and binding updates, bump to eapi3.
20 Dec 2010; Gilles Dartiguelongue <eva@gentoo.org> vala-0.8.1.ebuild,
vala-0.9.3.ebuild, -vala-0.9.8.ebuild, -vala-0.10.0.ebuild,
diff --git a/dev-lang/vala/vala-0.10.2.ebuild b/dev-lang/vala/vala-0.10.2.ebuild
new file mode 100644
index 000000000000..caf6c4fb87ce
--- /dev/null
+++ b/dev-lang/vala/vala-0.10.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.10.2.ebuild,v 1.1 2010/12/31 19:07:27 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Vala - Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test +vapigen"
+
+RDEPEND=">=dev-libs/glib-2.14:2"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( sys-devel/bison dev-util/byacc dev-util/yacc )
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ test? (
+ >=dev-libs/glib-2.26
+ dev-libs/dbus-glib )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-unversioned
+ $(use_enable vapigen)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+}