summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-08 22:10:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-08 22:10:12 +0000
commit3e36ab5ccb9f7aacdad1edcdf0e23f74b51eab34 (patch)
treeaddaeebab250b5815e820300d4fc659a14b7a729 /dev-lang
parentReadded cups USE flag. (diff)
downloadgentoo-2-3e36ab5ccb9f7aacdad1edcdf0e23f74b51eab34.tar.gz
gentoo-2-3e36ab5ccb9f7aacdad1edcdf0e23f74b51eab34.tar.bz2
gentoo-2-3e36ab5ccb9f7aacdad1edcdf0e23f74b51eab34.zip
Version bump. Deprecates dbus-glib in favor of gdbus.
(Portage version: 2.2_rc74/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/vala/ChangeLog7
-rw-r--r--dev-lang/vala/vala-0.9.8.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index ac55d5ffb4c1..cba83a68ea45 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/vala
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.25 2010/08/20 11:23:18 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.26 2010/09/08 22:10:12 eva Exp $
+
+*vala-0.9.8 (08 Sep 2010)
+
+ 08 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org> +vala-0.9.8.ebuild:
+ Version bump. Deprecates dbus-glib in favor of gdbus.
*vala-0.9.5 (20 Aug 2010)
diff --git a/dev-lang/vala/vala-0.9.8.ebuild b/dev-lang/vala/vala-0.9.8.ebuild
new file mode 100644
index 000000000000..a1ab4d1f62a0
--- /dev/null
+++ b/dev-lang/vala/vala-0.9.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.9.8.ebuild,v 1.1 2010/09/08 22:10:12 eva Exp $
+
+EAPI="1"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Vala - Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test +vapigen coverage"
+
+RDEPEND=">=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( sys-devel/bison dev-util/byacc dev-util/yacc )
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ test? ( dev-libs/dbus-glib )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable vapigen)
+ $(use_enable coverage)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+ if use coverage && has ccache ${FEATURES}; then
+ ewarn "USE=coverage does not work well with ccache; valac and libvala"
+ ewarn "built with ccache and USE=coverage create temporary files inside"
+ ewarn "CCACHE_DIR and mess with ccache's working, as well as causing"
+ ewarn "sandbox violations when used to compile other packages."
+ ewarn "It is STRONGLY recommended that you disable one of them."
+ fi
+}