summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-11-18 10:30:31 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-11-18 10:30:31 +0000
commit44f0980192aeba4a72a6180962ee1869dbf4796e (patch)
tree6a7b3d0c87069574e88516bef0414410d90d71b3 /dev-lang
parentx86 stable wrt security bug #390779. (diff)
downloadgentoo-2-44f0980192aeba4a72a6180962ee1869dbf4796e.tar.gz
gentoo-2-44f0980192aeba4a72a6180962ee1869dbf4796e.tar.bz2
gentoo-2-44f0980192aeba4a72a6180962ee1869dbf4796e.zip
Remove old.
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog5
-rw-r--r--dev-lang/v8/v8-3.5.10.23.ebuild84
2 files changed, 4 insertions, 85 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 9d0f933322e9..cfde47eb424d 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.107 2011/11/18 10:29:44 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.108 2011/11/18 10:30:31 phajdan.jr Exp $
+
+ 18 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-3.5.10.23.ebuild:
+ Remove old.
18 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-3.5.10.24.ebuild:
x86 stable wrt security bug #390779.
diff --git a/dev-lang/v8/v8-3.5.10.23.ebuild b/dev-lang/v8/v8-3.5.10.23.ebuild
deleted file mode 100644
index 40e8168266da..000000000000
--- a/dev-lang/v8/v8-3.5.10.23.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.5.10.23.ebuild,v 1.3 2011/11/11 11:56:16 phajdan.jr Exp $
-
-EAPI="3"
-
-inherit eutils flag-o-matic multilib pax-utils scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="http://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.bz2"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~x64-macos ~x86-macos"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf="library=shared soname=on importenv=LINKFLAGS,PATH"
-
- # Use target arch detection logic from bug #354601.
- case ${CHOST} in
- i?86-*) myarch=x86 ;;
- x86_64-*)
- if [[ $ABI = "" ]] ; then
- myarch=amd64
- else
- myarch="$ABI"
- fi ;;
- arm*-*) myarch=arm ;;
- *) die "Unrecognized CHOST: ${CHOST}"
- esac
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libv8-${PV}$(get_libname) \
- libv8-${PV}$(get_libname) || die
- fi
-
- dolib libv8-${PV}$(get_libname) || die
- dosym libv8-${PV}$(get_libname) /usr/$(get_libdir)/libv8$(get_libname) || die
-
- dodoc AUTHORS ChangeLog || die
-}