summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-03 22:25:44 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-03 22:25:44 +0000
commit54fea44f5c71c01ce7fd874026f477fa30b5cb0f (patch)
tree07b781a69b0b9dad9acc4ce29a958cf623d8be55 /dev-lang
parentMove selinux-logroate to RDEPEND; bug #287481 (diff)
downloadgentoo-2-54fea44f5c71c01ce7fd874026f477fa30b5cb0f.tar.gz
gentoo-2-54fea44f5c71c01ce7fd874026f477fa30b5cb0f.tar.bz2
gentoo-2-54fea44f5c71c01ce7fd874026f477fa30b5cb0f.zip
Version bump
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-2.10.0.ebuild156
2 files changed, 162 insertions, 1 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 94b7d16f798d..14c8ee4fb42f 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.163 2009/11/03 19:28:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.164 2009/11/03 22:25:44 bicatali Exp $
+
+*R-2.10.0 (03 Nov 2009)
+
+ 03 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org> +R-2.10.0.ebuild:
+ Version bump
03 Nov 2009; Raúl Porcel <armin76@gentoo.org> R-2.9.2.ebuild:
ia64 stable wrt #289381
diff --git a/dev-lang/R/R-2.10.0.ebuild b/dev-lang/R/R-2.10.0.ebuild
new file mode 100644
index 000000000000..eccaed96b597
--- /dev/null
+++ b/dev-lang/R/R-2.10.0.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.10.0.ebuild,v 1.1 2009/11/03 22:25:44 bicatali Exp $
+
+EAPI=2
+inherit eutils flag-o-matic bash-completion versionator
+
+DESCRIPTION="Language and environment for statistical computing and graphics"
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
+ bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc java jpeg lapack minimal nls perl png readline threads tk X cairo"
+
+# common depends
+CDEPEND="dev-libs/libpcre
+ app-arch/bzip2
+ virtual/blas
+ virtual/ghostscript
+ cairo? ( x11-libs/cairo[X]
+ || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
+ jpeg? ( media-libs/jpeg )
+ lapack? ( virtual/lapack )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ X? ( x11-libs/libXmu x11-misc/xdg-utils )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ doc? ( virtual/latex-base
+ || ( dev-texlive/texlive-fontsrecommended
+ app-text/ptex ) )"
+
+RDEPEND="${CDEPEND}
+ app-arch/unzip
+ app-arch/zip
+ java? ( >=virtual/jre-1.5 )"
+
+R_HOME=/usr/$(get_libdir)/${PN}
+
+pkg_setup() {
+ filter-ldflags -Wl,-Bdirect -Bdirect
+}
+
+src_prepare() {
+ # fix packages.html for doc (bug #205103)
+ # check in later versions if fixed
+ sed -i \
+ -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
+ src/library/tools/R/packageshtml.R \
+ || die "sed failed"
+
+ # fix Rscript
+ sed -i \
+ -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_HOME}\"':" \
+ src/unix/Makefile.in || die "sed unix Makefile failed"
+
+ # fix HTML links to manual (bug #273957)
+ sed -i -e 's:\.\./manual/:manual/:g' $(grep -Flr ../manual/ doc) \
+ || die "sed for HTML links to manual failed"
+
+ use lapack && \
+ export LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ if use X; then
+ export R_BROWSER="$(type -p xdg-open)"
+ export R_PDFVIEWER="$(type -p xdg-open)"
+ fi
+ use perl && export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ --enable-R-profiling \
+ --enable-memory-profiling \
+ --enable-R-shlib \
+ --enable-linux-lfs \
+ --with-system-zlib \
+ --with-system-bzlib \
+ --with-system-pcre \
+ --with-blas="$(pkg-config --libs blas)" \
+ --docdir=/usr/share/doc/${PF} \
+ rdocdir=/usr/share/doc/${PF} \
+ $(use_enable nls) \
+ $(use_enable threads) \
+ $(use_with lapack) \
+ $(use_with tk tcltk) \
+ $(use_with jpeg jpeglib) \
+ $(use_with !minimal recommended-packages) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with cairo) \
+ $(use_with X x)
+}
+
+src_compile(){
+ emake || die "emake failed"
+ RMATH_V=0.0.0
+ emake -j1 -C src/nmath/standalone \
+ libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
+ || die "emake math library failed"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake info pdf || die "emake docs failed"
+ fi
+}
+
+src_test() {
+ # we need to unset R_HOME otherwise some of the diff based
+ # tests fail due to warnings in the output
+ R_HOME="" emake -j1 check || die "Some of the tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc; then
+ emake DESTDIR="${D}" \
+ install-info install-pdf || die "emake install docs failed"
+ dosym /usr/share/doc/${PF}/manual /usr/share/doc/${PF}/html/manual
+ fi
+
+ # standalone math lib install (-j1 basically harmless)
+ emake -j1 \
+ -C src/nmath/standalone \
+ DESTDIR="${D}" install \
+ || die "emake install math library failed"
+
+ local mv=$(get_major_version ${RMATH_V})
+ mv "${D}"/usr/$(get_libdir)/libRmath.so \
+ "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
+ dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
+ dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
+
+ # env file
+ cat > 99R <<-EOF
+ LDPATH=${R_HOME}/lib
+ R_HOME=${R_HOME}
+ EOF
+ doenvd 99R || die "doenvd failed"
+ dobashcompletion "${WORKDIR}"/R.bash_completion
+}
+
+pkg_config() {
+ if use java; then
+ einfo "Re-initializing java paths for ${P}"
+ R CMD javareconf
+ fi
+}