summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2006-04-27 19:26:41 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2006-04-27 19:26:41 +0000
commit6777515f3e300978ac3adb15f03743af25607e88 (patch)
treec4a63213987ee522c015c9feb845317d40d5e8f4 /dev-lang
parentFixing SHA256 digest, pass four (diff)
downloadgentoo-2-6777515f3e300978ac3adb15f03743af25607e88.tar.gz
gentoo-2-6777515f3e300978ac3adb15f03743af25607e88.tar.bz2
gentoo-2-6777515f3e300978ac3adb15f03743af25607e88.zip
Bug fix release.
(Portage version: 2.0.54)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/Manifest2
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.09.21
-rw-r--r--dev-lang/ocaml/ocaml-3.09.2.ebuild87
4 files changed, 96 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 2b83e53eac3a..983a5393d1c5 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.78 2006/03/18 15:56:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.79 2006/04/27 19:26:41 mattam Exp $
+
+*ocaml-3.09.2 (27 Apr 2006)
+
+ 27 Apr 2006; Matthieu Sozeau <mattam@gentoo.org> +ocaml-3.09.2.ebuild:
+ Bug fix release 3.09.2.
18 Mar 2006; Markus Rothe <corsair@gentoo.org> ocaml-3.08.3.ebuild,
ocaml-3.08.4.ebuild, ocaml-3.09.1.ebuild:
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index 832742187427..85f47784903f 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -2,9 +2,11 @@ MD5 bc53f42df56adaf4a6d0214c8714c17f ChangeLog 12137
MD5 d80f37fe859bc2ea8f71e13f02578275 files/digest-ocaml-3.08.3 66
MD5 616991884ec513ca3018b0505bdb5707 files/digest-ocaml-3.08.4 244
MD5 9295b3bfcedf64968ef0d9585eb03279 files/digest-ocaml-3.09.1 66
+MD5 b739902cef462f826b4c0fb92756e71c files/digest-ocaml-3.09.2 66
MD5 c57fc46d92565b5d44c8c4f2a4a072d3 files/ocaml-3.08.3-gcc4.patch 710
MD5 3148840e70f4bb5263bdf7cd6c97e6d9 files/ocaml-rebuild.sh 1215
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 fe9b3ed100387585a4c41f959c2e64d0 ocaml-3.08.3.ebuild 2298
MD5 552ff7c558ae5d0569da269301c5951b ocaml-3.08.4.ebuild 2506
MD5 c41dbc92eaacfefbb9cd8a8b4e777436 ocaml-3.09.1.ebuild 2339
+MD5 c41dbc92eaacfefbb9cd8a8b4e777436 ocaml-3.09.2.ebuild 2339
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.09.2 b/dev-lang/ocaml/files/digest-ocaml-3.09.2
new file mode 100644
index 000000000000..f9a4b97490ae
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.09.2
@@ -0,0 +1 @@
+MD5 63428ce7e114520e8f529c9ca809a1b0 ocaml-3.09.2.tar.bz2 2036341
diff --git a/dev-lang/ocaml/ocaml-3.09.2.ebuild b/dev-lang/ocaml/ocaml-3.09.2.ebuild
new file mode 100644
index 000000000000..132716ea44c4
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.09.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.2.ebuild,v 1.1 2006/04/27 19:26:41 mattam Exp $
+
+inherit flag-o-matic eutils multilib
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+
+SRC_URI="http://caml.inria.fr/distrib/ocaml-3.09/${P}.tar.bz2"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86"
+IUSE="tcltk latex"
+
+DEPEND="virtual/libc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+pkg_setup() {
+ ewarn
+ ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn "Likewise, building with a hardened gcc is not possible."
+ ewarn
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+ replace-flags "-O?" -O2
+
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ # Fix for bug #46703
+ export LC_ALL=C
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+ sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/$(get_libdir)/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # compiler libs
+ dodir /usr/lib/ocaml/compiler-libs
+ insinto /usr/lib/ocaml/compiler-libs
+ doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
+
+ # headers
+ dodir /usr/include
+ dosym /usr/lib/ocaml/caml /usr/include/
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}
+
+pkg_postinst() {
+ if use latex; then
+ echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
+ echo
+ einfo "OCaml is not binary compatible from version to version,"
+ einfo "so you (may) need to rebuild all packages depending on it that"
+ einfo "are actually installed on your system."
+ einfo "To do so, you can run: "
+ einfo "sh ${FILESDIR}/ocaml-rebuild.sh [-h | emerge options]"
+ einfo "Which will call emerge on all old packages with the given options"
+ echo
+}