summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-11-21 17:14:09 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-11-21 17:14:09 +0000
commit7b1389fcaf9dc65c9f791a06c53588dd3c2f26c9 (patch)
treee5ec16c846bf8fe16f06984171c8627be62936f4 /dev-lang
parentStable on x86 wrt #199740 (diff)
downloadgentoo-2-7b1389fcaf9dc65c9f791a06c53588dd3c2f26c9.tar.gz
gentoo-2-7b1389fcaf9dc65c9f791a06c53588dd3c2f26c9.tar.bz2
gentoo-2-7b1389fcaf9dc65c9f791a06c53588dd3c2f26c9.zip
clean up; add patch to enable ODBC support on amd64, thanks to Alexander T <spam AT ndl DOT kiev DOT ua> in bug 198302
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog10
-rw-r--r--dev-lang/erlang/erlang-11.2.4-r1.ebuild152
-rw-r--r--dev-lang/erlang/erlang-11.2.5-r3.ebuild (renamed from dev-lang/erlang/erlang-11.2.5-r1.ebuild)37
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.4-r19
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.5-r3 (renamed from dev-lang/erlang/files/digest-erlang-11.2.5-r1)0
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch17
6 files changed, 51 insertions, 174 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 95e57823aadc..cb3c2c62b8a1 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.77 2007/09/23 07:34:43 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.78 2007/11/21 17:14:08 opfer Exp $
+
+*erlang-11.2.5-r3 (21 Nov 2007)
+
+ 21 Nov 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/erlang-11.2.5-odbc-support-amd64.patch, -erlang-11.2.4-r1.ebuild,
+ -erlang-11.2.5-r1.ebuild, +erlang-11.2.5-r3.ebuild:
+ clean up; add patch to enable ODBC support on amd64, thanks to Alexander T
+ <spam AT ndl DOT kiev DOT ua> in bug 198302
23 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
+files/erlang-11.2.5-hipe.patch, erlang-11.2.5-r2.ebuild:
diff --git a/dev-lang/erlang/erlang-11.2.4-r1.ebuild b/dev-lang/erlang/erlang-11.2.4-r1.ebuild
deleted file mode 100644
index 7130cd64baa7..000000000000
--- a/dev-lang/erlang/erlang-11.2.4-r1.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.4-r1.ebuild,v 1.3 2007/08/22 06:48:47 opfer Exp $
-
-inherit elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
-# binaries please tell maintainers or open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50erlang-gentoo.el
-
-pkg_setup() {
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it!"
- ewarn
- fi
-}
-
-src_unpack() {
- ## fix compilation on hardened systems, see bug #154338
- filter-flags "-fstack-protector"
- filter-flags "-fstack-protector-all"
-
- unpack ${A}
- cd "${S}"
-
- # needed for amd64
- epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
- use odbc || sed -i 's: odbc : :' lib/Makefile
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable kpoll kernell-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS EPLICENCE README
-
- dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
- dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
- dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
- dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
- dosym \
- ${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call \
- /usr/bin/erl_call
- dosym ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed ${ERL_LIBDIR}/bin/erl
- dosed ${ERL_LIBDIR}/bin/start
- grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER} | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}"/${ERL_LIBDIR}/Install
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir /usr/share/${i##${WORKDIR}}erl
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Avoid namespace collisions
- local newfile=${file}erl
- cp ${file} ${newfile}
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${newfile}
- # doman sucks so we can't use it
- cp ${newfile} "${D}"/usr/share/man/man${newfile##*.}/
- done
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of erlang's binaries,"
- elog "please open a bug and tell the maintainers."
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-4"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/erlang-11.2.5-r1.ebuild b/dev-lang/erlang/erlang-11.2.5-r3.ebuild
index 289f702999b1..1d858e8c055c 100644
--- a/dev-lang/erlang/erlang-11.2.5-r1.ebuild
+++ b/dev-lang/erlang/erlang-11.2.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.5-r1.ebuild,v 1.1 2007/08/15 07:54:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.5-r3.ebuild,v 1.1 2007/11/21 17:14:08 opfer Exp $
inherit elisp-common eutils flag-o-matic multilib versionator
@@ -41,19 +41,31 @@ S="${WORKDIR}/${MY_P}"
SITEFILE=50erlang-gentoo.el
src_unpack() {
- ## fix compilation on hardened systems, see bug #154338
- filter-flags "-fstack-protector"
- filter-flags "-fstack-protector-all"
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch #184419
+
# needed for amd64
epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
+
# needed for FreeBSD
- epatch "${FILESDIR}/${PN}-11.2.5-gethostbyname.patch"
+ epatch "${FILESDIR}/${P}-gethostbyname.patch"
+
+ # odbc is disabled in the amd64 code, but it works
+ if use x86 && use odbc; then
+ epatch "${FILESDIR}/${P}-odbc-support-amd64.patch"
+ fi
+
+ # needed for building with hipe and recent coreutils
+ use hipe && epatch "${FILESDIR}"/${P}-hipe.patch
+
use odbc || sed -i 's: odbc : :' lib/Makefile
+ # make sure we only link ssl dynamically
+ sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
+
if use hipe; then
ewarn
ewarn "You enabled High performance Erlang. Be aware that this extension"
@@ -113,18 +125,19 @@ src_install() {
if use doc ; then
for i in "${WORKDIR}"/man/man* ; do
- dodir "/usr/share/${i##${WORKDIR}}erl"
+ dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
done
for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Avoid namespace collisions
- local newfile=${file}erl
- cp ${file} ${newfile}
# Man page processing tools expect a capitalized "SEE ALSO" section
- # header
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${newfile}
+ # header, has been reported upstream, should be fixed in R12
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
# doman sucks so we can't use it
- cp ${newfile} "${D}"/usr/share/man/man${newfile##*.}/
+ cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
done
+ # extend MANPATH, so the normal man command can find it
+ # see bug 189639
+ dodir /etc/env.d/
+ echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
dohtml -A README,erl,hrl,c,h,kwc,info -r \
"${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
fi
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.4-r1 b/dev-lang/erlang/files/digest-erlang-11.2.4-r1
deleted file mode 100644
index 8a23b314578e..000000000000
--- a/dev-lang/erlang/files/digest-erlang-11.2.4-r1
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 187cd55de8866a278ed963664819404d otp_doc_html_R11B-4.tar.gz 4902864
-RMD160 36d8ed3e0523f651f57caa8588f12f0500344f0e otp_doc_html_R11B-4.tar.gz 4902864
-SHA256 fa1f313a0d3f79239ee2930159288419c6c4348d095cf58557ff799712d3a60f otp_doc_html_R11B-4.tar.gz 4902864
-MD5 cc041ceebc4a6615073d8d7e88495610 otp_doc_man_R11B-4.tar.gz 712928
-RMD160 ba006631a99757c65ff4955650485e213d6904b9 otp_doc_man_R11B-4.tar.gz 712928
-SHA256 5852d7d9b7f09f3dda0261fe51c52025eacbdae258a984994b1a2407a065450e otp_doc_man_R11B-4.tar.gz 712928
-MD5 649e6f057e6996f92c8496161d754d8d otp_src_R11B-4.tar.gz 11720279
-RMD160 53969dd0f1637e9ac784f38d6ec9c01b7986a9cd otp_src_R11B-4.tar.gz 11720279
-SHA256 6928f44b67982aa8e00a2b053ecc78437fc70e19a2b0131c8f1ee86f02009337 otp_src_R11B-4.tar.gz 11720279
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.5-r1 b/dev-lang/erlang/files/digest-erlang-11.2.5-r3
index 77aa33e4a391..77aa33e4a391 100644
--- a/dev-lang/erlang/files/digest-erlang-11.2.5-r1
+++ b/dev-lang/erlang/files/digest-erlang-11.2.5-r3
diff --git a/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch b/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch
new file mode 100644
index 000000000000..1b5405e9c41d
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch
@@ -0,0 +1,17 @@
+diff -urN otp_src_R11B-5/lib/odbc/c_src/Makefile.in otp_src_R11B-5.odbc/lib/odbc/c_src/Makefile.in
+--- otp_src_R11B-5/lib/odbc/c_src/Makefile.in 2006-05-03 11:18:45.000000000 +0300
++++ otp_src_R11B-5.odbc/lib/odbc/c_src/Makefile.in 2007-11-07 00:24:36.000000000 +0200
+@@ -57,11 +57,11 @@
+ WIN32_TARGET = $(WIN_BIN_DIR)/odbcserver.exe
+ EXE_TARGET = $(WIN32_TARGET)
+ else
+-ifneq ($(BITS64),yes)
++#ifneq ($(BITS64),yes)
+ EI_LIB = -lerl_interface -lei
+ UNIX_TARGET = $(BIN_DIR)/odbcserver
+ EXE_TARGET = $(UNIX_TARGET)
+-endif
++#endif
+ endif
+
+ C_FILES = odbcserver.c