summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-11-12 15:43:15 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-11-12 15:43:15 +0000
commit8e79f157183f73afd483a23148a005cebe5e6b8e (patch)
tree06f42887b82dbc876b56ec4d7d41497b86ae1a1b /dev-lang
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-8e79f157183f73afd483a23148a005cebe5e6b8e.tar.gz
gentoo-2-8e79f157183f73afd483a23148a005cebe5e6b8e.tar.bz2
gentoo-2-8e79f157183f73afd483a23148a005cebe5e6b8e.zip
apply patch only for amd64 for now
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/Manifest2
-rw-r--r--dev-lang/python/python-2.2.3-r5.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 8eaa13348ff6..1e54c40180b2 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -1,7 +1,7 @@
MD5 48d3de450107a8702bbd30ddfdceeed2 python-2.2.3-r3.ebuild 3488
MD5 b5ce70d94f27185e138e67267ff416fe python-2.2.2-r1.ebuild 3123
MD5 789d8555967a31cc0de2126fa6468fc2 python-2.2.3.ebuild 2999
-MD5 ed2d4e2aa82ebe752d2d35b864325c1f python-2.2.3-r5.ebuild 4445
+MD5 77b761a177b5943e0a0893fcbd8b0e3a python-2.2.3-r5.ebuild 4472
MD5 a5eec23c78d6a0923c477e34ce969392 python-2.3.2-r1.ebuild 4812
MD5 0a274212a2a49a52600b617a38bafa09 python-2.2.3-r2.ebuild 3441
MD5 c70d578ef0b3e6358108691e8b88d458 python-2.2.2.ebuild 3027
diff --git a/dev-lang/python/python-2.2.3-r5.ebuild b/dev-lang/python/python-2.2.3-r5.ebuild
index 83a05262932b..217d3433a1ee 100644
--- a/dev-lang/python/python-2.2.3-r5.ebuild
+++ b/dev-lang/python/python-2.2.3-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.7 2003/11/12 15:37:56 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r5.ebuild,v 1.8 2003/11/12 15:43:10 aliz Exp $
inherit flag-o-matic eutils python
@@ -44,7 +44,7 @@ src_unpack() {
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P}-disable_modules_and_ssl.patch
EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3-add_portage_search_path.patch
epatch ${FILESDIR}/${PN}-2.2.3-gentoo_py_dontcompile.patch
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P}-fPIC.patch
+ [ "${ARCH}" = "amd64" ] && EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P}-fPIC.patch
}
src_configure() {