summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-28 05:24:13 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-28 05:24:13 +0000
commit8ed32e6bf344c307316970f423c63b17604b0161 (patch)
tree903729d776fdd8e9151364e6f7be0a9abefd351c /dev-lang
parentAdded DarcNES a multi-system emulator (diff)
downloadgentoo-2-8ed32e6bf344c307316970f423c63b17604b0161.tar.gz
gentoo-2-8ed32e6bf344c307316970f423c63b17604b0161.tar.bz2
gentoo-2-8ed32e6bf344c307316970f423c63b17604b0161.zip
Dependencie fixes
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jdk/jdk-1.3.0.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-lang/jdk/jdk-1.3.0.ebuild b/dev-lang/jdk/jdk-1.3.0.ebuild
index e154a99c9218..f84feaf2180f 100644
--- a/dev-lang/jdk/jdk-1.3.0.ebuild
+++ b/dev-lang/jdk/jdk-1.3.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jdk/jdk-1.3.0.ebuild,v 1.4 2001/05/01 18:29:05 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jdk/jdk-1.3.0.ebuild,v 1.5 2001/05/28 05:24:13 achim Exp $
P=jdk-1.3.0
A=j2sdk-1.3.0-FCS-linux-i386.tar.bz2
@@ -10,23 +10,19 @@ DESCRIPTION="Blackdown JDK 1.3.0"
SRC_URI="http://www.ibiblio.org/pub/linux/devel/lang/java/blackdown.org/JDK-1.3.0/i386/FCS/${A}"
HOMEPAGE="http://www.blackdown.org/java-linux.html"
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc
virtual/x11"
-src_compile() {
- cd ${S}
-}
-
-src_install() {
+src_install() {
dodir /opt/jdk-${PV}
- dodir /usr
+ dodir /usr/share
cp -a ${S}/bin ${D}/opt/jdk-${PV}
cp -a ${S}/demo ${D}/opt/jdk-${PV}
cp -a ${S}/include ${D}/opt/jdk-${PV}
cp -a ${S}/lib ${D}/opt/jdk-${PV}
cp -a ${S}/jre ${D}/opt/jdk-${PV}
- cp -a ${S}/man ${D}/usr
+ cp -a ${S}/man ${D}/usr/share
cp ${S}/src.jar ${D}/opt/jdk-${PV}
into /usr
dodoc COPYRIGHT LICENSE README