summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-09-19 00:25:59 +0000
committerJon Portnoy <avenj@gentoo.org>2003-09-19 00:25:59 +0000
commit8ee1965d48d687f6a12b63113d56763f0c9029d8 (patch)
treeab2839f82b5647608d708dbc44b7e82942bec070 /dev-lang
parentrepoman: trim trailing whitespace (diff)
downloadgentoo-2-8ee1965d48d687f6a12b63113d56763f0c9029d8.tar.gz
gentoo-2-8ee1965d48d687f6a12b63113d56763f0c9029d8.tar.bz2
gentoo-2-8ee1965d48d687f6a12b63113d56763f0c9029d8.zip
ia64 keywords
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/icc/Manifest4
-rw-r--r--dev-lang/icc/icc-7.1.006.ebuild48
-rw-r--r--dev-lang/icc/icc-7.1.029.ebuild48
3 files changed, 50 insertions, 50 deletions
diff --git a/dev-lang/icc/Manifest b/dev-lang/icc/Manifest
index a13cfd9fddc3..0c647d11edf7 100644
--- a/dev-lang/icc/Manifest
+++ b/dev-lang/icc/Manifest
@@ -4,8 +4,8 @@ MD5 75845f8c8389441c8d7c6f2d80d7ca1b icc-6.0.ebuild 2936
MD5 13a5fd0e0298651c759d69aaa769acd7 icc-7.0.065.ebuild 3177
MD5 ba482af3531a84aeaccd6c1e54a842cf icc-7.0.065-r1.ebuild 3230
MD5 8267a3baf3fc2b1813c82c008f61634d icc-7.0.065-r2.ebuild 3230
-MD5 cafb288e0b0985f0267ccb5e6c673c0e icc-7.1.006.ebuild 3930
-MD5 c49127eefa0900b32687a5041f333658 icc-7.1.029.ebuild 4008
+MD5 6371b01d36cdaf7a9143229cce79b00b icc-7.1.006.ebuild 3710
+MD5 bcaad67983a7ae54eec4179775a2c4ba icc-7.1.029.ebuild 3788
MD5 5a2e5b03d1de761f8b08ef35070687be files/digest-icc-7.1.006 65
MD5 16cb4482e4303fd7d5308782b494463d files/digest-icc-6.0 65
MD5 16cb4482e4303fd7d5308782b494463d files/digest-icc-6.0-r1 65
diff --git a/dev-lang/icc/icc-7.1.006.ebuild b/dev-lang/icc/icc-7.1.006.ebuild
index c4f309db35f3..6084b62e9678 100644
--- a/dev-lang/icc/icc-7.1.006.ebuild
+++ b/dev-lang/icc/icc-7.1.006.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.006.ebuild,v 1.5 2003/09/18 20:10:41 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.006.ebuild,v 1.6 2003/09/19 00:25:55 avenj Exp $
inherit rpm
@@ -29,14 +29,14 @@ src_unpack() {
cd ${S}
# Keep disk space to a minimum
- if [ "$ARCH" = "x86" ]
- then
- rm -f intel-*.ia64.rpm
- else
- rm -f intel-*.i386.rpm
- fi
+ if [ "$ARCH" = "x86" ]
+ then
+ rm -f intel-*.ia64.rpm
+ else
+ rm -f intel-*.i386.rpm
+ fi
- rpm_unpack *.rpm
+ rpm_unpack *.rpm
}
src_compile() {
@@ -62,9 +62,9 @@ src_compile() {
chmod 644 $SUPPORTFILE
done
- # these should not be executable
- find "${SD}/compiler70/"{docs,man,training,ia32/include} -type f -exec chmod -x "{}" ";"
- find "${SD}/compiler70/ia32/lib" -name \*.a -exec chmod -x "{}" ";"
+ # these should not be executable
+ find "${SD}/compiler70/"{docs,man,training,ia32/include} -type f -exec chmod -x "{}" ";"
+ find "${SD}/compiler70/ia32/lib" -name \*.a -exec chmod -x "{}" ";"
}
@@ -74,19 +74,19 @@ src_install () {
cp -a opt ${D}
insinto /etc/env.d
- if [ "$ARCH" = "x86" ]
- then
- newins ${FILESDIR}/${PVR}/05icc-ifc-ia32 05icc-ifc || die
- # fix the processor name issue with the primary icc executable
- exeinto /opt/intel/compiler70/ia32/bin
- newexe ${FILESDIR}/${PVR}/icc-ia32 icc
- newexe ${FILESDIR}/${PVR}/icpc-ia32 icc
- else
- newins ${FILESDIR}/${PVR}/05icc-ifc-ia64 05icc-ifc || die
- dodir /usr/bin
- dosym ../../opt/intel/compiler70/ia64/bin/eccbin /usr/bin/ecc
- dosym ../../opt/intel/compiler70/ia64/bin/ecpcbin /usr/bin/ecpc
- fi
+ if [ "$ARCH" = "x86" ]
+ then
+ newins ${FILESDIR}/${PVR}/05icc-ifc-ia32 05icc-ifc || die
+ # fix the processor name issue with the primary icc executable
+ exeinto /opt/intel/compiler70/ia32/bin
+ newexe ${FILESDIR}/${PVR}/icc-ia32 icc
+ newexe ${FILESDIR}/${PVR}/icpc-ia32 icc
+ else
+ newins ${FILESDIR}/${PVR}/05icc-ifc-ia64 05icc-ifc || die
+ dodir /usr/bin
+ dosym ../../opt/intel/compiler70/ia64/bin/eccbin /usr/bin/ecc
+ dosym ../../opt/intel/compiler70/ia64/bin/ecpcbin /usr/bin/ecpc
+ fi
}
diff --git a/dev-lang/icc/icc-7.1.029.ebuild b/dev-lang/icc/icc-7.1.029.ebuild
index b563b4e132ed..5c014e02eda8 100644
--- a/dev-lang/icc/icc-7.1.029.ebuild
+++ b/dev-lang/icc/icc-7.1.029.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.029.ebuild,v 1.2 2003/09/18 19:47:56 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-7.1.029.ebuild,v 1.3 2003/09/19 00:25:55 avenj Exp $
inherit rpm
@@ -33,14 +33,14 @@ src_unpack() {
cd ${S}
# Keep disk space to a minimum
- if [ "$ARCH" = "x86" ]
- then
- rm -f intel-*.ia64.rpm
- else
- rm -f intel-*.i386.rpm
- fi
+ if [ "$ARCH" = "x86" ]
+ then
+ rm -f intel-*.ia64.rpm
+ else
+ rm -f intel-*.i386.rpm
+ fi
- rpm_unpack *.rpm
+ rpm_unpack *.rpm
}
src_compile() {
@@ -66,9 +66,9 @@ src_compile() {
chmod 644 $SUPPORTFILE
done
- # these should not be executable
- find "${SD}/compiler70/"{docs,man,training,ia32/include} -type f -exec chmod -x "{}" ";"
- find "${SD}/compiler70/ia32/lib" -name \*.a -exec chmod -x "{}" ";"
+ # these should not be executable
+ find "${SD}/compiler70/"{docs,man,training,ia32/include} -type f -exec chmod -x "{}" ";"
+ find "${SD}/compiler70/ia32/lib" -name \*.a -exec chmod -x "{}" ";"
}
@@ -78,19 +78,19 @@ src_install () {
cp -a opt ${D}
insinto /etc/env.d
- if [ "$ARCH" = "x86" ]
- then
- newins ${FILESDIR}/${PVR}/05icc-ifc-ia32 05icc-ifc || die
- # fix the processor name issue with the primary icc executable
- exeinto /opt/intel/compiler70/ia32/bin
- newexe ${FILESDIR}/${PVR}/icc-ia32 icc
- newexe ${FILESDIR}/${PVR}/icpc-ia32 icc
- else
- newins ${FILESDIR}/${PVR}/05icc-ifc-ia64 05icc-ifc || die
- dodir /usr/bin
- dosym ../../opt/intel/compiler70/ia64/bin/eccbin /usr/bin/ecc
- dosym ../../opt/intel/compiler70/ia64/bin/ecpcbin /usr/bin/ecpc
- fi
+ if [ "$ARCH" = "x86" ]
+ then
+ newins ${FILESDIR}/${PVR}/05icc-ifc-ia32 05icc-ifc || die
+ # fix the processor name issue with the primary icc executable
+ exeinto /opt/intel/compiler70/ia32/bin
+ newexe ${FILESDIR}/${PVR}/icc-ia32 icc
+ newexe ${FILESDIR}/${PVR}/icpc-ia32 icc
+ else
+ newins ${FILESDIR}/${PVR}/05icc-ifc-ia64 05icc-ifc || die
+ dodir /usr/bin
+ dosym ../../opt/intel/compiler70/ia64/bin/eccbin /usr/bin/ecc
+ dosym ../../opt/intel/compiler70/ia64/bin/ecpcbin /usr/bin/ecpc
+ fi
}