summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-06-09 14:06:27 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-06-09 14:06:27 +0000
commita9ad4aec6319c8f85d521fb914e9cb74199bbda7 (patch)
tree39313c8f1d82adf399fa44960f76d474c836f94c /dev-lang
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-a9ad4aec6319c8f85d521fb914e9cb74199bbda7.tar.gz
gentoo-2-a9ad4aec6319c8f85d521fb914e9cb74199bbda7.tar.bz2
gentoo-2-a9ad4aec6319c8f85d521fb914e9cb74199bbda7.zip
stop warnings about writable and executable sections
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/go-1.4.2.ebuild7
-rw-r--r--dev-lang/go/go-9999.ebuild7
3 files changed, 17 insertions, 3 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 0cbd438f5845..c8b147f11f1c 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.74 2015/06/02 20:05:54 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.75 2015/06/09 14:06:27 williamh Exp $
+
+ 09 Jun 2015; William Hubbs <williamh@gentoo.org> go-1.4.2.ebuild,
+ go-9999.ebuild:
+ stop warnings about writable and executable sections
02 Jun 2015; William Hubbs <williamh@gentoo.org>
-files/go-1.2-no-Werror.patch, -go-1.4.1.ebuild:
diff --git a/dev-lang/go/go-1.4.2.ebuild b/dev-lang/go/go-1.4.2.ebuild
index 2ee0d0d0a785..7143c23ae9e3 100644
--- a/dev-lang/go/go-1.4.2.ebuild
+++ b/dev-lang/go/go-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.4.2.ebuild,v 1.4 2015/05/27 12:49:55 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.4.2.ebuild,v 1.5 2015/06/09 14:06:27 williamh Exp $
EAPI=5
@@ -27,6 +27,11 @@ IUSE=""
DEPEND=""
RDEPEND=""
+# These test data objects have writable/executable stacks.
+QA_EXECSTACK="
+ usr/lib/go/src/debug/elf/testdata/go-relocation-test-gcc482-aarch64.obj
+ usr/lib/go/src/debug/elf/testdata/gcc-amd64-openbsd-debug-with-rela.obj"
+
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 67a6882ce278..c469faf6709e 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.26 2015/06/02 15:37:10 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.27 2015/06/09 14:06:27 williamh Exp $
EAPI=5
@@ -27,6 +27,11 @@ IUSE=""
DEPEND=">=dev-lang/go-bootstrap-1.4.1"
RDEPEND=""
+# These test data objects have writable/executable stacks.
+QA_EXECSTACK="
+ usr/lib/go/src/debug/elf/testdata/go-relocation-test-gcc482-aarch64.obj
+ usr/lib/go/src/debug/elf/testdata/gcc-amd64-openbsd-debug-with-rela.obj"
+
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"