summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-09-08 17:51:04 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-09-08 17:51:04 +0000
commitaf986abab4c1c0944178b32af9c02d4f2e984bd5 (patch)
treec4b031e9636bc7dc058b85972bec22f7715cad0d /dev-lang
parentMoved from science overlay. bug #79082 (diff)
downloadgentoo-2-af986abab4c1c0944178b32af9c02d4f2e984bd5.tar.gz
gentoo-2-af986abab4c1c0944178b32af9c02d4f2e984bd5.tar.bz2
gentoo-2-af986abab4c1c0944178b32af9c02d4f2e984bd5.zip
Bump to 0.4.9
(Portage version: 2.2_rc74/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/ChangeLog8
-rw-r--r--dev-lang/orc/files/orc-0.4.9-make-valgrind-optional.patch34
-rw-r--r--dev-lang/orc/orc-0.4.9.ebuild39
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-lang/orc/ChangeLog b/dev-lang/orc/ChangeLog
index 1770579e925f..d6e549ee4afd 100644
--- a/dev-lang/orc/ChangeLog
+++ b/dev-lang/orc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/orc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.6 2010/08/21 14:47:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.7 2010/09/08 17:51:03 ford_prefect Exp $
+
+*orc-0.4.9 (08 Sep 2010)
+
+ 08 Sep 2010; Arun Raghavan <ford_prefect@gentoo.org> +orc-0.4.9.ebuild,
+ +files/orc-0.4.9-make-valgrind-optional.patch:
+ Bump to 0.4.9
*orc-0.4.7 (21 Aug 2010)
diff --git a/dev-lang/orc/files/orc-0.4.9-make-valgrind-optional.patch b/dev-lang/orc/files/orc-0.4.9-make-valgrind-optional.patch
new file mode 100644
index 000000000000..9614f19ef27b
--- /dev/null
+++ b/dev-lang/orc/files/orc-0.4.9-make-valgrind-optional.patch
@@ -0,0 +1,34 @@
+From 81d0728db9d7442407c0d308ff1501d5778a14ed Mon Sep 17 00:00:00 2001
+From: Arun Raghavan <ford_prefect@gentoo.org>
+Date: Wed, 8 Sep 2010 22:59:53 +0530
+Subject: [PATCH] configure: Make valgrind header check optional
+
+---
+ configure.ac | 11 ++++++++++-
+ 1 files changed, 10 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 417b56b..ecfd2d4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -84,7 +84,16 @@ if test "$orc_cv_monotonic_clock" = "yes"; then
+ AC_DEFINE(HAVE_MONOTONIC_CLOCK,1,[Defined if we have a monotonic clock])
+ fi
+
+-AC_CHECK_HEADERS([valgrind/valgrind.h])
++AC_ARG_ENABLE([valgrind],
++ AC_HELP_STRING([--enable-valgrind],[enable valgrind support (default: auto)]),
++ [], [enable_valgrind=auto])
++if test "x${enable_valgrind}" != "xno"; then
++ AC_CHECK_HEADERS([valgrind/valgrind.h],
++ [found_valgrind_h=yes], [found_valgrind_h=no])
++ if test "x${enable_valgrind}" = "xyes" -a "x${found_valgrind_h}" = "no"; then
++ AC_MSG_ERROR([Valgrind support requested, but valgrind/valgrind.h not found. Have you installed the valgrind development package?])
++ fi
++fi
+
+ AS_COMPILER_FLAG(-Wall, ORC_CFLAGS="$ORC_CFLAGS -Wall")
+ if test "x$ORC_CVS" = "xyes"
+--
+1.7.2.2
+
diff --git a/dev-lang/orc/orc-0.4.9.ebuild b/dev-lang/orc/orc-0.4.9.ebuild
new file mode 100644
index 000000000000..11f8c13767b2
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.9.ebuild,v 1.1 2010/09/08 17:51:03 ford_prefect Exp $
+
+EAPI=3
+inherit autotools
+
+DESCRIPTION="The Oil Runtime Compiler"
+HOMEPAGE="http://code.entropywave.com/projects/orc/"
+SRC_URI="http://code.entropywave.com/download/orc/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs examples"
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' Makefile.am || die
+ fi
+
+ epatch "${FILESDIR}/${P}-make-valgrind-optional.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-dependency-tracking \
+ --disable-valgrind \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README TODO
+
+ find "${ED}" -name '*.la' -delete
+}