summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2007-10-06 23:57:33 +0000
committerKeri Harris <keri@gentoo.org>2007-10-06 23:57:33 +0000
commitafe37ae2e79f2e3b305e01fca4f8f15dd4ec043e (patch)
treef1b6a5c8b6cc31c7aff23d37660aebabe31c9b18 /dev-lang
parentFix incorrect CFLAGS being used for build utils #192959 by Woodward Crim Hoff... (diff)
downloadgentoo-2-afe37ae2e79f2e3b305e01fca4f8f15dd4ec043e.tar.gz
gentoo-2-afe37ae2e79f2e3b305e01fca4f8f15dd4ec043e.tar.bz2
gentoo-2-afe37ae2e79f2e3b305e01fca4f8f15dd4ec043e.zip
Version bump.
(Portage version: 2.1.3.11)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swi-prolog/ChangeLog7
-rw-r--r--dev-lang/swi-prolog/files/digest-swi-prolog-5.6.436
-rw-r--r--dev-lang/swi-prolog/swi-prolog-5.6.43.ebuild148
3 files changed, 160 insertions, 1 deletions
diff --git a/dev-lang/swi-prolog/ChangeLog b/dev-lang/swi-prolog/ChangeLog
index 0e434ee40036..8ed8836f65d4 100644
--- a/dev-lang/swi-prolog/ChangeLog
+++ b/dev-lang/swi-prolog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/swi-prolog
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.116 2007/10/03 06:52:19 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.117 2007/10/06 23:57:33 keri Exp $
+
+*swi-prolog-5.6.43 (06 Oct 2007)
+
+ 06 Oct 2007; keri <keri@gentoo.org> +swi-prolog-5.6.43.ebuild:
+ Version bump.
03 Oct 2007; keri <keri@gentoo.org> swi-prolog-5.6.41.ebuild:
Parallelize src_install() and src_check() via emake. Thanks goes to Donnie
diff --git a/dev-lang/swi-prolog/files/digest-swi-prolog-5.6.43 b/dev-lang/swi-prolog/files/digest-swi-prolog-5.6.43
new file mode 100644
index 000000000000..61fc30ad617a
--- /dev/null
+++ b/dev-lang/swi-prolog/files/digest-swi-prolog-5.6.43
@@ -0,0 +1,6 @@
+MD5 eb6f54380b35d1bb5b034027e535e77b pl-5.6.43.tar.gz 11989950
+RMD160 e47f16fa529b9597bd2a5309671ec911cb3cf9f5 pl-5.6.43.tar.gz 11989950
+SHA256 bbaaed3b9b7c59a5a48fc34400a34e4600785d2b6964d7c988356ceac1479776 pl-5.6.43.tar.gz 11989950
+MD5 b490939fc545c1746c4229d38c9d9251 swi-prolog-5.6.43-gentoo-patchset-0.tar.gz 10638
+RMD160 ea649812fd8ab5c99b33841d91e0aa48eab20de5 swi-prolog-5.6.43-gentoo-patchset-0.tar.gz 10638
+SHA256 6f61711e3b20db77362ad87a46119b92931436f7f7c4246f443cd0f58beb147d swi-prolog-5.6.43-gentoo-patchset-0.tar.gz 10638
diff --git a/dev-lang/swi-prolog/swi-prolog-5.6.43.ebuild b/dev-lang/swi-prolog/swi-prolog-5.6.43.ebuild
new file mode 100644
index 000000000000..0d014e82758e
--- /dev/null
+++ b/dev-lang/swi-prolog/swi-prolog-5.6.43.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/swi-prolog-5.6.43.ebuild,v 1.1 2007/10/06 23:57:33 keri Exp $
+
+inherit eutils flag-o-matic java-pkg-opt-2
+
+PATCHSET_VER="0"
+
+DESCRIPTION="free, small, and standard compliant Prolog compiler"
+HOMEPAGE="http://www.swi-prolog.org/"
+SRC_URI="http://gollem.science.uva.nl/cgi-bin/nph-download/SWI-Prolog/pl-${PV}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="berkdb debug doc gmp java minimal odbc readline ssl static tetex threads zlib X"
+
+DEPEND="!dev-lang/swi-prolog-lite
+ sys-libs/ncurses
+ zlib? ( sys-libs/zlib )
+ odbc? ( dev-db/unixODBC )
+ berkdb? ( sys-libs/db )
+ readline? ( sys-libs/readline )
+ gmp? ( dev-libs/gmp )
+ ssl? ( dev-libs/openssl )
+ java? ( >=virtual/jdk-1.4
+ dev-java/junit )
+ X? (
+ media-libs/jpeg
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-proto/xproto )"
+
+S="${WORKDIR}/pl-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/${PV}/1000-cflags.patch
+ epatch "${WORKDIR}"/${PV}/1001-multilib.patch
+ epatch "${WORKDIR}"/${PV}/1002-parallel-make.patch
+ epatch "${WORKDIR}"/${PV}/2100-thread-sandbox.patch
+ epatch "${WORKDIR}"/${PV}/2105-pl-profile-va-debug.patch
+ epatch "${WORKDIR}"/${PV}/2800-mandir.patch
+ epatch "${WORKDIR}"/${PV}/2900-thread-library.patch
+ epatch "${WORKDIR}"/${PV}/3029-clib-test.patch
+ epatch "${WORKDIR}"/${PV}/3059-ssl-test.patch
+ epatch "${WORKDIR}"/${PV}/3069-semweb-test.patch
+ epatch "${WORKDIR}"/${PV}/3150-jpl-env.patch
+ epatch "${WORKDIR}"/${PV}/3151-jpl-ppc-arch.patch
+ epatch "${WORKDIR}"/${PV}/3152-jpl-junit.patch
+ epatch "${WORKDIR}"/${PV}/3159-jpl-test.patch
+ epatch "${WORKDIR}"/${PV}/3160-xpce-parallel-build.patch
+ epatch "${WORKDIR}"/${PV}/3139-sgml-test.patch
+ epatch "${WORKDIR}"/${PV}/3149-sgml-RDF-test.patch
+ epatch "${WORKDIR}"/${PV}/3169-xpce-test.patch
+ epatch "${WORKDIR}"/${PV}/3199-ltx2htm.patch
+ epatch "${WORKDIR}"/${PV}/3229-zlib-test.patch
+}
+
+src_compile() {
+ einfo "Building SWI-Prolog compiler"
+
+ use debug && append-flags -DO_DEBUG
+
+ local threadconf
+ if use java && ! use minimal || use threads ; then
+ threadconf="--enable-mt"
+ else
+ threadconf="--disable-mt"
+ fi
+
+ cd "${S}"/src
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ ${threadconf} \
+ $(use_enable gmp) \
+ $(use_enable readline) \
+ $(use_enable !static shared) \
+ --disable-custom-flags \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if ! use minimal ; then
+ einfo "Building SWI-Prolog additional packages"
+
+ cd "${S}/packages"
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ ${threadconf} \
+ $(use_enable !static shared) \
+ --without-C-sicstus \
+ --with-chr \
+ --with-clib \
+ --with-clpqr \
+ --with-cpp \
+ --with-cppproxy \
+ $(use_with berkdb db) \
+ --with-http \
+ --without-jasmine \
+ $(use_with java jpl) \
+ $(use_with tetex ltx2htm) \
+ --with-nlp \
+ $(use_with odbc) \
+ --with-pldoc \
+ --with-plunit \
+ --with-semweb \
+ --with-sgml \
+ --with-sgml/RDF \
+ $(use_with ssl) \
+ --with-table \
+ $(use_with X xpce) \
+ $(use_with zlib) \
+ || die "packages econf failed"
+
+ emake || die "packages emake failed"
+ fi
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install || die "install src failed"
+
+ if ! use minimal ; then
+ emake -C packages DESTDIR="${D}" install || die "install packages failed"
+ if use doc ; then
+ emake -C packages DESTDIR="${D}" html-install || die "html-install failed"
+ emake -C packages/cppproxy DESTDIR="${D}" install-examples || die "install-examples failed"
+ fi
+ fi
+
+ dodoc ANNOUNCE ChangeLog INSTALL INSTALL.notes PORTING README README.GUI VERSION
+}
+
+src_test() {
+ cd "${S}/src"
+ emake check || die "make check failed. See above for details."
+
+ if ! use minimal ; then
+ cd "${S}/packages"
+ emake check || die "make check failed. See above for details."
+ fi
+}