summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2011-09-14 09:28:13 +0000
committerGeorge Shapovalov <george@gentoo.org>2011-09-14 09:28:13 +0000
commitb5f0fe93bf61f17635b14e8e5a21bc736117362b (patch)
tree69cf443ac76c36e650920f122b0c7953c5fdd673 /dev-lang
parentDrop mask for net-analyzer/wireshark-1.6.0_rc*. (diff)
downloadgentoo-2-b5f0fe93bf61f17635b14e8e5a21bc736117362b.tar.gz
gentoo-2-b5f0fe93bf61f17635b14e8e5a21bc736117362b.tar.bz2
gentoo-2-b5f0fe93bf61f17635b14e8e5a21bc736117362b.zip
overdue update to 4.3 using new bootstrap; ref bug #372179
(Portage version: 2.1.10.6/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog13
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.3.6.ebuild63
2 files changed, 73 insertions, 3 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 6028415c6b1a..90ee4eab4b20 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.44 2011/08/26 15:40:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.45 2011/09/14 09:28:13 george Exp $
+
+*gnat-gcc-4.3.6 (14 Sep 2011)
+
+ 14 Sep 2011; George Shapovalov <george@gentoo.org> +gnat-gcc-4.3.6.ebuild:
+ overdue update to 4.3 using new bootstrap; ref bug #372179
+ amd64 only atm. x86 is coming up next. Can't simply change 4.3.5, as
+ some changes to ebuild are needed to match a new bootstrap.
26 Aug 2011; Markos Chandras <hwoarang@gentoo.org> gnat-gcc-4.3.5.ebuild:
Stable on amd64 wrt bug #317971
@@ -8,10 +15,10 @@
20 Aug 2011; Thomas Kahle <tomka@gentoo.org> gnat-gcc-4.3.5.ebuild:
x86 stable per bug 379983
- 19 Jun 2011; <george@gentoo.org> gnat-gcc-4.4.5.ebuild:
+ 19 Jun 2011; George Shapovalov <george@gentoo.org> gnat-gcc-4.4.5.ebuild:
new bootstrap for x86
- 24 May 2011; <george@gentoo.org> gnat-gcc-4.4.5.ebuild:
+ 24 May 2011; George Shapovalov <george@gentoo.org> gnat-gcc-4.4.5.ebuild:
new bootstrap for sparc
*gnat-gcc-4.4.5 (23 May 2011)
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3.6.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3.6.ebuild
new file mode 100644
index 000000000000..0f67011eaab4
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.3.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.3.6.ebuild,v 1.1 2011/09/14 09:28:13 george Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
+# sparc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+# x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-2.3.1
+ >=dev-libs/gmp-4.2.2
+ >=sys-libs/zlib-1.1.4
+ >=sys-libs/ncurses-5.2-r2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.875
+ >=sys-libs/glibc-2.8
+ >=sys-devel/binutils-2.15.94"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ # newly added zlib dir is processed by configure even with
+ # --with-systtem-zlib passed, causing toruble on multilib
+ rm -rf "${S}"/zlib
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ # The sed in makegpr.adb is actually not for the line length but rather to
+ # "undo" the fixing, Last3 is matching just that - the last three characters
+ # of the compiler name.
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}