summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-17 18:40:27 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-17 18:40:27 +0000
commitcbdf96059b8aaaf1e905b6cfd525e281120f5670 (patch)
treee2154ef08995f6fc123113ebe3c0272ce3f7e3ea /dev-lang
parentDrop KDE functionality as it stopped working. Simplify ebuild. Closes bug #22... (diff)
downloadgentoo-2-cbdf96059b8aaaf1e905b6cfd525e281120f5670.tar.gz
gentoo-2-cbdf96059b8aaaf1e905b6cfd525e281120f5670.tar.bz2
gentoo-2-cbdf96059b8aaaf1e905b6cfd525e281120f5670.zip
Move scons to DEPEND wrt #220441. Remove old versions and keyword ~amd64 for testing.
(Portage version: 2.1.5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/toluapp/ChangeLog10
-rw-r--r--dev-lang/toluapp/files/toluapp-1.0.2-gentoo.patch22
-rw-r--r--dev-lang/toluapp/toluapp-1.0.2.ebuild39
-rw-r--r--dev-lang/toluapp/toluapp-1.0.7_p1.ebuild40
-rw-r--r--dev-lang/toluapp/toluapp-1.0.92.ebuild9
5 files changed, 13 insertions, 107 deletions
diff --git a/dev-lang/toluapp/ChangeLog b/dev-lang/toluapp/ChangeLog
index 373f9d64e26e..20be9a724bbb 100644
--- a/dev-lang/toluapp/ChangeLog
+++ b/dev-lang/toluapp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/toluapp
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/toluapp/ChangeLog,v 1.16 2007/03/26 09:17:13 opfer Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/toluapp/ChangeLog,v 1.17 2008/05/17 18:40:27 drac Exp $
+
+ 17 May 2008; Samuli Suominen <drac@gentoo.org>
+ -files/toluapp-1.0.2-gentoo.patch, -toluapp-1.0.2.ebuild,
+ -toluapp-1.0.7_p1.ebuild, toluapp-1.0.92.ebuild:
+ Move scons to DEPEND wrt #220441. Remove old versions and keyword ~amd64
+ for testing.
26 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
toluapp-1.0.92.ebuild:
diff --git a/dev-lang/toluapp/files/toluapp-1.0.2-gentoo.patch b/dev-lang/toluapp/files/toluapp-1.0.2-gentoo.patch
deleted file mode 100644
index 35be06176d5c..000000000000
--- a/dev-lang/toluapp/files/toluapp-1.0.2-gentoo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur tolua++-1.0.2/config_linux.py tolua++/config_linux.py
---- tolua++-1.0.2/config_linux.py 2003-10-23 10:56:24.000000000 +0200
-+++ tolua++/config_linux.py 2004-05-09 15:48:57.414493136 +0200
-@@ -3,7 +3,6 @@
- # use 'scons -h' to see the list of command line options available
-
- # Compiler flags (based on Debian's installation of lua)
--CCFLAGS = ['-I/usr/include/lua50']
-
- # this is the default directory for installation. Files will be installed on
- # <prefix>/bin, <prefix>/lib and <prefix>/include when you run 'scons install'
-@@ -13,8 +12,8 @@
- #
- # You can see more 'generic' options for POSIX systems on config_posix.py
-
--prefix = '/usr/local'
-+prefix = '/usr'
-
- # libraries (based on Debian's installation of lua)
--LIBS = ['lua50', 'lualib50', 'dl', 'm']
-+LIBS = ['lua', 'lualib', 'dl', 'm']
-
diff --git a/dev-lang/toluapp/toluapp-1.0.2.ebuild b/dev-lang/toluapp/toluapp-1.0.2.ebuild
deleted file mode 100644
index 950f17339448..000000000000
--- a/dev-lang/toluapp/toluapp-1.0.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/toluapp/toluapp-1.0.2.ebuild,v 1.6 2005/04/24 12:36:15 hansmi Exp $
-
-inherit eutils toolchain-funcs
-
-MY_PN=${PN/toluapp/tolua++}
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="A tool to integrate C/C++ code with Lua."
-HOMEPAGE="http://www.codenix.com/~tolua/"
-SRC_URI="http://www.codenix.com/~tolua/${MY_P}.tar.bz2"
-KEYWORDS="x86 ppc"
-LICENSE="as-is"
-SLOT="0"
-IUSE=""
-S=${WORKDIR}/${MY_P}
-
-DEPEND=">=dev-lang/lua-5
- dev-util/scons
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/toluapp-1.0.2-gentoo.patch
-}
-
-src_compile() {
- scons CC="$(tc-getCC)" CCFLAGS="${CFLAGS}" LINK="$(tc-getCC)" all
-}
-
-src_install() {
- dobin bin/tolua++
- dolib.a lib/libtolua++.a
- insinto /usr/include
- doins include/tolua++.h
- dodoc INSTALL README
- dohtml doc/*
-}
diff --git a/dev-lang/toluapp/toluapp-1.0.7_p1.ebuild b/dev-lang/toluapp/toluapp-1.0.7_p1.ebuild
deleted file mode 100644
index 7818517b1f10..000000000000
--- a/dev-lang/toluapp/toluapp-1.0.7_p1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/toluapp/toluapp-1.0.7_p1.ebuild,v 1.1 2006/04/05 21:24:44 twp Exp $
-
-inherit eutils toolchain-funcs
-
-MY_PN=${PN/toluapp/tolua++}
-MY_PV=${PV/_p/-}
-MY_P=${MY_PN}_${MY_PV}
-DESCRIPTION="A tool to integrate C/C++ code with Lua."
-HOMEPAGE="http://www.codenix.com/~tolua/"
-SRC_URI="http://www.codenix.com/~tolua/${MY_P}.tar.gz"
-KEYWORDS="~x86 ~ppc"
-LICENSE="as-is"
-SLOT="0"
-IUSE=""
-S=${WORKDIR}/${MY_PN}-${PV/_*/}
-
-DEPEND=">=dev-lang/lua-5
- dev-util/scons
- >=sys-apps/sed-4"
-
-src_compile() {
- sed -i -e "s/lua50/lua/g" -e "s/lualib50/lualib/" ${S}/config_linux.py
- scons \
- CC=$(tc-getCC) \
- CCFLAGS="${CFLAGS}" \
- LINK=$(tc-getCC) \
- prefix=${D}/usr \
- install || die
-}
-
-src_install() {
- dobin bin/tolua++
- dolib.a lib/libtolua++.a
- insinto /usr/include
- doins include/tolua++.h
- dodoc INSTALL README
- dohtml doc/*
-}
diff --git a/dev-lang/toluapp/toluapp-1.0.92.ebuild b/dev-lang/toluapp/toluapp-1.0.92.ebuild
index 3de1f7a76984..6f2070d4111c 100644
--- a/dev-lang/toluapp/toluapp-1.0.92.ebuild
+++ b/dev-lang/toluapp/toluapp-1.0.92.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/toluapp/toluapp-1.0.92.ebuild,v 1.3 2007/03/26 09:17:13 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/toluapp/toluapp-1.0.92.ebuild,v 1.4 2008/05/17 18:40:27 drac Exp $
inherit eutils toolchain-funcs
@@ -9,13 +9,14 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="A tool to integrate C/C++ code with Lua."
HOMEPAGE="http://www.codenix.com/~tolua/"
SRC_URI="http://www.codenix.com/~tolua/${MY_P}.tar.bz2"
-KEYWORDS="ppc x86"
+KEYWORDS="~amd64 ppc x86"
LICENSE="as-is"
SLOT="0"
IUSE=""
S=${WORKDIR}/${MY_P}
-DEPEND=">=dev-lang/lua-5.1.1
+RDEPEND=">=dev-lang/lua-5.1.1"
+DEPEND="${RDEPEND}
dev-util/scons
>=sys-apps/sed-4"