summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-04-27 21:49:08 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-04-27 21:49:08 +0000
commitd1c02c062a4d99216a3596aa08fa76b810c09d97 (patch)
tree2ba272124b252471901ba5ffb527589e7670665d /dev-lang
parentFixing SHA256 digest, pass four (diff)
downloadgentoo-2-d1c02c062a4d99216a3596aa08fa76b810c09d97.tar.gz
gentoo-2-d1c02c062a4d99216a3596aa08fa76b810c09d97.tar.bz2
gentoo-2-d1c02c062a4d99216a3596aa08fa76b810c09d97.zip
New minor version and remove old unused patch
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog11
-rw-r--r--dev-lang/ghc/files/digest-ghc-6.4.26
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild268
3 files changed, 284 insertions, 1 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 3e032b1178d0..05a414c42700 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.96 2006/04/27 21:41:38 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.97 2006/04/27 21:49:08 dcoutts Exp $
+
+ 27 Apr 2006; Duncan Coutts <dcoutts@gentoo.org>
+ -files/ghc-6.4-powerpc.patch, +ghc-6.4.2.ebuild:
+ Remove old unused patch
+
+*ghc-6.4.2 (27 Apr 2006)
+
+ 27 Apr 2006; Duncan Coutts <dcoutts@gentoo.org> +ghc-6.4.2.ebuild:
+ New minor version
27 Apr 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r3.ebuild:
We dont need the java/fop stuff since were only building html docs
diff --git a/dev-lang/ghc/files/digest-ghc-6.4.2 b/dev-lang/ghc/files/digest-ghc-6.4.2
new file mode 100644
index 000000000000..2a258e9747fc
--- /dev/null
+++ b/dev-lang/ghc/files/digest-ghc-6.4.2
@@ -0,0 +1,6 @@
+MD5 a394bf14e94c3bca5507d568fcc03375 ghc-6.4.2-src.tar.bz2 6954958
+RMD160 19943eb2673e663973e64739cdf23720b6f36d38 ghc-6.4.2-src.tar.bz2 6954958
+SHA256 d517e52e0204a077c54cda11b67bf9b6ac3daa47ac7bccf1561afc7c572e6be0 ghc-6.4.2-src.tar.bz2 6954958
+MD5 6d97897b1f5cef7bf4bdc7fa6745d853 ghc-testsuite-6.4.2.tar.gz 1181389
+RMD160 1eea6a19a9fca6b3d56a6f29b69289cb88af8173 ghc-testsuite-6.4.2.tar.gz 1181389
+SHA256 1a864243e922c233049585fa3bf4a86a0ca3e7b3ffebf26245eb037f15dd4d12 ghc-testsuite-6.4.2.tar.gz 1181389
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
new file mode 100644
index 000000000000..0c55294235f8
--- /dev/null
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -0,0 +1,268 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.1 2006/04/27 21:49:08 dcoutts Exp $
+
+# Brief explanation of the bootstrap logic:
+#
+# ghc requires ghc-bin to bootstrap.
+# Therefore,
+# (1) both ghc-bin and ghc provide virtual/ghc
+# (2) virtual/ghc *must* default to ghc-bin
+# (3) ghc depends on virtual/ghc
+#
+# This solution has the advantage that the binary distribution
+# can be removed once an forall after the first succesful install
+# of ghc.
+
+inherit base eutils flag-o-matic autotools ghc-package check-reqs
+
+DESCRIPTION="The Glasgow Haskell Compiler"
+HOMEPAGE="http://www.haskell.org/ghc/"
+
+# discover if this is a snapshot release
+IS_SNAPSHOT="${PV%%*pre*}" # zero if snapshot
+MY_PV="${PV/_pre/.}"
+MY_P="${PN}-${MY_PV}"
+EXTRA_SRC_URI="${MY_PV}"
+[[ -z "${IS_SNAPSHOT}" ]] && EXTRA_SRC_URI="stable/dist"
+
+SRC_URI="http://www.haskell.org/ghc/dist/${EXTRA_SRC_URI}/${MY_P}-src.tar.bz2
+ test? ( http://haskell.org/ghc/dist/ghc-testsuite-${MY_PV}.tar.gz )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test doc X opengl openal"
+
+S="${WORKDIR}/${MY_P}"
+
+PROVIDE="virtual/ghc"
+
+RDEPEND="
+ >=sys-devel/gcc-2.95.3
+ >=dev-lang/perl-5.6.1
+ >=dev-libs/gmp-4.1
+ >=sys-libs/readline-4.2
+ X? ( || ( x11-libs/libX11 virtual/x11 ) )
+ opengl? ( virtual/opengl virtual/glu virtual/glut )
+ openal? ( media-libs/openal )"
+
+# ghc cannot usually be bootstrapped using later versions ...
+DEPEND="${RDEPEND}
+ <virtual/ghc-6.5
+ !>=virtual/ghc-6.6
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2
+ >=dev-haskell/haddock-0.6-r2 )"
+
+# TODO: this needs upgrading to 1.1.4
+PDEPEND=">=dev-haskell/cabal-1.1.3"
+
+# Portage's resolution of virtuals fails on virtual/ghc in some Portage releases,
+# the following function causes the build to fail with an informative error message
+# in such a case.
+# pkg_setup() {
+# if ! has_version virtual/ghc; then
+# eerror "This ebuild needs a version of GHC to bootstrap from."
+# eerror "Please emerge dev-lang/ghc-bin to get a binary version."
+# eerror "You can either use the binary version directly or emerge"
+# eerror "dev-lang/ghc afterwards."
+# die "virtual/ghc version required to build"
+# fi
+# }
+
+append-ghc-cflags() {
+ local flag compile assemble link
+ for flag in $*; do
+ case ${flag} in
+ compile) compile="yes";;
+ assemble) assemble="yes";;
+ link) link="yes";;
+ *)
+ [[ ${compile} ]] && GHC_CFLAGS="${GHC_CFLAGS} -optc${flag}"
+ [[ ${assemble} ]] && GHC_CFLAGS="${GHC_CFLAGS} -opta${flag}"
+ [[ ${link} ]] && GHC_CFLAGS="${GHC_CFLAGS} -optl${flag}";;
+ esac
+ done
+}
+
+ghc_setup_cflags() {
+ # We need to be very careful with the CFLAGS we ask ghc to pass through to
+ # gcc. There are plenty of flags which will make gcc produce output that
+ # breaks ghc in various ways. The main ones we want to pass through are
+ # -mcpu / -march flags. These are important for arches like alpha & sparc.
+ # We also use these CFLAGS for building the C parts of ghc, ie the rts.
+ strip-flags
+ strip-unsupported-flags
+ filter-flags -fPIC
+
+ GHC_CFLAGS=""
+ for flag in ${CFLAGS}; do
+ case ${flag} in
+
+ # Ignore extra optimisation (ghc passes -O to gcc anyway)
+ # -O2 and above break on too many systems
+ -O*) ;;
+
+ # Arch and ABI flags are probably ok
+ -m*) append-ghc-cflags compile assemble ${flag};;
+
+ # Debugging flags are also probably ok
+ -g*) append-ghc-cflags compile assemble ${flag};;
+
+ # Ignore all other flags, including all -f* flags
+ esac
+ done
+
+ # hardened-gcc needs to be disabled, because the mangler doesn't accept
+ # its output.
+ append-ghc-cflags compile link $(test-flags-CC -nopie)
+ append-ghc-cflags compile $(test-flags-CC -fno-stack-protector)
+
+ # We also add -Wa,--noexecstack to get ghc to generate .o files with
+ # non-exectable stack. This it a hack until ghc does it itself properly.
+ append-ghc-cflags assemble "-Wa,--noexecstack"
+}
+
+src_unpack() {
+ base_src_unpack
+ ghc_setup_cflags
+
+ # Modify the ghc driver script to use GHC_CFLAGS
+ echo "SCRIPT_SUBST_VARS += GHC_CFLAGS" >> "${S}/ghc/driver/ghc/Makefile"
+ echo "GHC_CFLAGS = ${GHC_CFLAGS}" >> "${S}/ghc/driver/ghc/Makefile"
+ sed -i -e 's|$TOPDIROPT|$TOPDIROPT $GHC_CFLAGS|' "${S}/ghc/driver/ghc/ghc.sh"
+
+ # If we're using the testsuite then move it to into the build tree
+ use test && mv "${WORKDIR}/testsuite" "${S}/"
+}
+
+src_compile() {
+ # initialize build.mk
+ echo '# Gentoo changes' > mk/build.mk
+
+ # We also need to use the GHC_CFLAGS flags when building ghc itself
+ echo "SRC_HC_OPTS+=${GHC_CFLAGS}" >> mk/build.mk
+ echo "SRC_CC_OPTS+=${CFLAGS} -Wa,--noexecstack" >> mk/build.mk
+
+ # If you need to do a quick build then enable this bit and add debug to IUSE
+ #if use debug; then
+ # echo "SRC_HC_OPTS = -H32m -O0" >> mk/build.mk
+ # echo "GhcStage1HcOpts =" >> mk/build.mk
+ # echo "GhcLibHcOpts =" >> mk/build.mk
+ # echo "GhcLibWays =" >> mk/build.mk
+ # echo "SplitObjs = NO" >> mk/build.mk
+ #fi
+
+ # determine what to do with documentation
+ if use doc; then
+ echo XMLDocWays="html" >> mk/build.mk
+ else
+ echo XMLDocWays="" >> mk/build.mk
+ # needed to prevent haddock from being called
+ echo NO_HADDOCK_DOCS=YES >> mk/build.mk
+ fi
+
+ # circumvent a very strange bug that seems related with ghc producing too much
+ # output while being filtered through tee (e.g. due to portage logging)
+ # reported as bug #111183
+ echo "SRC_HC_OPTS+=-fno-warn-deprecations" >> mk/build.mk
+
+ # force the config variable ArSupportsInput to be unset;
+ # ar in binutils >= 2.14.90.0.8-r1 seems to be classified
+ # incorrectly by the configure script
+ echo "ArSupportsInput:=" >> mk/build.mk
+
+ # Some arches do support some ghc features even though they're off by default
+ use ia64 && echo "GhcWithInterpreter=YES" >> mk/build.mk
+
+ # The SplitObjs feature makes 'ar'/'ranlib' take loads of RAM:
+ CHECKREQS_MEMORY="200"
+ if ! check_reqs_conditional; then
+ einfo "Turning off ghc's 'Split Objs' feature because this machine"
+ einfo "does not have enough RAM for it. This will have the effect"
+ einfo "of making binaries produced by ghc considerably larger."
+ echo "SplitObjs=NO" >> mk/build.mk
+ fi
+
+ econf \
+ $(use_enable opengl opengl) \
+ $(use_enable opengl glut) \
+ $(use_enable openal openal) \
+ $(use_enable X x11) \
+ $(use_enable X hgl) \
+ || die "econf failed"
+
+ emake all datadir="/usr/share/doc/${PF}" || die "make failed"
+ # the explicit datadir is required to make the haddock entries
+ # in the package.conf file point to the right place ...
+
+}
+
+src_install () {
+ local insttarget
+
+ insttarget="install"
+ use doc && insttarget="${insttarget} install-docs"
+
+ # the libdir0 setting is needed for amd64, and does not
+ # harm for other arches
+ emake -j1 ${insttarget} \
+ prefix="${D}/usr" \
+ datadir="${D}/usr/share/doc/${PF}" \
+ infodir="${D}/usr/share/info" \
+ mandir="${D}/usr/share/man" \
+ libdir0="${D}/usr/$(get_libdir)" \
+ || die "make ${insttarget} failed"
+
+ #need to remove ${D} from ghcprof script
+ # TODO: does this actually work?
+ cd "${D}/usr/bin"
+ mv ghcprof ghcprof-orig
+ sed -e 's:$FPTOOLS_TOP_ABS:#$FPTOOLS_TOP_ABS:' ghcprof-orig > ghcprof
+ chmod a+x ghcprof
+ rm -f ghcprof-orig
+
+ cd "${S}/ghc"
+ dodoc README ANNOUNCE LICENSE VERSION
+
+ dosbin ${FILESDIR}/ghc-updater
+}
+
+pkg_postinst () {
+ ebegin "Unregistering ghc's built-in cabal "
+ $(ghc-getghcpkg) unregister Cabal > /dev/null
+ eend $?
+ ghc-reregister
+ einfo "If you have dev-lang/ghc-bin installed, you might"
+ einfo "want to unmerge it. It is no longer needed."
+ einfo
+ ewarn "IMPORTANT:"
+ ewarn "If you have upgraded from another version of ghc or"
+ ewarn "if you have switched from ghc-bin to ghc, please run:"
+ ewarn " /usr/sbin/ghc-updater"
+ ewarn "to re-merge all ghc-based Haskell libraries."
+}
+
+src_test() {
+ if use test; then
+ local summary
+ summary="${TMP}/testsuite-summary.txt"
+
+ make -C "${S}/testsuite/" boot || die "Preparing the testsuite failed"
+ make -C "${S}/testsuite/tests/ghc-regress" \
+ TEST_HC="${S}/ghc/compiler/stage2/ghc-inplace" \
+ EXTRA_RUNTEST_OPTS="--output-summary=${summary}"
+
+ if grep -q ' 0 unexpected failures' "${summary}"; then
+ einfo "All tests passed ok"
+ else
+ ewarn "Some tests failed, for a summary see: ${summary}"
+ fi
+ else
+ ewarn "Sadly, due to some portage limitations you need both"
+ ewarn "USE=test and FEATURES=test to run the ghc testsuite"
+ fi
+}
+