summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-02-27 19:38:42 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-02-27 19:38:42 +0000
commitd6d2d7e0f024981338cb4fab1b12e5aef78ad767 (patch)
tree0413712ddf51c6821af6d743c81fc291ce1ceb6a /dev-lang
parentmove the filter-flags statement into src_compile (Manifest recommit) (diff)
downloadgentoo-2-d6d2d7e0f024981338cb4fab1b12e5aef78ad767.tar.gz
gentoo-2-d6d2d7e0f024981338cb4fab1b12e5aef78ad767.tar.bz2
gentoo-2-d6d2d7e0f024981338cb4fab1b12e5aef78ad767.zip
move the filter-flags statement into src_compile
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r1.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r2.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.06.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.07.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.07_beta2.ebuild5
7 files changed, 24 insertions, 13 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index c2b3757b04b7..b894e6d7529a 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.20 2004/02/17 22:04:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.21 2004/02/27 19:38:42 seemant Exp $
+
+ 27 Feb 2004; Seemant Kulleen <seemant@gentoo.org> ocaml-3.06-r1.ebuild,
+ ocaml-3.06-r2.ebuild, ocaml-3.06.ebuild, ocaml-3.07-r1.ebuild,
+ ocaml-3.07.ebuild, ocaml-3.07_beta2.ebuild:
+ move the filter-flags statement into src_compile
17 Feb 2004; Aron Griffis <agriffis@gentoo.org> ocaml-3.07-r1.ebuild:
add ~ia64
diff --git a/dev-lang/ocaml/ocaml-3.06-r1.ebuild b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
index 92aefa730102..6c85669d12bb 100644
--- a/dev-lang/ocaml/ocaml-3.06-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.5 2004/02/17 22:04:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.6 2004/02/27 19:38:42 seemant Exp $
inherit flag-o-matic eutils
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -18,6 +17,8 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tk-3.3.3 )"
src_compile() {
+ filter-flags "-fstack-protector"
+
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.06-r2.ebuild b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
index 5c04f8dc8275..f9d26e660435 100644
--- a/dev-lang/ocaml/ocaml-3.06-r2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.3 2004/02/03 00:08:33 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.4 2004/02/27 19:38:42 seemant Exp $
inherit flag-o-matic eutils
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -24,6 +23,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags "-fstack-protector"
+
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.06.ebuild b/dev-lang/ocaml/ocaml-3.06.ebuild
index f09c14cf0adc..a67cf644f78e 100644
--- a/dev-lang/ocaml/ocaml-3.06.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.10 2003/09/07 02:48:39 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.11 2004/02/27 19:38:42 seemant Exp $
inherit flag-o-matic
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -18,6 +17,8 @@ DEPEND="virtual/glibc
tcltk? ( >=dev-lang/tk-3.3.3 )"
src_compile() {
+filter-flags "-fstack-protector"
+
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index 52dec3581764..d5670acb1392 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.2 2004/02/17 22:04:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.3 2004/02/27 19:38:42 seemant Exp $
inherit flag-o-matic eutils
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -27,6 +26,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags "-fstack-protector"
+
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.07.ebuild b/dev-lang/ocaml/ocaml-3.07.ebuild
index 4ede1ea9972c..d8efa90b6af4 100644
--- a/dev-lang/ocaml/ocaml-3.07.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07.ebuild,v 1.2 2003/10/06 23:51:34 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07.ebuild,v 1.3 2004/02/27 19:38:42 seemant Exp $
inherit flag-o-matic eutils
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -25,6 +24,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags "-fstack-protector"
+
local myconf
use tcltk || myconf="-no-tk"
diff --git a/dev-lang/ocaml/ocaml-3.07_beta2.ebuild b/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
index 54754e7fb5bd..f2f24b8f08aa 100644
--- a/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07_beta2.ebuild,v 1.3 2004/01/02 19:48:24 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07_beta2.ebuild,v 1.4 2004/02/27 19:38:42 seemant Exp $
inherit flag-o-matic eutils
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -36,6 +35,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags "-fstack-protector"
+
local myconf
use tcltk || myconf="-no-tk"