summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-19 21:55:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-19 21:55:06 +0000
commitd90a4d90c64510ac47950c0030a7942b2994b3dc (patch)
tree55d0682937e406e50694c5772771623368cd13b6 /dev-lang
parentremove old (diff)
downloadgentoo-2-d90a4d90c64510ac47950c0030a7942b2994b3dc.tar.gz
gentoo-2-d90a4d90c64510ac47950c0030a7942b2994b3dc.tar.bz2
gentoo-2-d90a4d90c64510ac47950c0030a7942b2994b3dc.zip
remove old
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog5
-rw-r--r--dev-lang/ocaml/ocaml-3.11.0.ebuild128
2 files changed, 4 insertions, 129 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index beeb1daad43f..238ec46c29b2 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.165 2009/06/15 22:53:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.166 2009/06/19 21:55:06 aballier Exp $
+
+ 19 Jun 2009; Alexis Ballier <aballier@gentoo.org> -ocaml-3.11.0.ebuild:
+ remove old
*ocaml-3.11.1 (15 Jun 2009)
diff --git a/dev-lang/ocaml/ocaml-3.11.0.ebuild b/dev-lang/ocaml/ocaml-3.11.0.ebuild
deleted file mode 100644
index 0451f3516887..000000000000
--- a/dev-lang/ocaml/ocaml-3.11.0.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0.ebuild,v 1.4 2009/05/19 23:12:46 aballier Exp $
-
-EAPI="1"
-
-inherit flag-o-matic eutils multilib versionator toolchain-funcs
-
-MY_P="${P/_/+}"
-DESCRIPTION="Fast modern type-inferring functional programming language descended from the ML family"
-HOMEPAGE="http://www.ocaml.org/"
-SRC_URI="http://caml.inria.fr/pub/distrib/ocaml-$( get_version_component_range 1-2)/${MY_P}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="emacs gdbm latex ncurses +ocamlopt tk X xemacs"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
- ncurses? ( sys-libs/ncurses )
- X? ( x11-libs/libX11 x11-proto/xproto )
- gdbm? ( sys-libs/gdbm )"
-RDEPEND="${DEPEND}"
-
-PDEPEND="emacs? ( app-emacs/ocaml-mode )
- xemacs? ( app-xemacs/ocaml )"
-
-S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
- # results in relocations if gcc wants to create a PIE executable
- if gcc-specs-pie ; then
- append-ldflags -nopie
- ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
- ewarn "We have appended -nopie to ocaml build options"
- ewarn "because linking an executable with pie while the objects are not pic will not work"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix the EXEC_STACK in ocaml compiled binaries (#153382)
- epatch "${FILESDIR}"/${PN}-3.11.0_beta1-exec-stack-fixes.patch
-
- # The configure script doesn't inherit previous defined variables,
- # overwriting previous declarations of bytecccompopts, bytecclinkopts,
- # nativecccompopts and nativecclinkopts. Reported upstream as issue 0004267.
- epatch "${FILESDIR}"/${PN}-3.11.0_beta1-configure.patch
-
- # ocaml has automagics on libX11 and gdbm
- # http://caml.inria.fr/mantis/view.php?id=4278
- epatch "${FILESDIR}/${PN}-3.10.0-automagic.patch"
-
- # Respect LDFLAGS for ocamlyacc
- epatch "${FILESDIR}"/${PN}-3.11.0_beta1-yaccldflags.patch
-}
-
-src_compile() {
- export LC_ALL=C
- local myconf="--host ${CHOST}"
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- use tk || myconf="${myconf} -no-tk"
- use ncurses || myconf="${myconf} -no-curses"
- use X || myconf="${myconf} -no-graph"
- use gdbm || myconf="${myconf} -no-dbm"
-
- # ocaml uses a home-brewn configure script, preventing it to use econf.
- RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
- --with-pthread ${myconf} || die "configure failed!"
-
- make world || die "make world failed!"
-
- # Native code generation can be disabled now
- if use ocamlopt ; then
- make opt || die "make opt failed!"
- make opt.opt || die "make opt.opt failed!"
- fi
-}
-
-src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
- install || die "make install failed!"
-
- # Install the compiler libs
- dodir /usr/$(get_libdir)/ocaml/compiler-libs
- insinto /usr/$(get_libdir)/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo}
- use ocamlopt && doins {utils,typing,parsing}/*.{cmx,o}
-
- # Symlink the headers to the right place
- dodir /usr/include
- dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
-
- # Remove ${D} from ld.conf, as the buildsystem isn't $(DESTDIR) aware
- dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
-
- dodoc Changes INSTALL README Upgrading
-
- # Create and envd entry for latex input files (this definitely belongs into
- # CONTENT and not in pkg_postinst.
- if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
- doenvd "${T}"/99ocamldoc
- fi
-
- # Install ocaml-rebuild.sh script rather than keeping it in $PORTDIR
- dosbin "${FILESDIR}/ocaml-rebuild.sh"
-}
-
-pkg_postinst() {
- echo
- ewarn "OCaml is not binary compatible from version to version, so you"
- ewarn "need to rebuild all packages depending on it, that are actually"
- ewarn "installed on your system. To do so, you can run:"
- ewarn "/usr/sbin/ocaml-rebuild.sh [-h | emerge options]"
- ewarn "Which will call emerge on all old packages with the given options"
- echo
-}