summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-12-17 18:39:32 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-12-17 18:39:32 +0000
commitdb2c7c6815e39eb1aa9b4d8e74aa7322911d628e (patch)
treecd4e99a5200f40bb12692476d301237a5bc51c8f /dev-lang
parentamd64/ppc/ppc64/x86 stable wrt bug #494508; Drop old. (diff)
downloadgentoo-2-db2c7c6815e39eb1aa9b4d8e74aa7322911d628e.tar.gz
gentoo-2-db2c7c6815e39eb1aa9b4d8e74aa7322911d628e.tar.bz2
gentoo-2-db2c7c6815e39eb1aa9b4d8e74aa7322911d628e.zip
sync live ebuild
(Portage version: 2.2.7/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog5
-rw-r--r--dev-lang/go/go-9999.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index d28ddbffb2c9..dac655607a54 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.26 2013/12/16 12:12:11 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.27 2013/12/17 18:39:32 williamh Exp $
+
+ 17 Dec 2013; William Hubbs <williamh@gentoo.org> go-9999.ebuild:
+ sync live ebuild
16 Dec 2013; Naohiro Aota <naota@gentoo.org> go-1.2.ebuild:
Add ~x86-fbsd. #494418
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 27b4da91edd0..f720423686d5 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.12 2013/05/20 16:52:33 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.13 2013/12/17 18:39:32 williamh Exp $
EAPI=5
@@ -14,7 +14,7 @@ if [[ ${PV} = 9999 ]]; then
else
SRC_URI="http://go.googlecode.com/files/go${PV}.src.tar.gz"
# Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* ~amd64 ~arm ~x86"
+ KEYWORDS="-* ~amd64 ~arm ~x86 ~x86-fbsd"
fi
DESCRIPTION="A concurrent garbage collected and typesafe programming language"
@@ -24,14 +24,14 @@ LICENSE="BSD"
SLOT="0"
IUSE="bash-completion emacs vim-syntax zsh-completion"
-DEPEND="sys-apps/ed"
+DEPEND=""
RDEPEND="bash-completion? ( app-shells/bash-completion )
emacs? ( virtual/emacs )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
zsh-completion? ( app-shells/zsh-completion )"
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/linux.*/.*"
+QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
# The go language uses *.a files which are _NOT_ libraries and should not be
# stripped.
@@ -129,6 +129,11 @@ pkg_postinst()
find "${ROOT}"usr/lib/go -type f \
-exec touch -r "${ROOT}"${tref} {} \;
eend $?
+
+ if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
+ ${REPLACING_VERSIONS} != ${PV} ]]; then
+ elog "Release notes are located at http://golang.org/doc/go${PV}"
+ fi
}
pkg_postrm()