summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-14 15:54:38 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-14 15:54:38 +0000
commitf8c333db8e1aa014ae5d69616abb80373247c7e8 (patch)
tree780de04e854232ff570fcbe25bf21556182e8028 /dev-lang
parentVersion bump (diff)
downloadgentoo-2-f8c333db8e1aa014ae5d69616abb80373247c7e8.tar.gz
gentoo-2-f8c333db8e1aa014ae5d69616abb80373247c7e8.tar.bz2
gentoo-2-f8c333db8e1aa014ae5d69616abb80373247c7e8.zip
Add live ebuild, bug #266502 by Vladimir Dolzhenko <vladimir.dolzhenko@gmail.com>. Used modified ebuild by Mike Gilbert <floppymaster@gmail.com>.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog9
-rw-r--r--dev-lang/v8/v8-9999.ebuild85
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 044342f4ac0d..ab11184c2583 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.17 2010/12/10 17:08:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.18 2010/12/14 15:54:38 phajdan.jr Exp $
+
+*v8-9999 (14 Dec 2010)
+
+ 14 Dec 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> +v8-9999.ebuild:
+ Add live ebuild, bug #266502 by Vladimir Dolzhenko
+ <vladimir.dolzhenko@gmail.com>. Used modified ebuild by Mike Gilbert
+ <floppymaster@gmail.com>.
*v8-2.4.9.14 (10 Dec 2010)
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
new file mode 100644
index 000000000000..306e6f8e74df
--- /dev/null
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.1 2010/12/14 15:54:38 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib scons-utils subversion toolchain-funcs
+
+DESCRIPTION="Google's open source JavaScript engine"
+HOMEPAGE="http://code.google.com/p/v8"
+ESVN_REPO_URI="http://v8.googlecode.com/svn/trunk"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="readline"
+
+RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
+DEPEND="${RDEPEND}"
+
+EXTRA_ESCONS="library=shared importenv=\"LINKFLAGS\""
+
+pkg_setup() {
+ tc-export AR CC CXX RANLIB
+
+ # Make the build respect LDFLAGS.
+ export LINKFLAGS="${LDFLAGS}"
+}
+
+src_prepare() {
+ # Stop -Werror from breaking the build.
+ epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
+
+ # Respect the user's CFLAGS, including the optimization level.
+ epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+
+ # Remove a test that is known to fail:
+ # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
+ rm test/mjsunit/debug-script.js || die
+}
+
+src_configure() {
+ # GCC issues multiple warnings about strict-aliasing issues in v8 code.
+ append-flags -fno-strict-aliasing
+}
+
+src_compile() {
+ local myconf=""
+
+ # Use target arch detection logic from bug #296917.
+ local myarch="$ABI"
+ [[ $myarch = "" ]] && myarch="$ARCH"
+
+ if [[ $myarch = amd64 ]] ; then
+ myconf+=" arch=x64"
+ elif [[ $myarch = x86 ]] ; then
+ myconf+=" arch=ia32"
+ elif [[ $myarch = arm ]] ; then
+ myconf+=" arch=arm"
+ else
+ die "Failed to determine target arch, got '$myarch'."
+ fi
+
+ escons $(use_scons readline console readline dumb) ${myconf} . || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r include || die
+
+ dobin d8 || die
+ dolib libv8.so || die
+
+ dodoc AUTHORS ChangeLog || die
+}
+
+src_test() {
+ tools/test.py --no-build -p dots --shell d8 || die
+}
+
+pkg_postinst() {
+ einfo "The live ebuild does not use SONAME."
+ einfo "You must rebuild all packages depending on ${PN}"
+ einfo "to avoid ABI breakages."
+}