summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-10 11:01:05 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-10 11:01:05 +0000
commit7fea846a6b2d26455939bba3d2360817d7cc8910 (patch)
tree04360ddaf3944d25e70b6220bf8032f695b6f4b5 /dev-libs/DirectFB-extra
parentAdd fix by Martin Väth for building with gcc-4.3 #218542. (diff)
downloadgentoo-2-7fea846a6b2d26455939bba3d2360817d7cc8910.tar.gz
gentoo-2-7fea846a6b2d26455939bba3d2360817d7cc8910.tar.bz2
gentoo-2-7fea846a6b2d26455939bba3d2360817d7cc8910.zip
Version bump.
(Portage version: 2.2_pre5)
Diffstat (limited to 'dev-libs/DirectFB-extra')
-rw-r--r--dev-libs/DirectFB-extra/ChangeLog10
-rw-r--r--dev-libs/DirectFB-extra/DirectFB-extra-1.1.0.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-libs/DirectFB-extra/ChangeLog b/dev-libs/DirectFB-extra/ChangeLog
index cc24b7da9f72..0420e71b7e34 100644
--- a/dev-libs/DirectFB-extra/ChangeLog
+++ b/dev-libs/DirectFB-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/DirectFB-extra
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB-extra/ChangeLog,v 1.20 2007/12/02 22:29:43 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB-extra/ChangeLog,v 1.21 2008/05/10 11:01:05 vapier Exp $
+
+*DirectFB-extra-1.1.0 (10 May 2008)
+
+ 10 May 2008; Mike Frysinger <vapier@gentoo.org>
+ +DirectFB-extra-1.1.0.ebuild:
+ Version bump.
*DirectFB-extra-1.0.0-r1 (02 Dec 2007)
diff --git a/dev-libs/DirectFB-extra/DirectFB-extra-1.1.0.ebuild b/dev-libs/DirectFB-extra/DirectFB-extra-1.1.0.ebuild
new file mode 100644
index 000000000000..f1f21e53a81c
--- /dev/null
+++ b/dev-libs/DirectFB-extra/DirectFB-extra-1.1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB-extra/DirectFB-extra-1.1.0.ebuild,v 1.1 2008/05/10 11:01:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Extra image/video/font providers and graphics/input drivers for DirectFB"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://directfb.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="ffmpeg flash fusion imlib mmx mpeg quicktime svg xine zlib"
+
+RDEPEND="~dev-libs/DirectFB-1.1.1
+ ffmpeg? ( media-video/ffmpeg )
+ flash? ( media-libs/libflash )
+ fusion? ( dev-libs/linux-fusion )
+ imlib? ( media-libs/imlib2 )
+ mpeg? ( media-libs/libmpeg3 )
+ quicktime? ( virtual/quicktime )
+ svg? ( x11-libs/libsvg-cairo )
+ xine? ( media-libs/xine-lib )
+ zlib? ( sys-libs/zlib )"
+# avi? ( media-video/avifile )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.0-CFLAGS.patch
+}
+
+src_compile() {
+ # $(use_enable avi avifile)
+ econf \
+ $(use_enable ffmpeg) \
+ $(use_enable flash) \
+ $(use_enable fusion fusionsound) \
+ $(use_enable imlib imlib2) \
+ $(use_enable mmx) \
+ $(use_enable mpeg libmpeg3) \
+ $(use_enable quicktime openquicktime) \
+ $(use_enable svg) \
+ $(use_enable xine) \
+ $(use_enable zlib) \
+ --disable-avifile \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}