summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-04-16 22:04:38 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-04-16 22:04:38 +0000
commitfac033e2fe3445f52c9ea19b123edb7143fe8812 (patch)
treeb1456e559c04ee555003412fdb274c2cb423964d /dev-libs/apr-util/apr-util-0.9.12.ebuild
parentVersion bump (diff)
downloadgentoo-2-fac033e2fe3445f52c9ea19b123edb7143fe8812.tar.gz
gentoo-2-fac033e2fe3445f52c9ea19b123edb7143fe8812.tar.bz2
gentoo-2-fac033e2fe3445f52c9ea19b123edb7143fe8812.zip
Version bump
(Portage version: 2.1_pre6)
Diffstat (limited to 'dev-libs/apr-util/apr-util-0.9.12.ebuild')
-rw-r--r--dev-libs/apr-util/apr-util-0.9.12.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/apr-util/apr-util-0.9.12.ebuild b/dev-libs/apr-util/apr-util-0.9.12.ebuild
new file mode 100644
index 000000000000..d0a984f34730
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-0.9.12.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.12.ebuild,v 1.1 2006/04/16 22:04:38 vericgar Exp $
+
+inherit eutils
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb gdbm ldap"
+RESTRICT="test"
+
+DEPEND="dev-libs/expat
+ ~dev-libs/apr-0.9.7
+ berkdb? ( =sys-libs/db-4* )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )"
+
+src_compile() {
+
+ local myconf=""
+
+ use ldap && myconf="${myconf} --with-ldap"
+ myconf="${myconf} $(use_with gdbm)"
+
+ if use berkdb; then
+ if has_version '=sys-libs/db-4.3*'; then
+ myconf="${myconf} --with-dbm=db43
+ --with-berkeley-db=/usr/include/db4.3:/usr/$(get_libdir)"
+ elif has_version '=sys-libs/db-4.2*'; then
+ myconf="${myconf} --with-dbm=db42
+ --with-berkeley-db=/usr/include/db4.2:/usr/$(get_libdir)"
+ elif has_version '=sys-libs/db-4*'; then
+ myconf="${myconf} --with-dbm=db4
+ --with-berkeley-db=/usr/include/db4:/usr/$(get_libdir)"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf \
+ --datadir=/usr/share/apr-util-0 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" installbuilddir=/usr/share/apr-util-0/build install || die
+
+ #bogus values pointing at /var/tmp/portage
+ sed -i -e 's:APU_SOURCE_DIR=.*:APU_SOURCE_DIR=:g' ${D}/usr/bin/apu-config
+ sed -i -e 's:APU_BUILD_DIR=.*:APU_BUILD_DIR=/usr/share/apr-util-0/build:g' ${D}/usr/bin/apu-config
+
+ dodoc CHANGES NOTICE
+
+ # Will install as portage user when using userpriv. Fixing
+ chown -R root:0 ${D}/usr/include/apr-0/
+}