summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-06-11 22:07:59 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-06-11 22:07:59 +0000
commit454859857d474bdcf5061e6c5633f32e27f22849 (patch)
treeeda724418a612e020985bb8261205aa0fb43f2ec /dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
parentVersion bump #81634. (diff)
downloadgentoo-2-454859857d474bdcf5061e6c5633f32e27f22849.tar.gz
gentoo-2-454859857d474bdcf5061e6c5633f32e27f22849.tar.bz2
gentoo-2-454859857d474bdcf5061e6c5633f32e27f22849.zip
Fix g/bsd compatibility, bug 95468.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs/apr-util/apr-util-0.9.6-r2.ebuild')
-rw-r--r--dev-libs/apr-util/apr-util-0.9.6-r2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild b/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
index 6afc427b580d..e23b6fe11a3c 100644
--- a/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
+++ b/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild,v 1.1 2005/05/10 23:54:36 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-0.9.6-r2.ebuild,v 1.2 2005/06/11 22:07:59 kloeri Exp $
inherit eutils
@@ -36,13 +36,17 @@ src_compile() {
if use berkdb; then
if has_version '=sys-libs/db-4.2*'; then
- myconf="${myconf} --with-dbm=db42 --with-berkely-db=/usr"
+ myconf="${myconf} --with-dbm=db42
+ --with-berkeley-db=/usr/include/db4.2:/usr/$(get_libdir)"
elif has_version '=sys-libs/db-4*'; then
- myconf="${myconf} --with-dbm=db4 --with-berkely-db=/usr"
+ myconf="${myconf} --with-dbm=db4
+ --with-berkeley-db=/usr/include/db4:/usr/$(get_libdir)"
elif has_version '=sys-libs/db-3*'; then
- myconf="${myconf} --with-dbm=db3 --with-berkely-db=/usr"
+ myconf="${myconf} --with-dbm=db3
+ --with-berkeley-db=/usr/include/db3:/usr/$(get_libdir)"
elif has_version '=sys-libs/db-2'; then
- myconf="${myconf} --with-dbm=db2 --with-berkely-db=/usr"
+ myconf="${myconf} --with-dbm=db2
+ --with-berkely-db=/usr/include/db2:/usr/$(get_libdir)"
fi
fi
@@ -65,5 +69,5 @@ src_install() {
dodoc CHANGES NOTICE
# Will install as portage user when using userpriv. Fixing
- chown -R root:root ${D}/usr/include/apr-0/
+ chown -R root:0 ${D}/usr/include/apr-0/
}