summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-04-30 10:33:21 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-04-30 10:33:21 +0000
commit4b046f43ebb4a682ae6cd7849da42f59c8dff248 (patch)
tree77b9970d609164fcb35a3139374b0c8a1f4b6602 /dev-libs/apr
parentVersion bump. Remove old. (diff)
downloadgentoo-2-4b046f43ebb4a682ae6cd7849da42f59c8dff248.tar.gz
gentoo-2-4b046f43ebb4a682ae6cd7849da42f59c8dff248.tar.bz2
gentoo-2-4b046f43ebb4a682ae6cd7849da42f59c8dff248.zip
Version bump. Removed old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog10
-rw-r--r--dev-libs/apr/apr-1.4.8-r1.ebuild119
-rw-r--r--dev-libs/apr/apr-1.5.2.ebuild146
-rw-r--r--dev-libs/apr/files/apr-1.4.6-mint.patch27
4 files changed, 154 insertions, 148 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index b7ee0b277d59..474c6a7c82ca 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/apr
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.226 2014/11/15 20:45:08 polynomial-c Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.227 2015/04/30 10:33:20 polynomial-c Exp $
+
+*apr-1.5.2 (30 Apr 2015)
+
+ 30 Apr 2015; Lars Wendler <polynomial-c@gentoo.org> -apr-1.4.8-r1.ebuild,
+ +apr-1.5.2.ebuild, -files/apr-1.4.6-mint.patch:
+ Version bump. Removed old.
15 Nov 2014; Lars Wendler <polynomial-c@gentoo.org> apr-1.5.1-r1.ebuild:
Added kludge to fix compilation with >=libtool-2.4.3 until autotools.eclass
diff --git a/dev-libs/apr/apr-1.4.8-r1.ebuild b/dev-libs/apr/apr-1.4.8-r1.ebuild
deleted file mode 100644
index 2260a58a37fd..000000000000
--- a/dev-libs/apr/apr-1.4.8-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.4.8-r1.ebuild,v 1.14 2014/01/31 23:11:41 vapier Exp $
-
-EAPI="4"
-
-inherit autotools eutils libtool multilib toolchain-funcs
-
-DESCRIPTION="Apache Portable Runtime Library"
-HOMEPAGE="http://apr.apache.org/"
-SRC_URI="mirror://apache/apr/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc elibc_FreeBSD older-kernels-compatibility static-libs +urandom"
-
-RDEPEND="elibc_glibc? ( >=sys-apps/util-linux-2.16 )
- elibc_mintlib? ( >=sys-apps/util-linux-2.18 )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-DOCS=(CHANGES NOTICE README)
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.6-mint.patch
-
- # Ensure that system libtool is used.
- local g=
- [[ ${CHOST} == *-darwin* ]] && g=g
- sed -e 's:${installbuilddir}/libtool:'"${EPREFIX}/usr/bin/${g}libtool"':' -i apr-config.in || die "sed failed"
- sed -e 's:@LIBTOOL@:$(SHELL) '"${EPREFIX}/usr/bin/${g}libtool"':' -i build/apr_rules.mk.in || die "sed failed"
-
- # Apply user patches, bug #449048
- epatch_user
-
- AT_M4DIR="build" eautoreconf
- elibtoolize
-
- epatch "${FILESDIR}/config.layout.patch"
-}
-
-src_configure() {
- local myconf
-
- [[ ${CHOST} == *-mint* ]] && export ac_cv_func_poll=no
-
- if use older-kernels-compatibility; then
- local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
- export apr_cv_accept4="no"
- export apr_cv_dup3="no"
- export apr_cv_epoll_create1="no"
- export apr_cv_sock_cloexec="no"
- fi
- if tc-is-cross-compiler; then
- export apr_cv_tcp_nodelay_with_cork="yes"
- fi
-
- if use urandom; then
- myconf+=" --with-devrandom=/dev/urandom"
- elif (( ${CHOST#*-hpux11.} <= 11 )); then
- : # no /dev/*random on hpux11.11 and before, $PN detects this.
- else
- myconf+=" --with-devrandom=/dev/random"
- fi
-
- tc-is-static-only && myconf+=" --disable-dso"
-
- # shl_load does not search runpath, but hpux11 supports dlopen
- [[ ${CHOST} == *-hpux11* ]] && myconf="${myconf} --enable-dso=dlfcn"
-
- if [[ ${CHOST} == *-solaris2.10 ]]; then
- case $(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h) in
- *atomic_cas_ptr*) ;;
- *)
- elog "You do not have Solaris Patch ID "$(
- [[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885
- )" (Problem 4954703) installed on your host ($(hostname)),"
- elog "using generic atomic operations instead."
- myconf="${myconf} --disable-nonportable-atomics"
- ;;
- esac
- fi
-
- CONFIG_SHELL="${EPREFIX}"/bin/bash econf \
- --enable-layout=gentoo \
- --enable-nonportable-atomics \
- --enable-threads \
- ${myconf}
-
- rm -f libtool
-}
-
-src_compile() {
- emake
-
- if use doc; then
- emake dox
- fi
-}
-
-src_install() {
- default
-
- find "${ED}" -name "*.la" -exec rm -f {} +
-
- if use doc; then
- dohtml -r docs/dox/html/*
- fi
-
- if ! use static-libs; then
- find "${ED}" -name "*.a" -exec rm -f {} +
- fi
-
- # This file is only used on AIX systems, which Gentoo is not,
- # and causes collisions between the SLOTs, so remove it.
- # Even in Prefix, we don't need this on AIX.
- rm -f "${ED}usr/$(get_libdir)/apr.exp"
-}
diff --git a/dev-libs/apr/apr-1.5.2.ebuild b/dev-libs/apr/apr-1.5.2.ebuild
new file mode 100644
index 000000000000..875224d16b3f
--- /dev/null
+++ b/dev-libs/apr/apr-1.5.2.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.5.2.ebuild,v 1.1 2015/04/30 10:33:20 polynomial-c Exp $
+
+EAPI=5
+
+inherit autotools eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility static-libs +urandom"
+
+RDEPEND="elibc_glibc? ( >=sys-apps/util-linux-2.16 )
+ elibc_mintlib? ( >=sys-apps/util-linux-2.18 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.4.2
+ doc? ( app-doc/doxygen )"
+
+DOCS=(CHANGES NOTICE README)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.0-mint.patch
+ epatch "${FILESDIR}"/${PN}-1.5.0-libtool.patch
+ epatch "${FILESDIR}"/${PN}-1.5.0-cross-types.patch
+ epatch "${FILESDIR}"/${PN}-1.5.0-sysroot.patch #385775
+
+ epatch_user #449048
+
+ # kludge to fix compilation with >=libtool-2.4.3 until autotools.eclass
+ # got fixed (bug #527506)
+ _elibtoolize --install --copy --force
+
+ AT_M4DIR="build" eautoreconf
+ elibtoolize
+
+ epatch "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+ local myconf=()
+
+ [[ ${CHOST} == *-mint* ]] && export ac_cv_func_poll=no
+
+ if use older-kernels-compatibility; then
+ local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+ export apr_cv_accept4="no"
+ export apr_cv_dup3="no"
+ export apr_cv_epoll_create1="no"
+ export apr_cv_sock_cloexec="no"
+ fi
+ if tc-is-cross-compiler; then
+ # The apache project relies heavily on AC_TRY_RUN and doesn't
+ # have any sane cross-compiling fallback logic.
+ export \
+ ac_cv_file__dev_zero="yes" \
+ ac_cv_func_sem_open="yes" \
+ ac_cv_negative_eai="yes" \
+ ac_cv_o_nonblock_inherited="no" \
+ ac_cv_struct_rlimit="yes" \
+ ap_cv_atomic_builtins="yes" \
+ apr_cv_accept4="yes" \
+ apr_cv_dup3="yes" \
+ apr_cv_epoll="yes" \
+ apr_cv_epoll_create1="yes" \
+ apr_cv_gai_addrconfig="yes" \
+ apr_cv_mutex_recursive="yes" \
+ apr_cv_mutex_robust_shared="yes" \
+ apr_cv_process_shared_works="yes" \
+ apr_cv_pthreads_lib="-pthread" \
+ apr_cv_sock_cloexec="yes" \
+ apr_cv_tcp_nodelay_with_cork="yes"
+ fi
+
+ if use urandom; then
+ myconf+=( --with-devrandom=/dev/urandom )
+ elif (( ${CHOST#*-hpux11.} <= 11 )); then
+ : # no /dev/*random on hpux11.11 and before, $PN detects this.
+ else
+ myconf+=( --with-devrandom=/dev/random )
+ fi
+
+ tc-is-static-only && myconf+=( --disable-dso )
+
+ # shl_load does not search runpath, but hpux11 supports dlopen
+ [[ ${CHOST} == *-hpux11* ]] && myconf+=( --enable-dso=dlfcn )
+
+ if [[ ${CHOST} == *-solaris2.10 ]]; then
+ case $(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h) in
+ *atomic_cas_ptr*) ;;
+ *)
+ elog "You do not have Solaris Patch ID "$(
+ [[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885
+ )" (Problem 4954703) installed on your host ($(hostname)),"
+ elog "using generic atomic operations instead."
+ myconf+=( --disable-nonportable-atomics )
+ ;;
+ esac
+ fi
+
+ econf \
+ --enable-layout=gentoo \
+ --enable-nonportable-atomics \
+ --enable-posix-shm \
+ --enable-threads \
+ $(use_enable static-libs static) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ # This header is the same across targets, so use the build compiler.
+ emake tools/gen_test_char
+ tc-export_build_env BUILD_CC
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
+ tools/gen_test_char.c -o tools/gen_test_char || die
+ fi
+
+ emake
+
+ if use doc; then
+ emake dox
+ fi
+}
+
+src_install() {
+ default
+
+ # Prallel install breaks since apr-1.5.1
+ #make -j1 DESTDIR="${D}" install || die
+
+ prune_libtool_files --all
+
+ if use doc; then
+ dohtml -r docs/dox/html/*
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ # Even in Prefix, we don't need this on AIX.
+ rm -f "${ED}usr/$(get_libdir)/apr.exp"
+}
diff --git a/dev-libs/apr/files/apr-1.4.6-mint.patch b/dev-libs/apr/files/apr-1.4.6-mint.patch
deleted file mode 100644
index 43442da98834..000000000000
--- a/dev-libs/apr/files/apr-1.4.6-mint.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ur apr-1.2.11/build/apr_hints.m4 apr-1.2.11-mint/build/apr_hints.m4
---- apr-1.2.11/build/apr_hints.m4 Tue Jun 26 23:47:46 2007
-+++ apr-1.2.11-mint/build/apr_hints.m4 Tue Mar 25 12:00:14 2008
-@@ -44,8 +44,9 @@
-
- case "$host" in
- *mint)
-- APR_ADDTO(CPPFLAGS, [-DMINT])
-- APR_ADDTO(LIBS, [-lportlib])
-+ APR_ADDTO(CPPFLAGS, [-DMINT -D_GNU_SOURCE])
-+ apr_cv_pthreads_cflags="none"
-+ apr_cv_pthreads_lib="-lpthread"
- ;;
- *MPE/iX*)
- APR_ADDTO(CPPFLAGS, [-DMPE -D_POSIX_SOURCE -D_SOCKET_SOURCE])
-diff -ur apr-1.2.11/build/apr_threads.m4 apr-1.2.11-mint/build/apr_threads.m4
---- apr-1.2.11/build/apr_threads.m4 Thu Aug 3 11:05:26 2006
-+++ apr-1.2.11-mint/build/apr_threads.m4 Wed Mar 19 08:38:56 2008
-@@ -198,7 +198,7 @@
- AC_DEFUN(APR_CHECK_SIGWAIT_ONE_ARG,[
- AC_CACHE_CHECK(whether sigwait takes one argument,ac_cv_sigwait_one_arg,[
- AC_TRY_COMPILE([
--#if defined(__NETBSD__) || defined(DARWIN)
-+#if defined(__NETBSD__) || defined(DARWIN) || defined(MINT)
- /* When using the unproven-pthreads package, we need to pull in this
- * header to get a prototype for sigwait(). Else things will fail later
- * on. XXX Should probably be fixed in the unproven-pthreads package.