summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-02-18 09:13:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-02-18 09:13:22 +0000
commit4a0e967e65f1696b71d2674b9bd0c8c4b8663d6b (patch)
treea85f56b1cd7279b3b8bd7d99e18c6233ee4c7549 /dev-libs/beecrypt/beecrypt-4.2.1.ebuild
parentFix the revdep-rebuild thingie for good. Wrt bug#404105 (diff)
downloadgentoo-2-4a0e967e65f1696b71d2674b9bd0c8c4b8663d6b.tar.gz
gentoo-2-4a0e967e65f1696b71d2674b9bd0c8c4b8663d6b.tar.bz2
gentoo-2-4a0e967e65f1696b71d2674b9bd0c8c4b8663d6b.zip
Bump to eapi4 and add static-libs useflag.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/beecrypt/beecrypt-4.2.1.ebuild')
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1.ebuild34
1 files changed, 18 insertions, 16 deletions
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1.ebuild
index 4da8d4a5b8ae..aac0eba76958 100644
--- a/dev-libs/beecrypt/beecrypt-4.2.1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-4.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.2.1.ebuild,v 1.14 2011/11/13 18:46:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.2.1.ebuild,v 1.15 2012/02/18 09:13:22 scarabeus Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="python? 2"
inherit eutils multilib autotools java-pkg-opt-2 python
@@ -14,10 +14,10 @@ SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="java cxx python threads doc"
+IUSE="java cxx python static-libs threads doc"
COMMONDEPEND="!<app-arch/rpm-4.2.1
- threads? ( cxx? ( >=dev-libs/icu-2.8 ) )"
+ cxx? ( >=dev-libs/icu-2.8 )"
DEPEND="${COMMONDEPEND}
java? ( >=virtual/jdk-1.4 )
@@ -28,6 +28,10 @@ DEPEND="${COMMONDEPEND}
RDEPEND="${COMMONDEPEND}
java? ( >=virtual/jre-1.4 )"
+DOCS="BUGS README BENCHMARKS NEWS"
+
+REQUIRED_USE="cxx? ( threads )"
+
pkg_setup() {
use python && python_set_active_version 2
}
@@ -45,17 +49,17 @@ src_configure() {
# cpluscplus needs threads support
econf \
--disable-expert-mode \
+ $(use_enable static-libs static) \
$(use_enable threads) \
$(use_with python python "${EPREFIX}"/usr/bin/python2) \
- $(use threads && use_with cxx cplusplus || echo --without-cplusplus) \
+ $(use_with cxx cplusplus) \
$(use_with java)
}
src_compile() {
default
- if use doc
- then
+ if use doc; then
cd include/beecrypt
doxygen || die "doxygen failed"
fi
@@ -64,17 +68,15 @@ src_compile() {
src_test() {
export BEECRYPT_CONF_FILE="${T}/beecrypt-test.conf"
echo "provider.1=${S}/c++/provider/.libs/base.so" > "${BEECRYPT_CONF_FILE}"
- emake check || die "self test failed"
- emake bench || die "self benchmark test failed"
+ emake check
+ emake bench
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ default
rm -f "${ED}"/usr/$(get_libdir)/python*/site-packages/_bc.*a
- dodoc BUGS README BENCHMARKS NEWS || die "dodoc failed"
- if use doc
- then
- dohtml -r docs/html/. || die "dohtml failed"
- fi
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+
+ use doc && dohtml -r docs/html/.
}