summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-13 01:02:25 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-13 01:02:25 +0000
commit6b35965abdc614d097e9217da41388abd75be84f (patch)
tree980e04b32868fb68458cbc46a5e5392059dee9b5 /dev-libs/beecrypt
parentadd missing inputproto dep, bug #205548 (diff)
downloadgentoo-2-6b35965abdc614d097e9217da41388abd75be84f.tar.gz
gentoo-2-6b35965abdc614d097e9217da41388abd75be84f.tar.bz2
gentoo-2-6b35965abdc614d097e9217da41388abd75be84f.zip
Do not let the configure script decide the lib64. Make it respect the standard configure --libdir option.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-libs/beecrypt')
-rw-r--r--dev-libs/beecrypt/ChangeLog9
-rw-r--r--dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild8
-rw-r--r--dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild24
3 files changed, 25 insertions, 16 deletions
diff --git a/dev-libs/beecrypt/ChangeLog b/dev-libs/beecrypt/ChangeLog
index 1ae7ab2a9ec0..377896ca807d 100644
--- a/dev-libs/beecrypt/ChangeLog
+++ b/dev-libs/beecrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/beecrypt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.57 2007/06/02 07:34:14 alonbl Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/ChangeLog,v 1.58 2008/01/13 01:02:25 vapier Exp $
+
+ 13 Jan 2008; Mike Frysinger <vapier@gentoo.org> beecrypt-4.1.2-r1.ebuild,
+ beecrypt-4.1.2-r2.ebuild:
+ Do not let the configure script decide the lib64. Make it respect the
+ standard configure --libdir option.
02 Jun 2007; Alon Bar-Lev <alonbl@gentoo.org>
-files/beecrypt-3.1.0-alpha.patch, -files/beecrypt-3.1.0-athlon.diff,
diff --git a/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild b/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild
index 82427bd9363c..ec6416707f82 100644
--- a/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild,v 1.21 2007/06/02 03:18:38 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild,v 1.22 2008/01/13 01:02:25 vapier Exp $
inherit flag-o-matic eutils multilib autotools java-pkg-opt-2
@@ -32,6 +32,10 @@ src_unpack() {
# Set correct python libdir on multilib systems
sed -i -e 's:get_python_lib():get_python_lib(1,0):' \
configure.ac || die "sed failed"
+ # let configure figure out libpaths, not a pokey build system
+ sed -i \
+ -e '/^libaltdir=/s:=.*:=$(libdir):' \
+ $(find . -name Makefile.am) || die
# upstream patches from CVS
epatch "${FILESDIR}/${P}-python-Makefile-am.patch"
diff --git a/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild b/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild
index cc1f58a6fdb4..b287dc61c604 100644
--- a/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild
+++ b/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild,v 1.3 2007/02/07 19:47:17 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r2.ebuild,v 1.4 2008/01/13 01:02:25 vapier Exp $
inherit flag-o-matic eutils multilib autotools java-pkg-opt-2
@@ -20,7 +20,6 @@ DEPEND="${COMMONDEPEND}
java? ( >=virtual/jdk-1.4 )
doc? ( app-doc/doxygen
virtual/tetex )"
-
RDEPEND="${COMMONDEPEND}
java? ( >=virtual/jre-1.4 )"
@@ -34,15 +33,16 @@ src_unpack() {
# Set correct python libdir on multilib systems
sed -i -e 's:get_python_lib():get_python_lib(1,0):' \
configure.ac || die "sed failed"
-
- # upstream patches from CVS
- epatch "${FILESDIR}/${P}-python-Makefile-am.patch"
- epatch "${FILESDIR}/${P}-python-debug-py-c.patch"
- epatch "${FILESDIR}/${P}-build.patch"
- epatch "${FILESDIR}/${P}-gcc4.patch"
- epatch "${FILESDIR}/${P}-threads.patch"
- #Patch from Fedora rpm, Miloslav Trmac <mitr@redhat.com>
- epatch "${FILESDIR}/${P}-base64.patch"
+ # let configure figure out libpaths, not a pokey build system
+ sed -i \
+ -e '/^libaltdir=/s:=.*:=$(libdir):' \
+ $(find . -name Makefile.am) || die
+ epatch "${FILESDIR}"/${P}-python-Makefile-am.patch
+ epatch "${FILESDIR}"/${P}-python-debug-py-c.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-threads.patch
+ epatch "${FILESDIR}"/${P}-base64.patch
eautoreconf
}