summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-04-26 10:27:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-04-26 10:27:37 +0000
commit5f980c57eb486645513a2b0327c635ff3c6be57d (patch)
tree051c3b0b42a70ee3e637461dd6ea2df87018f3a5 /dev-libs/blitz/blitz-0.9-r1.ebuild
parentRemove old version (diff)
downloadgentoo-2-5f980c57eb486645513a2b0327c635ff3c6be57d.tar.gz
gentoo-2-5f980c57eb486645513a2b0327c635ff3c6be57d.tar.bz2
gentoo-2-5f980c57eb486645513a2b0327c635ff3c6be57d.zip
Removed icc flag, added a revision bump removing fortran stuff (not needed without the benchmarks), and examples building. Propagate user flags and cleanup. See bug #217317
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-libs/blitz/blitz-0.9-r1.ebuild')
-rw-r--r--dev-libs/blitz/blitz-0.9-r1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-libs/blitz/blitz-0.9-r1.ebuild b/dev-libs/blitz/blitz-0.9-r1.ebuild
index 143590c6ccf0..5144621f700d 100644
--- a/dev-libs/blitz/blitz-0.9-r1.ebuild
+++ b/dev-libs/blitz/blitz-0.9-r1.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.2 2008/04/01 15:48:32 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.3 2008/04/26 10:27:37 bicatali Exp $
inherit eutils toolchain-funcs fortran
DESCRIPTION="High-performance C++ numeric library"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.oonumerics.org/blitz"
-IUSE="debug doc examples icc"
+IUSE="debug doc examples"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
LICENSE="|| ( GPL-2 Blitz-Artistic )"
-DEPEND="icc? ( dev-lang/icc )
- doc? ( app-doc/doxygen )"
+DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
FORTAN="g77"
@@ -30,7 +29,7 @@ src_unpack() {
src_compile() {
local myconf
# ICC: if we've got it, use it
- use icc && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
+ [[ $(tc-getCXX) = ic*c ]] && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
export CC=$(tc-getCC) CXX=$(tc-getCXX)
econf \