summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2010-07-18 06:17:02 +0000
committerDaniel Black <dragonheart@gentoo.org>2010-07-18 06:17:02 +0000
commiteee3f0f1863cf75952513e1bf975b9dfe40e5628 (patch)
treedc70b04014d1196e7b3d4d765b27d5d2efed3e0c /dev-libs/blitz
parentfix homepage as per bug #325027. Thanks John Keeping (diff)
downloadgentoo-2-eee3f0f1863cf75952513e1bf975b9dfe40e5628.tar.gz
gentoo-2-eee3f0f1863cf75952513e1bf975b9dfe40e5628.tar.bz2
gentoo-2-eee3f0f1863cf75952513e1bf975b9dfe40e5628.zip
small cleanout
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/blitz')
-rw-r--r--dev-libs/blitz/ChangeLog6
-rw-r--r--dev-libs/blitz/blitz-0.9-r1.ebuild56
-rw-r--r--dev-libs/blitz/blitz-0.9-r2.ebuild61
3 files changed, 5 insertions, 118 deletions
diff --git a/dev-libs/blitz/ChangeLog b/dev-libs/blitz/ChangeLog
index 22ec50cfc5e9..8c77dd725ff2 100644
--- a/dev-libs/blitz/ChangeLog
+++ b/dev-libs/blitz/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/blitz
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.34 2010/06/25 13:21:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/ChangeLog,v 1.35 2010/07/18 06:17:02 dragonheart Exp $
+
+ 18 Jul 2010; Daniel Black <dragonheart@gentoo.org> -blitz-0.9-r1.ebuild,
+ -blitz-0.9-r2.ebuild:
+ small cleanout
25 Jun 2010; Justin Lecher <jlec@gentoo.org> blitz-0.9.ebuild,
blitz-0.9-r3.ebuild:
diff --git a/dev-libs/blitz/blitz-0.9-r1.ebuild b/dev-libs/blitz/blitz-0.9-r1.ebuild
deleted file mode 100644
index 5144621f700d..000000000000
--- a/dev-libs/blitz/blitz-0.9-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r1.ebuild,v 1.3 2008/04/26 10:27:37 bicatali Exp $
-
-inherit eutils toolchain-funcs fortran
-
-DESCRIPTION="High-performance C++ numeric library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.oonumerics.org/blitz"
-IUSE="debug doc examples"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="|| ( GPL-2 Blitz-Artistic )"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-FORTAN="g77"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e 's/blitz-uninstalled.pc//' \
- Makefile.in || die "sed failed"
- epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
-}
-
-src_compile() {
- local myconf
- # ICC: if we've got it, use it
- [[ $(tc-getCXX) = ic*c ]] && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
-
- export CC=$(tc-getCC) CXX=$(tc-getCXX)
- econf \
- --enable-shared \
- $(use_enable doc doxygen) \
- $(use_enable doc enable-html-docs) \
- $(use_enable debug) \
- ${myconf} || die "econf failed"
-}
-
-src_test() {
- make check-testsuite || die "selftest failed"
-}
-
-src_install () {
- dodir /usr/share/doc/${PF}/html
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF}/html install || die "emake install failed"
- dodoc ChangeLog ChangeLog.1 README README.binutils TODO AUTHORS NEWS
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.cpp
- fi
-}
diff --git a/dev-libs/blitz/blitz-0.9-r2.ebuild b/dev-libs/blitz/blitz-0.9-r2.ebuild
deleted file mode 100644
index e4b7e67c9dc1..000000000000
--- a/dev-libs/blitz/blitz-0.9-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9-r2.ebuild,v 1.2 2008/05/17 10:29:38 bicatali Exp $
-
-inherit eutils
-
-DESCRIPTION="High-performance C++ numeric library"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.oonumerics.org/blitz"
-IUSE="debug doc examples"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="|| ( GPL-2 Blitz-Artistic )"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # remove examples compiling
- sed -i \
- -e 's/blitz-uninstalled.pc//' \
- -e 's/examples//g' \
- Makefile.in || die "sed failed"
- epatch "${FILESDIR}"/${P}-gcc-4.3-missing-includes.patch
-}
-
-src_compile() {
- # blas and fortran are only useful for benchmarks
- econf \
- --enable-shared \
- --disable-cxx-flags-preset \
- --disable-fortran \
- --without-blas \
- $(use_enable doc doxygen) \
- $(use_enable doc html-docs) \
- $(use_enable debug) \
- || die "econf failed"
- emake lib || die "emake lib failed"
-}
-
-src_test() {
- # exprctor fails if BZ_DEBUG flag is not set
- # CXXFLAGS gets overwritten
- emake AM_CXXFLAGS="-DBZ_DEBUG" check-testsuite || die "selftest failed"
-}
-
-src_install () {
- dodir /usr/share/doc/${PF}/html
- emake \
- DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF}/html \
- install || die "emake install failed"
- dodoc ChangeLog ChangeLog.1 README README.binutils TODO AUTHORS NEWS
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.cpp
- fi
-}