summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-09-23 04:25:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-09-23 04:25:46 +0000
commit5c9c8888b5fa410a4fac5593a2d0725ef371799e (patch)
tree8da8c86c629d198c3e118745fd0de0ff52d17bc4 /dev-libs/boehm-gc/boehm-gc-6.6.ebuild
parentVersion bump, remove old version (diff)
downloadgentoo-2-5c9c8888b5fa410a4fac5593a2d0725ef371799e.tar.gz
gentoo-2-5c9c8888b5fa410a4fac5593a2d0725ef371799e.tar.bz2
gentoo-2-5c9c8888b5fa410a4fac5593a2d0725ef371799e.zip
Version bumped. Marked 6.5 as stable on x86.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-6.6.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-6.6.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-6.6.ebuild b/dev-libs/boehm-gc/boehm-gc-6.6.ebuild
new file mode 100644
index 000000000000..69534407df04
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-6.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-6.6.ebuild,v 1.1 2005/09/23 04:25:46 matsuu Exp $
+
+inherit eutils
+
+MY_P=gc${PV/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
+SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="nocxx threads"
+
+RDEPEND="virtual/libc"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e '/^SUBDIRS/s/doc//' Makefile.in || die
+ epatch ${FILESDIR}/${PN}-6.5-gentoo.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ if use nocxx ; then
+ myconf="${myconf} --disable-cplusplus"
+ else
+ myconf="${myconf} --enable-cplusplus"
+ fi
+
+ use threads || myconf="${myconf} --disable-threads"
+
+ econf ${myconf} || die "Configure failed..."
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # dist_noinst_HEADERS
+ insinto /usr/include/gc
+ doins include/{cord.h,ec.h,javaxfc.h}
+ insinto /usr/include/gc/private
+ doins include/private/*.h
+
+ dodoc README.QUICK doc/README* doc/barrett_diagram
+ dohtml doc/*.html
+ newman doc/gc.man GC_malloc.1
+}