summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-10-06 20:43:03 +0000
committerFabian Groffen <grobian@gentoo.org>2007-10-06 20:43:03 +0000
commit750b3705e2616bae17e1ca3b8ae09c28d4b33ab9 (patch)
tree91789bca2c7734699027baa74569dd8c9229286b /dev-libs/boost
parentAdd upstream patch to support +4GiB file sizes. Bug #142945 by Vadim. Add (diff)
downloadgentoo-2-750b3705e2616bae17e1ca3b8ae09c28d4b33ab9.tar.gz
gentoo-2-750b3705e2616bae17e1ca3b8ae09c28d4b33ab9.tar.bz2
gentoo-2-750b3705e2616bae17e1ca3b8ae09c28d4b33ab9.zip
Revert my changes made to this ebuild per a pending conflict with its maintainer. Prefix keeps these changes.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/boost-1.34.1.ebuild8
2 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index a99d4560880f..81e14359e94c 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.121 2007/08/31 10:34:24 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.122 2007/10/06 20:43:03 grobian Exp $
+
+ 06 Oct 2007; Fabian Groffen <grobian@gentoo.org> boost-1.34.1.ebuild:
+ Revert my changes made to this ebuild per a pending conflict with its
+ maintainer. Prefix keeps these changes.
31 Aug 2007; Fabian Groffen <grobian@gentoo.org> boost-1.34.1.ebuild:
change CHOST check from !=darwin to ==linux, see
diff --git a/dev-libs/boost/boost-1.34.1.ebuild b/dev-libs/boost/boost-1.34.1.ebuild
index 77fd1a230627..8d5b62ec6afa 100644
--- a/dev-libs/boost/boost-1.34.1.ebuild
+++ b/dev-libs/boost/boost-1.34.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1.ebuild,v 1.4 2007/08/31 10:34:24 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1.ebuild,v 1.5 2007/10/06 20:43:03 grobian Exp $
inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.boost.org/"
SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
LICENSE="freedist Boost-1.0"
SLOT="0"
-IUSE="debug doc icu pyste tools"
+IUSE="debug doc icu pyste tools userland_Darwin"
DEPEND="icu? ( >=dev-libs/icu-3.2 )
sys-libs/zlib
@@ -52,7 +52,7 @@ src_unpack() {
rm boost-build.jam
# This enables building the boost.random library with /dev/urandom support
- if [[ ${CHOST} == *-linux-* ]] ; then
+ if ! use userland_Darwin ; then
mkdir -p libs/random/build
cp "${FILESDIR}/random-Jamfile" libs/random/build/Jamfile.v2
fi
@@ -88,7 +88,7 @@ generate_userconfig() {
distutils_python_version
local compiler compilerVersion compilerExecutable
- if [[ ${CHOST} == *-darwin* ]] ; then
+ if use userland_Darwin ; then
compiler=darwin
compilerExecutable=c++
append-ldflags -ldl