summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-01 09:19:39 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-01 09:19:39 +0000
commit7fecf9b71ec17b04bc6a6d79a9002bdeb9ce30cd (patch)
treeed896cb3b4619727baa4b9dfccf2d5e11eaca88b /dev-libs/boost
parentKeyworded ~sparc-fbsd (diff)
downloadgentoo-2-7fecf9b71ec17b04bc6a6d79a9002bdeb9ce30cd.tar.gz
gentoo-2-7fecf9b71ec17b04bc6a6d79a9002bdeb9ce30cd.tar.bz2
gentoo-2-7fecf9b71ec17b04bc6a6d79a9002bdeb9ce30cd.zip
using userland_Darwin is a bad idea, use CHOST comparison instead
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.34.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/boost/boost-1.34.1.ebuild b/dev-libs/boost/boost-1.34.1.ebuild
index 0600a2aa575f..ca78af10cd70 100644
--- a/dev-libs/boost/boost-1.34.1.ebuild
+++ b/dev-libs/boost/boost-1.34.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1.ebuild,v 1.2 2007/07/29 14:20:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1.ebuild,v 1.3 2007/08/01 09:19:39 grobian Exp $
inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.boost.org/"
SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
LICENSE="freedist Boost-1.0"
SLOT="0"
-IUSE="debug doc icu pyste tools userland_Darwin"
+IUSE="debug doc icu pyste tools"
DEPEND="icu? ( >=dev-libs/icu-3.2 )
sys-libs/zlib
@@ -52,7 +52,7 @@ src_unpack() {
rm boost-build.jam
# This enables building the boost.random library with /dev/urandom support
- if ! use userland_Darwin ; then
+ if [[ ${CHOST} != *-darwin* ]] ; then
mkdir -p libs/random/build
cp "${FILESDIR}/random-Jamfile" libs/random/build/Jamfile.v2
fi
@@ -88,7 +88,7 @@ generate_userconfig() {
distutils_python_version
local compiler compilerVersion compilerExecutable
- if use userland_Darwin ; then
+ if [[ ${CHOST} == *-darwin* ]] ; then
compiler=darwin
compilerExecutable=c++
append-ldflags -ldl