summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-12-27 16:59:47 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-12-27 16:59:47 +0000
commite3f9290f9642beb34b8a0554d64a1885a6f87d77 (patch)
tree83c2d917154bc80ef4a539dab3d4145ba742d636 /dev-libs/boost
parentRemove obsolete entries from hardened/linux/amd64/no-multilib/package.mask (diff)
downloadgentoo-2-e3f9290f9642beb34b8a0554d64a1885a6f87d77.tar.gz
gentoo-2-e3f9290f9642beb34b8a0554d64a1885a6f87d77.tar.bz2
gentoo-2-e3f9290f9642beb34b8a0554d64a1885a6f87d77.zip
Properly disable all code, which depends on Boost.Context and remove all redundant headers, wrt bug #493116. Thanks to Mike Frysinger for discovering this issue. Drop old revisions
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog11
-rw-r--r--dev-libs/boost/boost-1.53.0-r1.ebuild (renamed from dev-libs/boost/boost-1.53.0.ebuild)6
-rw-r--r--dev-libs/boost/boost-1.54.0-r1.ebuild (renamed from dev-libs/boost/boost-1.54.0.ebuild)6
3 files changed, 18 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 77bdaa8b5c8e..0c70abfe4040 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.309 2013/12/14 19:45:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.310 2013/12/27 16:59:47 pinkbyte Exp $
+
+*boost-1.54.0-r1 (27 Dec 2013)
+*boost-1.53.0-r1 (27 Dec 2013)
+
+ 27 Dec 2013; Sergey Popov <pinkbyte@gentoo.org> -boost-1.53.0.ebuild,
+ +boost-1.53.0-r1.ebuild, -boost-1.54.0.ebuild, +boost-1.54.0-r1.ebuild:
+ Properly disable all code, which depends on Boost.Context and remove all
+ redundant headers, wrt bug #493116. Thanks to Mike Frysinger for discovering
+ this issue. Drop old revisions
14 Dec 2013; Agostino Sarubbo <ago@gentoo.org> boost-1.52.0-r6.ebuild:
Stable for sparc, wrt bug #455464
diff --git a/dev-libs/boost/boost-1.53.0.ebuild b/dev-libs/boost/boost-1.53.0-r1.ebuild
index 4101e5ac7fd3..0ea6abd85532 100644
--- a/dev-libs/boost/boost-1.53.0.ebuild
+++ b/dev-libs/boost/boost-1.53.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.53.0.ebuild,v 1.8 2013/11/14 09:47:42 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.53.0-r1.ebuild,v 1.1 2013/12/27 16:59:47 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -121,7 +121,8 @@ src_configure() {
use python || OPTIONS+=" --without-python"
use nls || OPTIONS+=" --without-locale"
- OPTIONS+=" pch=off --boost-build=${EPREFIX}/usr/share/boost-build --prefix=\"${ED}usr\" --layout=system threading=$(usex threads multi single) link=$(usex static-libs shared,static shared) --without-context"
+ OPTIONS+=" pch=off --boost-build=${EPREFIX}/usr/share/boost-build --prefix=\"${ED}usr\" --layout=system threading=$(usex threads multi single) link=$(usex static-libs shared,static shared)"
+ OPTIONS+=" --without-context"
[[ ${CHOST} == *-winnt* ]] && OPTIONS+=" -sNO_BZIP2=1"
}
@@ -253,6 +254,7 @@ EOF
fi
rm -r "${ED}"/usr/include/boost/context || die
+ rm -r "${ED}"/usr/include/boost/coroutine || die
if use doc; then
find libs/*/* -iname "test" -or -iname "src" | xargs rm -rf
diff --git a/dev-libs/boost/boost-1.54.0.ebuild b/dev-libs/boost/boost-1.54.0-r1.ebuild
index 446112bac6ad..79b629f3e227 100644
--- a/dev-libs/boost/boost-1.54.0.ebuild
+++ b/dev-libs/boost/boost-1.54.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0.ebuild,v 1.4 2013/11/14 09:47:42 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0-r1.ebuild,v 1.1 2013/12/27 16:59:47 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -121,7 +121,8 @@ src_configure() {
use python || OPTIONS+=" --without-python"
use nls || OPTIONS+=" --without-locale"
- OPTIONS+=" pch=off --boost-build=${EPREFIX}/usr/share/boost-build --prefix=\"${ED}usr\" --layout=system threading=$(usex threads multi single) link=$(usex static-libs shared,static shared) --without-context"
+ OPTIONS+=" pch=off --boost-build=${EPREFIX}/usr/share/boost-build --prefix=\"${ED}usr\" --layout=system threading=$(usex threads multi single) link=$(usex static-libs shared,static shared)"
+ OPTIONS+=" --without-context --without-coroutine"
[[ ${CHOST} == *-winnt* ]] && OPTIONS+=" -sNO_BZIP2=1"
}
@@ -253,6 +254,7 @@ EOF
fi
rm -r "${ED}"/usr/include/boost/context || die
+ rm -r "${ED}"/usr/include/boost/coroutine || die
if use doc; then
find libs/*/* -iname "test" -or -iname "src" | xargs rm -rf